X
Tap here to go to the mobile version of the site.

Support Forum

Thunderbird still in 12 hours time even if computer is 24 hours

  • No replies
  • 2 have this problem
  • 12 views
Posted

Mac OS X 10.14.6, TB 68.1.0

TB shows times in a 12h format, even if the computer is set on a 24h format.

It's been like that for a very, very long time. I would say, probably since I use started using Thunderbird, so many years. I always assumed it was TB unable to use locale, since that's a common problems with many software, except a friend, today, wondered why my TB was like that. Since this friend uses OSX too, we compared our settings.

OS X is set in Canadian French. We both have identical time settings, in a 24h format. Beside, my clock on the top right is 24h.

If I type 'locale' in the console, I get the following:

LANG="fr_CA.UTF-8" LC_COLLATE="fr_CA.UTF-8" LC_CTYPE="fr_CA.UTF-8" LC_MESSAGES="fr_CA.UTF-8" LC_MONETARY="fr_CA.UTF-8" LC_NUMERIC="fr_CA.UTF-8" LC_TIME="fr_CA.UTF-8" LC_ALL=

Important detail: friend have his TB in french too. Mine is in English (US).

If I go into Preferences, Advanced, it's set on "Regional settings locale: French (Canada)".

Weird thing is, date is fine, it shows 2019-09-17, which is the proper French Canada locale.

Because I like to be thorough, I went as far as installing French TB over my current TB. I got 24h time (and TB was in French). Then I downloaded a fresh copy of English TB, installed it, back to 12h time.

Any idea how to get 24h time on my TB? Thanks.

Mac OS X 10.14.6, TB 68.1.0 TB shows times in a 12h format, even if the computer is set on a 24h format. It's been like that for a very, very long time. I would say, probably since I use started using Thunderbird, so many years. I always assumed it was TB unable to use locale, since that's a common problems with many software, except a friend, today, wondered why my TB was like that. Since this friend uses OSX too, we compared our settings. OS X is set in Canadian French. We both have identical time settings, in a 24h format. Beside, my clock on the top right is 24h. If I type 'locale' in the console, I get the following: LANG="fr_CA.UTF-8" LC_COLLATE="fr_CA.UTF-8" LC_CTYPE="fr_CA.UTF-8" LC_MESSAGES="fr_CA.UTF-8" LC_MONETARY="fr_CA.UTF-8" LC_NUMERIC="fr_CA.UTF-8" LC_TIME="fr_CA.UTF-8" LC_ALL= Important detail: friend have his TB in french too. Mine is in English (US). If I go into Preferences, Advanced, it's set on "Regional settings locale: French (Canada)". Weird thing is, date is fine, it shows 2019-09-17, which is the proper French Canada locale. Because I like to be thorough, I went as far as installing French TB over my current TB. I got 24h time (and TB was in French). Then I downloaded a fresh copy of English TB, installed it, back to 12h time. Any idea how to get 24h time on my TB? Thanks.
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/77.0.3865.90 Safari/537.36

More Information

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.