Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox Bookmarks are Jumbled

more options

I am a very organized person and I expect my bookmarks to be neat and organized. I noticed yesterday that my bookmarks were all jumbled and out of place. My folders were no longer nested but all unorganized. Fortunately, I had a backup, so I restored it, only for it to get jumbled again. So, I signed out of all devices, selecting to delete everything. So, I imported my backup, and everything is fine. I logged back into Firefox on the computer that I imported the backup to, and again, everything was screwed up.

So, signed out again, chose the option to delete everything and restored the backup again. That is where I am right now. I am thinking something is corrupt with my account, but I do not know how to fix it. I was hoping that someone could help me. I have looked through the support documents, but I have yet to find one that helps me. I am running Windows 10 on four computers, Linux Mint on one and three Raspberry Pies with Raspbian. I also have two Android phones. I have had this setup for quite awhile with no problems until now.

All Replies (2)

more options

It could be that the data on your Firefox Account is not correct. This would involve removing your Firefox Sync data from your account and starting fresh. Then, when you load your backup (I assume it's a backup file), it should transfer to your Firefox Account.

There are a couple of simple ways to remove the data from your Firefox Account. You can reset your Firefox Account password or you can select the option to delete your data from the Firefox Sync servers when you Disconnect your Firefox Account from the Sync settings page in Firefox.

Hope this helps.

more options

I tried that already and it still did not work. I also tried resetting my account and it did not solve my problem either. As a matter of fact, I cannot even disconnect now. I click on the button to disconnect, then I select both boxes to delete both sets of data and then I am returned to the same account page where I am still connected.