Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Drop Down Navigation Menus Not Working

  • 14 replies
  • 4 have this problem
  • 141 views
  • Last reply by paul

more options

I've researched and tried just about everything I can to get drop down menus to work on a certain site...turned off hardware acceleration, tried loading the site in safe mode without any add-ons or themes, disabled all content blocking for the site, deleted all cookies and cache, reinstalled flash, etc etc etc. Nothing works. I have verified that the site functions properly using other browsers so I'm at a dead end now. Any help would be appreciated.

All Replies (14)

more options

Hello jamescarmour,

Would it be possible for you to give a link to (or the name of) the site in question ?

And maybe be a bit more specific about what happens when you click on those drop down menus ?

more options

Yeah I wasn't sure what the policy was as far as posting links. The site is www.golfsub70.com. Nothing happens when I hover over the button that should be a drop down...I can click it and it just takes me to the link for the main button (e.g. "Golf Clubs" from the menu)

more options

I need to click the three bar Menu button to open the drop-down list drop-down list that have an arrow next to it.


If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content.

  • click the shield icon for more details and possibly disable the protection

You can check the Web Console about what content is blocked


You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" from websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Modified by cor-el

more options

I see only two (little) drop down menus :

"Position" (on the left side) and "Show" (on the right side)

Are these the ones you are talking about  ?

They both open just fine for me, but I don't hover over them; I click on the little black arrow .....

more options

OK. My window wasn't width enough to show a real menu bar. With a wider window I get a menu bar with items (e.g. Golf Clubs) that opens on hover. My above posted suggestions would still apply.

Modified by cor-el

more options

I've tried all of those solutions. The drop downs don't work in safe mode and I've removed/cleared/refreshed everything else. No theme has been installed. No issues whatsoever in Chrome with all sorts of extensions running.

more options

Does the mobile version of the website work if you make the window smaller (<800px)?

I see that these menu items have a touchstart/touchend event, so maybe touch event support could be interfering.

You can try to modify these two prefs on the about:config page to see whether this has effect.

  • dom.w3c_touch_events.enabled = 0
  • layout.css.touch_action.enabled = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

more options

Since I saw cor-el's screenshots, I now know what drop down menus
you are talking about - doesn't work for me either.

(no content blocking, no add-ons etc..)

Changing the values of those preferences made no difference.

No error messages in the web console.

Tried the site in Edge : drop down menus work like a charm ....

more options

Really strange...not sure what would be causing those drop downs to not work. Thanks for the suggestions though.

more options

cor-el said

I see that these menu items have a touchstart/touchend event, so maybe touch event support could be interfering.

Yes !!! I have a touchscreen, and just now I thought about touching those tabs with a finger and : yay  ! Drop down menus open just fine ...

more options

McCoy said

cor-el said
I see that these menu items have a touchstart/touchend event, so maybe touch event support could be interfering.

Yes !!! I have a touchscreen, and just now I thought about touching those tabs with a finger and : yay  ! Drop down menus open just fine ...

Wow that does work! Crazy

more options

None of the suggestions that I have found make any difference. disabling all the add-ons, no acceleration, no themes, and it has been this way for a long time. chrome works and same with every other browser for drop downs. I'm thinking some sort of popup filter that is built in, as that is the kind of action and I have had messages on some sites saying to turn on javascript, but I have not disabled it.


I think it has been at least a year or so when this first started, it was shortly after the fix where none of the add-ons would work as they were disabled for everyone.

more options

@ paul :

Does this happen on the same site ? (see the OP's link)

Do you have a touchscreen ? (see what solved the OP's problem)

If not, maybe you could start your own thread using this link :

https://support.mozilla.org/en-US/questions/new/desktop/other

(you'll have to scroll down to the bottom of that page)

more options

sony vaio touch pad, not touch screen. ALL websites affected.