X
Tap here to go to the mobile version of the site.

Support Forum

Automatically stop "A web page is slowing down your browser"

ral
Posted

I don't care [to take the time to find out] what's causing it; I just want to stop it. I always click "Stop it". Now I just want to avoid ever seeing it, or it would be ok to see the message for a second or so but then have FF click "Stop it".

Thank you

I don't care [to take the time to find out] what's causing it; I just want to stop it. I always click "Stop it". Now I just want to avoid ever seeing it, or it would be ok to see the message for a second or so but then have FF click "Stop it". Thank you
Quote

Additional System Details

Installed Plug-ins

OpenH264 Video Codec provided by Cisco Systems, Inc. Widevine Content Decryption Module provided by Google Inc. [Extension] Video DownloadHelper

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:69.0) Gecko/20100101 Firefox/69.0

More Information

FredMcD
  • Top 10 Contributor
4272 solutions 59923 answers

”Webpage is slowing down your browser” This is the new way the browser tells you there is a problem with the script program(s). https://support.mozilla.org/en-US/kb/warning-unresponsive-script?cache=no

”Webpage is slowing down your browser” This is the new way the browser tells you there is a problem with the script program(s). https://support.mozilla.org/en-US/kb/warning-unresponsive-script?cache=no
Was this helpful to you? 0
Quote

Question owner

FredMcD said

”Webpage is slowing down your browser” This is the new way the browser tells you there is a problem with the script program(s). https://support.mozilla.org/en-US/kb/warning-unresponsive-script?cache=no

I knew that. As I said, I just want to stop it. The webpage you cite doesn't begin to address my issue. Thanks anyway.

''FredMcD [[#answer-1252190|said]]'' <blockquote> ”Webpage is slowing down your browser” This is the new way the browser tells you there is a problem with the script program(s). https://support.mozilla.org/en-US/kb/warning-unresponsive-script?cache=no </blockquote> I knew that. As I said, I just want to stop it. The webpage you cite doesn't begin to address my issue. Thanks anyway.

Modified by ral

Was this helpful to you? 0
Quote
McCoy
  • Top 10 Contributor
546 solutions 5143 answers

Hello ral,

Would you try this please :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar dom.ipc.process

and look for the preference dom.ipc.processHangMonitor

Set its value to false

Then type in the search bar and look for the preference :

dom.ipc.reportProcessHangs

and set its value also to false

Then close and restart Firefox.

Shouldn't that help you to get rid of the nuisance; then change the values back.

I hope it does the trick though ....

Hello ral, Would you try this please : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar '''dom.ipc.process''' and look for the preference '''dom.ipc.processHangMonitor''' Set its value to '''false''' Then type in the search bar and look for the preference : '''dom.ipc.reportProcessHangs''' and set its value also to '''false''' Then close and restart Firefox. Shouldn't that help you to get rid of the nuisance; then change the values back. I hope it does the trick though ....
Was this helpful to you? 1
Quote

Question owner

McCoy said

Hello ral, Would you try this please : Type in the address bar about:config and press Enter (promise to be careful, if asked) Type in the search bar dom.ipc.process and look for the preference dom.ipc.processHangMonitor Set its value to false Then type in the search bar and look for the preference : dom.ipc.reportProcessHangs and set its value also to false Then close and restart Firefox. Shouldn't that help you to get rid of the nuisance; then change the values back. I hope it does the trick though ....

Thank you McCoy! It looks right and I'm going to mark "solved". If it does work, I'll never know.

''McCoy [[#answer-1252443|said]]'' <blockquote> Hello ral, Would you try this please : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar '''dom.ipc.process''' and look for the preference '''dom.ipc.processHangMonitor''' Set its value to '''false''' Then type in the search bar and look for the preference : '''dom.ipc.reportProcessHangs''' and set its value also to '''false''' Then close and restart Firefox. Shouldn't that help you to get rid of the nuisance; then change the values back. I hope it does the trick though .... </blockquote> Thank you McCoy! It looks right and I'm going to mark "solved". If it does work, I'll never know.
Was this helpful to you? 0
Quote
McCoy
  • Top 10 Contributor
546 solutions 5143 answers

ral said

Thank you McCoy! It looks right and I'm going to mark "solved".

My pleasure !

If it does work, I'll never know.

Well, if you never see that banner again ......

''ral [[#answer-1253200|said]]'' <blockquote> Thank you McCoy! It looks right and I'm going to mark "solved". </blockquote> My pleasure ! <blockquote> If it does work, I'll never know. </blockquote> Well, if you never see that banner again ......
Was this helpful to you? 0
Quote

Question owner

Well, it stopped the "A web page is slowing down your browser" message, but now I'm back to the "A script on this page has stopped working" message. In either case I am stopped from proceeding until I click on something. So I still have essentially the same problem. The next time it happens I will note the exact wording and probably post a new question. I guess this is progress, so

Thank you very much, Robert Leeper

Well, it stopped the "A web page is slowing down your browser" message, but now I'm back to the "A script on this page has stopped working" message. In either case I am stopped from proceeding until I click on something. So I still have essentially the same problem. The next time it happens I will note the exact wording and probably post a new question. I guess this is progress, so Thank you very much, Robert Leeper
Was this helpful to you? 0
Quote
McCoy
  • Top 10 Contributor
546 solutions 5143 answers

Would you please (for now) disable your Video DownloadHelper extension, to see if that will make a difference ?

If that's not it; would you try this on the "about:config" page and type in the search bar :

dom.max_script_run_time and change its value to 30

then close and restart Firefox.

Any luck ?

Would you please (for now) disable your Video DownloadHelper extension, to see if that will make a difference ? If that's not it; would you try this on the "about:config" page and type in the search bar : '''dom.max_script_run_time''' and change its value to '''30''' then close and restart Firefox. Any luck ?
Was this helpful to you? 1
Quote

Question owner

Thank you very much, McCoy. I will try it/them.

For testing purposes it would be extremely useful to have a page that is known to have a script that stalls frequently. Do you know of such?

Thanks again. Robert

Thank you very much, McCoy. I will try it/them. For testing purposes it would be extremely useful to have a page that is known to have a script that stalls frequently. Do you know of such? Thanks again. Robert
Was this helpful to you? 0
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17588 solutions 159105 answers

Note that it is probably not a good idea to disable the hang monitor (dom.ipc.processHangMonitor = false). This includes hangs in the plugin-container process used by Flash to control what happens if the plugin doesn't respond (IPC=Inter-Process Communication). If you disable all hangs then you can block Firefox and would have to kill the process or wait a long time.

You can read the comments in the Firefox source code.

Note that it is probably not a good idea to disable the hang monitor (dom.ipc.processHangMonitor = false). This includes hangs in the plugin-container process used by Flash to control what happens if the plugin doesn't respond (IPC=Inter-Process Communication). If you disable all hangs then you can block Firefox and would have to kill the process or wait a long time. You can read the comments in the Firefox source code. *https://dxr.mozilla.org/mozilla-release/source/browser/modules/ProcessHangMonitor.jsm
Was this helpful to you?
Quote
djonesgm 0 solutions 1 answers

https://www.westernjournal.com/eagle-eyed-nunes-finds-loophole-clause-allows-gop-call-witnesses/?ff_source=Email&ff_medium=newsletter-CT&ff_campaign=dailypm&ff_content=conservative-tribune

This is a typical page from the Western Journal website which produces the "slowing down" message. As far as I can tell, every Western Journal site page does this same thing.

I don't want to follow previous suggestions about modifying FF to handle a problem that seems confined to this website.

I do not have problems viewing this website in other browsers, so the hangup is unique to something in FF.

Please investigate whatever it is in FF that clashes with these Western Journal pages and either change the FF trigger or come ujp with an EFFECTIVE solution in FF... Stop or Wait are useless, since neither deals with the false problem.

https://www.westernjournal.com/eagle-eyed-nunes-finds-loophole-clause-allows-gop-call-witnesses/?ff_source=Email&ff_medium=newsletter-CT&ff_campaign=dailypm&ff_content=conservative-tribune This is a typical page from the Western Journal website which produces the "slowing down" message. As far as I can tell, every Western Journal site page does this same thing. I don't want to follow previous suggestions about modifying FF to handle a problem that seems confined to this website. I do not have problems viewing this website in other browsers, so the hangup is unique to something in FF. Please investigate whatever it is in FF that clashes with these Western Journal pages and either change the FF trigger or come ujp with an EFFECTIVE solution in FF... Stop or Wait are useless, since neither deals with the false problem.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.