Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox doesn't block websites specifically blacklisted by MacOS parental controls

  • 6 replies
  • 2 have this problem
  • 5 views
  • Last reply by Ryan

more options

I have a specific list of websites that I would like to block access to on an account but these sites are not being blocked properly.

On the MacOS parental controls, there are three options: Allow unrestricted access, Try to limit access to adult websites, and Allow access to only these websites (see screenshot #1)

I chose the "Try to limit access to adult websites" option and found that Firefox does not block the same sites that Safari does. Attempting to solve this issue, I added specific sites to the blacklist in the Customize section (see screenshot #2). But this still did not solve the issue - sites listed on the blacklist are still perfectly accessible in Firefox.

Am I doing something wrong here? I read the Firefox article on restricting content (https://support.mozilla.org/en-US/kb/block-and-unblock-websites-parental-controls-firef?redirectlocale=en-US&redirectslug=Parental+controls) but that wasn't helpful for my situation.

Attached screenshots

All Replies (6)

more options

Hi Ryan, I noticed that the link in your post is in regard to Win 10. Almost all of the Firefox articles are customizable for different operating systems in the gray box on the left.

Take a look at that same article customized for Mac: https://support.mozilla.org/en-US/kb/block-and-unblock-websites-parental-controls-firef#firefox:mac:fx69

and see if it helps your situation.

more options

Thanks My_Cheese, but Firefox automatically supplies the correct operating system article when I visit the page. It does not offer any information for my use case.

more options

If you want to double-check that Firefox is configured properly -

Type or paste about:config in the address bar and press enter. Select: I accept the Risk! In the search bar at the top, type or paste

security.family_safety.mode

Check the value in the Value column:

0 - disables the feature entirely 1 - enables detection of Family Safety mode but doesn't import the root 2 - enables detection and imports the root

It should be set to 2

more options

OK, it is set to 2

more options

The only thing else that I can suggest is that you double-check the

Parental controls on Mac https://support.apple.com/guide/mac-help/set-up-parental-controls-mtusr004/mac

and I'll try to escalate your issue here on this end.

more options

OK, thank you for your help. I've double checked the settings and they correspond as laid out in the article. Everything works as intended on Safari, but not so on Firefox.