Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Min and max buttons are not available on extensions windows

  • 11 replies
  • 1 has this problem
  • 13 views
  • Last reply by cor-el

more options

Min and max buttons are not available on extensions windows, beside that those windows are always on top (only of Firefox itself, not in other windows), so I can not continue using Firefox when one window is open. My specific case is that I need to use "Katalon recorder" extension, but i can't, since I need to move the windows around to record my moves on any page, which makes it really annoying. Is there any workaround for this?? (I am on linux deepin 15.11 and Firefox nightly 71.0a1 (2019-09-09))

Attached screenshots

All Replies (11)

more options

Hi guepardomar, it seems very dysfunctional if the popup is modal and blocks access to Firefox. Could there be an extension setting to change that? You might check their documentation and forum to see whether this is a known issue.

more options

Thanks jscher2000 for your quick reply. Unfortunately, this happens to me with every single add-on that is capable to open a windows as I show in this image attached. I've been searching on the links you've provided, for long time, and I've been using chrome because I need to use that extension for my work, but I'm tired already of using chrome (just because I like Firefox), and looking around the web I've found a solution to other issue tweaking the about:config (touch gestures didn't work either) but can't find anything about this. By the way, I would like to add that in the past I've been using a lot of Linux distros, until I landed on Deepin that is the one I liked the most, and only (as far as I can remember) on a distro that uses a KDE desktop worked well (as well as Microsoft windows before I replace it with Linux). Sorry for the long reply, but I wanted to add as many details as possible, since I'm desperate already. Greatly appreciate any help.

more options

With that happening with 3 different extensions, I wonder if that is a new "feature" in Nightly Fx71??

more options

I can't think of any extensions I have installed that create sticky dialog windows like that. But I digress.

Does this preference make any difference:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste panel and pause while the list is filtered

(3) Double-click the ui.panel.default_level_parent preference to switch the value from false to true (or true to false, if yours is opposite mine)

more options

the-edmeister said

With that happening with 3 different extensions, I wonder if that is a new "feature" in Nightly Fx71??

That's a good point, because the screenshots for Pushbullet on the Add-ons site show the drop-down panel style: https://addons.mozilla.org/firefox/addon/pushbullet/

more options

jscher2000, I did as you suggested and didn't work. ui.panel.default_level_parent was set to true, change it to false, restart the browser, even the pc. By the way I opened the pushbullet add-on on a window just to show that this happens on any extension, because by default is drop-down panel, but it has an option (as showed on the image attached)

more options

When extensions create a new window, they have four types to choose from:

  • "normal"
  • "popup"
  • "panel"
  • "detached_panel"

Only the "normal" type has the standard window features. I don't think most authors use that style.

more options

the-edmeister said

With that happening with 3 different extensions, I wonder if that is a new "feature" in Nightly Fx71??

No, is not, I have had this issue for more that a year already, and I started with the "normal" version of Firefox, moved to developer version version and now to nightly, and the very same thing.

jscher2000 said

When extensions create a new window, they have four types to choose from:
  • "normal"
  • "popup"
  • "panel"
  • "detached_panel"
Only the "normal" type has the standard window features. I don't think most authors use that style.

Well, don't know which one the authors use, if I can tweak that on about:config, I would like. And don't think they use a different configuration for different OS, but in windows (using my VM) it works as it should as you can see in image attached.

more options

Hi guepardomar, I am not familiar with Linux popups. Since you have been seeing this for over a year, it may be that there is something different about your shell that hasn't been reported before. Perhaps you could file a new bug reporting this difference and see whether the developers can change the behavior to be more consistent with other platforms, or not.

https://bugzilla.mozilla.org/

more options

thanks for the help jscher2000, I did as you suggested, hope they can fix it.

more options

There is an "Always on Top" item in the system menu (right-click the title bar; Alt+Space), but that doesn't have a checkmark and either state keeps the window on top if I switch to another tab. Minimize and maximize are disabled as well, only move and resize are active and I can move the window to another workspace to have it out of view..