Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why can't I email a web page when I click on the 'envelope' "Email a link to this page" button?

  • 7 replies
  • 1 has this problem
  • 59 views
  • Last reply by RobertJ

more options

I frequently use the "Email a link to this page" feature. I'm running Waterfox 56.2.13 (64-bit), and my email is via Thunderbird 69.0b4. When I click on the email page button, an hourglass activity icon flashes for a few seconds, but a new message form with the page URL isn't generated. This is a very recent problem. Please help. TIA

Chosen solution

Thank you for taking the time to let us know.

Browse Safe!

Read this answer in context 👍 1

All Replies (7)

more options

Hi Bruce Wheeler, I'm not familiar with Waterfox. It isn't a Mozilla product. Here's the subReddit which they use for their Support Forum: https://www.reddit.com/r/waterfox/

more options

Thanks for your suggestion. When I click on Waterfox Help it takes me here:

https://support.mozilla.org/en-US/products/firefox?as=u&utm_source=inproduct

Looks Mozilla to me... Anyway, FWIW, I reinstalled both Waterfox - newest V, and Thunderbird - no difference in my problem

more options

OK Select Menu -> Options On the General page, under Applications Set mailto to Always Ask

When you use the Email Link a Launch Application dialog will open. Select the mail application that you wish to use.

Any difference?

more options

I did it, no change. I click on the email the page button, the hourglass shows up, and that's it.

more options

It could be a problem in your Profile. Try creating a new 'Test Profile' to see if the problem persists there.

Otherwise, you may need to do a Refresh.

more options

Followup: it was a Thunderbird problem. Latest version fixed the problem. Thnx for your help.

more options

Chosen Solution

Thank you for taking the time to let us know.

Browse Safe!