Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

One webpage times out instead of loading

  • 3 replies
  • 1 has this problem
  • Last reply by RobertJ

more options

I cleared out my History, Form, cookies, and cache a week ago and ever since I have one webpage, and ONLY one, that simply keeps giving me this error:

The connection has timed out

The server at is taking too long to respond.

   The site could be temporarily unavailable or too busy. Try again in a few moments.
   If you are unable to load any pages, check your computer’s network connection.
   If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

Now, the site simply can't be temporarily unavailable for over a week, especially since I have no trouble opening and logging into it using the Chrome browser on my tablet. However, even IE on my desktop gets this same message. As mentioned earlier in this message this is the only webpage that does this. All of my other ones work just fine and dandy. And I know it's not my firewall, since even with it turned off I get the same thing. Now, I really need to be able to access that website so if anyone can help me get this cleared up I would appreciate it. Just know that I'm not the most computer literate person around so any explanations need to be easy to follow!

All Replies (3)

more options

Hi wildchild1954, Do you use the same security software on your tablet and desktop?

If not, I would temporarily disable the security software on your desktop and try the site again.

more options

I have AVG on my desktop ande I have tried it with that shut down. No dice. AVG wouldn't block just the one webpage though, even if that was it.

more options

Actually, it would, if it sees a bad or corrupted certificate for that site.

You can try turning off Content Blocking for that site: Go to the site Click on the left end of the address bar Select Turn Off Blocking For This Site Refresh the tab