X
Tap here to go to the mobile version of the site.

Support Forum

How to disable content blocking for google drive?

Posted

Hello, I am having the most difficult time (since a year!) trying to use firefox with google drive. Whenever I try to download a file from google drive, I get the following error message (also see attached screen shots)

The page isn’t redirecting properly

An error occurred during a connection to doc-08-2g-apps-viewer.googleusercontent.com.

   This problem can sometimes be caused by disabling or refusing to accept cookies.

1. I have tried all trouble shooting steps. 2. Have tried downloading in safe mode (of firefox), with all plugins and extensions disabled. 3. There is no way for me to add the URL to "safe list" to not block content on this site

I am running v.68.0.2 (64 bit) and only 2 plugins (see screen shot 3)

Would really really appreciate any help to solve this.

TIA

Hello, I am having the most difficult time (since a year!) trying to use firefox with google drive. Whenever I try to download a file from google drive, I get the following error message (also see attached screen shots) The page isn’t redirecting properly An error occurred during a connection to doc-08-2g-apps-viewer.googleusercontent.com. This problem can sometimes be caused by disabling or refusing to accept cookies. 1. I have tried all trouble shooting steps. 2. Have tried downloading in safe mode (of firefox), with all plugins and extensions disabled. 3. There is no way for me to add the URL to "safe list" to not block content on this site I am running v.68.0.2 (64 bit) and only 2 plugins (see screen shot 3) Would really really appreciate any help to solve this. TIA
Attached screenshots
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

More Information

ineuw 2 solutions 24 answers

I have the identical software and setup without any problems.

In Firefox this may be a Security & Privacy setting. In any case delete all Google cookies and try Do you login to Google automatically and remain logged in?

I have the identical software and setup without any problems. In Firefox this may be a Security & Privacy setting. In any case delete all Google cookies and try Do you login to Google automatically and remain logged in?
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
520 solutions 4884 answers

Hello spittie,

Your second screenshot shows that you have not given the site permission to set cookies ....

Would you do this please :

When you're on that site, click on the 'i' in a circle, next to the padlock at the left side of the address bar.

Then click on the little black arrow on the dropdown (next to 'Connection') and then on "More Information", which will take you to "Page Info".

(well, you know how this works, looking at your screenshot)

Click on the 'Permissions" tab and scroll down to "Set Cookies". Uncheck "Use Default" and check "Allow".

Then close and restart Firefox.

Any difference ?

Hello spittie, Your second screenshot shows that you have not given the site permission to set cookies .... Would you do this please : When you're on that site, click on the 'i' in a circle, next to the padlock at the left side of the address bar. Then click on the little black arrow on the dropdown (next to 'Connection') and then on "More Information", which will take you to "Page Info". (well, you know how this works, looking at your screenshot) Click on the 'Permissions" tab and scroll down to "Set Cookies". Uncheck "Use Default" and check "Allow". Then close and restart Firefox. Any difference ?
Was this helpful to you?
Quote

Question owner

ineuw said

I have the identical software and setup without any problems. In Firefox this may be a Security & Privacy setting. In any case delete all Google cookies and try Do you login to Google automatically and remain logged in?

Hi ineuw, I have cleared all cookies, logged in afresh and tried but to no avail :(

''ineuw [[#answer-1246374|said]]'' <blockquote> I have the identical software and setup without any problems. In Firefox this may be a Security & Privacy setting. In any case delete all Google cookies and try Do you login to Google automatically and remain logged in? </blockquote> Hi ineuw, I have cleared all cookies, logged in afresh and tried but to no avail :(
Was this helpful to you?
Quote

Question owner

Hi McCoy, Thanks for taking the time to write a detailed solution. really appreciate it!!

I did the steps you mentioned, but still getting the "unsecure connection" message (see screen shot).

isthere anything else I could try?

Hi McCoy, Thanks for taking the time to write a detailed solution. really appreciate it!! I did the steps you mentioned, but still getting the "unsecure connection" message (see screen shot). isthere anything else I could try?
Was this helpful to you?
Quote

Question owner

McCoy said

Hello spittie, Your second screenshot shows that you have not given the site permission to set cookies .... Would you do this please : When you're on that site, click on the 'i' in a circle, next to the padlock at the left side of the address bar. Then click on the little black arrow on the dropdown (next to 'Connection') and then on "More Information", which will take you to "Page Info". (well, you know how this works, looking at your screenshot) Click on the 'Permissions" tab and scroll down to "Set Cookies". Uncheck "Use Default" and check "Allow". Then close and restart Firefox. Any difference ?

SOrry I didn't quote/tag you. Please see my response above.

''McCoy [[#answer-1246380|said]]'' <blockquote> Hello spittie, Your second screenshot shows that you have not given the site permission to set cookies .... Would you do this please : When you're on that site, click on the 'i' in a circle, next to the padlock at the left side of the address bar. Then click on the little black arrow on the dropdown (next to 'Connection') and then on "More Information", which will take you to "Page Info". (well, you know how this works, looking at your screenshot) Click on the 'Permissions" tab and scroll down to "Set Cookies". Uncheck "Use Default" and check "Allow". Then close and restart Firefox. Any difference ? </blockquote> SOrry I didn't quote/tag you. Please see my response above.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17413 solutions 157293 answers

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content.

  • click the shield icon for more details and possibly disable the protection

You can check the Web Console about what content is blocked


Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content. *make sure your extensions and filters are updated to the latest version *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content. *click the shield icon for more details and possibly disable the protection You can check the Web Console about what content is blocked *"3-bar" menu button or Tools -> Web Developer *https://support.mozilla.org/en-US/kb/content-blocking ---- Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
520 solutions 4884 answers

Hello again spittie,

According to your screenshots, Firefox isn't blocking any content .....

Would you please take a look at the last post in this Reddit thread and see if that will work for you :

https://www.reddit.com/r/firefox/comments/aeamte/cant_download_pdf_files_from_google_drive_using/

If everything else fails, maybe you could consider installing this add-on :

https://addons.mozilla.org/en-US/firefox/addon/google-drive-downloader/

Under "About this extension" it says :

" Please note that any supported format which you wish to download will be downloaded as a "PDF" File. "

Might be worth a try .....

Hello again spittie, According to your screenshots, Firefox isn't blocking any content ..... Would you please take a look at the last post in this Reddit thread and see if that will work for you : https://www.reddit.com/r/firefox/comments/aeamte/cant_download_pdf_files_from_google_drive_using/ If everything else fails, maybe you could consider installing this add-on : https://addons.mozilla.org/en-US/firefox/addon/google-drive-downloader/ Under "About this extension" it says : "'' Please note that any supported format which you wish to download will be downloaded as a "PDF" File.'' " Might be worth a try .....
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.