Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox autofills password field with incorrect password. How do I fix this?

  • 3 replies
  • 2 have this problem
  • 32 views
  • Last reply by cor-el

more options

OS: Zorin OS 15 Firefox Version 68.0.1 (64-bit)

I have a website that I use and I have 2 accounts if that matters.

When I select an account to log in with Firefox overwrites my saved password with I long string of letters and numbers for some reason.

What is going on?

How do I fix this?

Thanks!

All Replies (3)

more options

If you are using to accounts on a website, and both login/passwords are saved to the Password Manager, its possible one or both entries are wrong.

Type about:preferences#security<enter> in the address bar. Look under Logins,

Note: For Firefox v56+ its; about:preferences#privacy Look under Forms & Passwords +++++++++++++++++++++++++++++++ Turn on Remember Logins. To check the passwords you have listed, press Saved Logins.

more options

Coffmn, In addition to what FredMcD suggested, this article may help:

Password Manager - Remember, delete and edit logins and passwords in Firefox

more options

It is possible that the website copies the password you entered to another hidden field and modifies the visible password field to prevent a browser from storing this password. You can create a password block exception to prevent the website from modifying the stored password. You can double-click the password in the Password Manager to edit the stored password and store the correct password.

  • Options/Preferences -> Privacy & Security: Logins and Passwords: "Saved Logins" -> "Show Passwords"