Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why is Firefox does not displaying pages correctly

  • 11 replies
  • 1 has this problem
  • 17 views
  • Last reply by FredMcD

more options

This has been happening for sometime now and im getting sick of it and on the brink of getting rid of it all together. Certain websites have parts of the page missing (mostly clickable links). Yet if i open the same page using internet explorer or google chrome everything works fine. I have read that deleting the chache and cookies helps resolve this (which i have done countless times) but the problem keeps coming back. It's ridiculous that you have to keep doing this. And yes my version of Firefox is up to date. Why is it that only firefox has this issue, surely it's about time something was done to sort it once and for all. Infuriating!!!!!

All Replies (11)

more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Content Blocking. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature:

https://support.mozilla.org/en-US/kb/content-blocking

more options

FredMcD said

Make sure you are not blocking content. Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

One issue that seems more common lately is Firefox's Content Blocking. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature:

https://support.mozilla.org/en-US/kb/content-blocking

But does this mean i therefore have to constantly start firefox in "safe mode"? If so its not a solution really. I don't get why if this is the reason, then why can't firefox do something to sort it so that people don't have to do this? Like i say, other browsers don't have this issue

more options

Are the sites listed in Manage Permissions for Cookies & Site Data?

more options

My_Cheese_Is_Slippin' said

Are the sites listed in Manage Permissions for Cookies & Site Data?

I don't know to be honest, not even sure how to check? Does this mean i have to manually input sites into this list everytime i visit a new site or have this problem? If so its too much of a pain to have to do this all the time? Again, other browsers don't require all this.

more options

TKTrooper said

Does this mean i have to manually input sites into this list everytime i visit a new site or have this problem?

No. That's why they are called settings

What did you find out from @FredMcD's suggestion?

more options

My_Cheese_Is_Slippin' said

TKTrooper said
Does this mean i have to manually input sites into this list everytime i visit a new site or have this problem?

No. That's why they are called settings

What did you find out from @FredMcD's suggestion?

The same issue is still there

Modified by TKTrooper

more options

My_Cheese_Is_Slippin' said

What did you find out from @FredMcD's suggestion?

Hello TKTrooper,

Would you please check your content blocking settings, as suggested ?

more options

OK. I visited the site builditandtheywillcome. My Content Blocking and anti-malware made the site almost impossible to navigate. Even after disabling Content Blocking, there were 41 aspects blocked by anti-malware. The risk is yours to take.

This article will explain Content Blocking and how to disable it for a specific site: Content blocking

You may also have to disable your security software to visit that site.

Good Luck

more options

McCoy said

My_Cheese_Is_Slippin' said
What did you find out from @FredMcD's suggestion?

Hello TKTrooper,

Would you please check your content blocking settings, as suggested ?

The content blocking is set to standard and always has been, and the "Send web sites a “Do Not Track” signal that you don’t want to be tracked" is set to always

more options

My_Cheese_Is_Slippin' said

OK. I visited the site builditandtheywillcome. My Content Blocking and anti-malware made the site almost impossible to navigate. Even after disabling Content Blocking, there were 41 aspects blocked by anti-malware. The risk is yours to take. This article will explain Content Blocking and how to disable it for a specific site: Content blocking You may also have to disable your security software to visit that site. Good Luck

That website is just one example, and i do trust it as i know the owner. But this happens with numerous sites, some well known and highly used. With regards to this site in particular, i have previously tried it with security software disabled and and addons and its still the same. Plus as previously stated, none of these issues are evident when using google chrome. It does seem the easiest option is to just get rid of firefox to be honest.

more options

TKTrooper said

does this mean i therefore have to constantly start firefox in "safe mode"? If so its not a solution really

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.