Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't access internet after reactivating history

  • 8 replies
  • 1 has this problem
  • 3 views
  • Last reply by Zuk

more options

I normally use the setting - Privacy & Security - History - Never remember history

but sometime I need to store my passwords in some website so I reactivate history.

The huge problem I have is I can't access internet after reactivating history: after typing the web address, press enter and I wait forever the page to load.

If I deactivate the history again, no problem everything works.

In other words I am locked out in no history mode.

It is reproducible on my Laptop and Desktop PC, both Windows 10 x64 Pro. Reinstalling does not help.

Huge Bug in my eyes: browser do not connect to internet anymore.

Attached screenshots

Modified by Zuk

Chosen solution

Thanks cor-el.

Finally I found the problem: uBlock Origin. For the records it was activated also in private mode. Anyway I reported to them this Problem and I removed it.

Everything works now and the web pages are loading much faster.

Read this answer in context 👍 0

All Replies (8)

more options

History shouldn't affect the Browers opening sites. How do you mean reactivate the history? This is confusing to understand for anyone reading this.

more options

History and passwords are separate within the browser.

Password

Type about:preferences#security<enter> in the address bar. Look under Logins,

Note: For Firefox v56+ its; about:preferences#privacy Look under Forms & Passwords +++++++++++++++++++++++++++++++ Turn on Remember Logins. To check the passwords you have listed, press Saved Logins.

Press the Exceptions button and see what's inside.

more options

Web Access Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select Network.

[v56+] Type about:preferences#general<enter> in the address bar. Look for Network. +++++++++++++++++++++ Look for Configure How Firefox Connects and press the Settings button. If you are using a proxy, make sure those settings are correct. If there is no proxy, first try No Proxy. If there is a problem, then try System Proxy.

more options

WestEnd said

History shouldn't affect the Browers opening sites. How do you mean reactivate the history? This is confusing to understand for anyone reading this.

"History activated" means about:preferences#privacy, under History , Firefox will: Remember history selected.

"History dectivated" means about:preferences#privacy, under History , Firefox will: Never remember history selected.

"Reactivating history" means about:preferences#privacy, under History , switch from Firefox will: Never remember history to Firefox will: Remember history.

Modified by Zuk

more options

FredMcD said

History and passwords are separate within the browser.

Not 100% correct.

See here for details. If history is not active the logins can not saved, which is why I need to reactivate the history once a month or less.

FredMcD said

Press the Exceptions button and see what's inside.

It has nothing to do with Exceptions.

more options

FredMcD said

If there is no proxy, first try No Proxy. If there is a problem, then try System Proxy.

I have no proxy. Those settings seem to remain the same by changing the history status, as they should. I tried No Proxy, Proxy Autodetect and finally Use System Proxy. It still fail to load any web page.

What is surprising to me I can reproduce this bug in two different PC but on the www it seems I am the first to notice that.

For the future, once I get it working with the history activated, I will activate the "Private Mode" by adding the switch -private on the command line, see here for details.

In the case I will need to activate the history again, I wil remove the - private temporarily. I can't trust the setting options about:preferences#privacy - History anymore.

Thanks for helping me!

Modified by Zuk

more options

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

Chosen Solution

Thanks cor-el.

Finally I found the problem: uBlock Origin. For the records it was activated also in private mode. Anyway I reported to them this Problem and I removed it.

Everything works now and the web pages are loading much faster.

Modified by Zuk