X
Tap here to go to the mobile version of the site.

Support Forum

I have a problem with Firefox suddenly not loading any webpage. It is not an internet connection issue.

Posted

I am using Firefox on a laptop, and have been for years. I used it repeatedly yesterday without issue. Yesterday evening, although I had made no changes to any settings on Firefox or my computer, it suddenly stopped loading any webpage. It just shows a blank white tab and it acts like it's loading but it never does. It doesn't time out and it doesn't give me a 'website not found' error. I shut down last night but the problem the problem persists this morning. I can not finding anything in the Firefox settings to change that would make a difference.

It is not an internet connection issue. The internet is working fine here for all devices, including this one, I am currently at the same location, posting this question from my laptop, using Chrome. I've always preferred Firefox, but if I can't get it to work, I won't be able to use it anymore.

I am using Firefox on a laptop, and have been for years. I used it repeatedly yesterday without issue. Yesterday evening, although I had made no changes to any settings on Firefox or my computer, it suddenly stopped loading any webpage. It just shows a blank white tab and it acts like it's loading but it never does. It doesn't time out and it doesn't give me a 'website not found' error. I shut down last night but the problem the problem persists this morning. I can not finding anything in the Firefox settings to change that would make a difference. It is not an internet connection issue. The internet is working fine here for all devices, including this one, I am currently at the same location, posting this question from my laptop, using Chrome. I've always preferred Firefox, but if I can't get it to work, I won't be able to use it anymore.
Quote

Additional System Details

Installed Plug-ins

OpenH264 Video Codec, Shockwave, Widevine Content Decryption Module

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/75.0.3770.142 Safari/537.36

More Information

jscher2000
  • Top 10 Contributor
8573 solutions 70093 answers

Hi bengood921, sorry to hear about this problem.

Another user reported their initial tab being "dead" but new tabs worked. Can you open a new tab (Ctrl+t) and see whether that works?


Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Hi bengood921, sorry to hear about this problem. Another user reported their initial tab being "dead" but new tabs worked. Can you open a new tab (Ctrl+t) and see whether that works? ---- Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?
Was this helpful to you?
Quote

Question owner

To be clear, with regards to your first question - all tabs are dead. Creating new tabs generated the same results, whether I then used them go to webpages I'd been to before, or new ones I hadn't. Only the Firefox 'new tab' screen worked (by new tab screen I mean the one where it brings up icons for pages I frequently use, and then a row of suggested news articles).

I'm happy to say, however, that restarting in safe mode worked. As far as I can tell, all webpages are loading as they should. The next question then would be what should I do next, if anything.

Thank you for your assistance.

To be clear, with regards to your first question - all tabs are dead. Creating new tabs generated the same results, whether I then used them go to webpages I'd been to before, or new ones I hadn't. Only the Firefox 'new tab' screen worked (by new tab screen I mean the one where it brings up icons for pages I frequently use, and then a row of suggested news articles). I'm happy to say, however, that restarting in safe mode worked. As far as I can tell, all webpages are loading as they should. The next question then would be what should I do next, if anything. Thank you for your assistance.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8573 solutions 70093 answers

Hi bengood921, the most common reason for pages to work in safe mode but not in regular mode is a problem extension.

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

In Safe Mode, extensions are automatically disabled, but hopefully you can still operate the little ••• menu on the right side to disable them manually. Then when you restart in regular mode, you can selectively re-enable the ones you most rely on and test again.

Also, make sure they are up-to-date: The "gear" icon above the list drops a menu that includes "Check for Updates".

Hi bengood921, the most common reason for pages to work in safe mode but not in regular mode is a problem extension. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either: * Ctrl+Shift+a (Mac: Command+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons * type or paste '''about:addons''' in the address bar and press Enter/Return In the left column of the Add-ons page, click Extensions. In Safe Mode, extensions are automatically disabled, but hopefully you can still operate the little ••• menu on the right side to disable them manually. Then when you restart in regular mode, you can selectively re-enable the ones you most rely on and test again. Also, make sure they are up-to-date: The "gear" icon above the list drops a menu that includes "Check for Updates".
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.