Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox fails to display images on google sites

  • 3 replies
  • 1 has this problem
  • 114 views
  • Last reply by jaygray0919

more options

Am running Firefox 68.0.1 (64-bit) on Win10. When visiting google pages, in both normal (logged-in) and incognito mode, firefox faults. When visiting google fonts page, the browser faults completely. When visiting google developer pages, firefox does not display selection and navigation icons (which are SVG objects). What setting in my firefox configuration may be causing these problems? The attached screen shots illustrate. Surprise: none of these conditions exist in Chrome. They also do not exist in MS Edge.

Attached screenshots

Chosen solution

Thank you. Adblock was the cause. Have disabled Adblock; will re-enable and disable for specific URLs.

Read this answer in context 👍 0

All Replies (3)

more options

What happens when your not running in Private Browsing ?

Have you tried changing the settings in Options --> Content Blocking to something lower if it is set high ?

more options

You appear to have some content blocking extensions installed.

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content.

  • click the shield icon for more details and possibly disable the protection

You can check the Web Console about what content is blocked

more options

Chosen Solution

Thank you. Adblock was the cause. Have disabled Adblock; will re-enable and disable for specific URLs.