X
Tap here to go to the mobile version of the site.

Support Forum

missing add-ons in new windows

Posted

Hello,

I'm running Firefox V68.0 (64-bit) on windows 10 V1803 (Built 17134.885)

When opening a link from an email, the browser opens up with no add-ons.

I have the following properties in about:config

browser.link.open_newwindow; 3 browser.link.open_newwindow.disabled_in_fullscreen; false browser.link.open_newwindow.override.external; -1 browser.link.open_newwindow.restriction; 0 services.sync.prefs.sync.browser.link.open_newwindow; true

Any idea how to fix this?

Thanks

Eyal

Hello, I'm running Firefox V68.0 (64-bit) on windows 10 V1803 (Built 17134.885) When opening a link from an email, the browser opens up with no add-ons. I have the following properties in about:config browser.link.open_newwindow; 3 browser.link.open_newwindow.disabled_in_fullscreen; false browser.link.open_newwindow.override.external; -1 browser.link.open_newwindow.restriction; 0 services.sync.prefs.sync.browser.link.open_newwindow; true Any idea how to fix this? Thanks Eyal

Chosen solution

Hi Eyal, are the add-ons the only difference, or are your bookmarks, history, etc. also missing?


Firefox 67+ handles external links -- links in other programs, desktop shortcuts, etc. -- in a different way. Instead of opening in whatever Firefox profile (settings file) is currently running, they will open in the default profile. So possibly your regular profile and the one marked as default might be out of alignment.

You may need to update your default profile to the one you normally use. Here's one way:

Next time you use an external link and get an unfamiliar Firefox, try this:

Profile Manager Page

Type or paste about:profiles in the address bar and press Enter/Return to load it.

This page should list at least one profile, and possibly several. (Each profile has two folders and one or more buttons. Do not use any Remove buttons!)

The profile the current Firefox window is currently using will have this:

This is the profile in use and it cannot be deleted.

If another profile is running it will have this longer text:

This profile is in use in another application and it cannot be deleted.

If you see that, does that profile have a button labeled Set as default profile? If so, please click that to align the external link behavior with your preferred settings.

Any luck?

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

More Information

jscher2000
  • Top 10 Contributor
8580 solutions 70167 answers

Chosen Solution

Hi Eyal, are the add-ons the only difference, or are your bookmarks, history, etc. also missing?


Firefox 67+ handles external links -- links in other programs, desktop shortcuts, etc. -- in a different way. Instead of opening in whatever Firefox profile (settings file) is currently running, they will open in the default profile. So possibly your regular profile and the one marked as default might be out of alignment.

You may need to update your default profile to the one you normally use. Here's one way:

Next time you use an external link and get an unfamiliar Firefox, try this:

Profile Manager Page

Type or paste about:profiles in the address bar and press Enter/Return to load it.

This page should list at least one profile, and possibly several. (Each profile has two folders and one or more buttons. Do not use any Remove buttons!)

The profile the current Firefox window is currently using will have this:

This is the profile in use and it cannot be deleted.

If another profile is running it will have this longer text:

This profile is in use in another application and it cannot be deleted.

If you see that, does that profile have a button labeled Set as default profile? If so, please click that to align the external link behavior with your preferred settings.

Any luck?

Hi Eyal, are the add-ons the only difference, or are your bookmarks, history, etc. also missing? ---- Firefox 67+ handles external links -- links in other programs, desktop shortcuts, etc. -- in a different way. Instead of opening in whatever Firefox profile (settings file) is currently running, they will open in the default profile. So possibly your regular profile and the one marked as default might be out of alignment. You may need to update your default profile to the one you normally use. Here's one way: Next time you use an external link and get an unfamiliar Firefox, try this: '''Profile Manager Page''' Type or paste '''about:profiles''' in the address bar and press Enter/Return to load it. This page should list at least one profile, and possibly several. (Each profile has two folders and one or more buttons. Do not use any Remove buttons!) The profile the current Firefox window is currently using will have this: '''This is the profile in use and it cannot be deleted.''' If another profile is running it will have this longer text: '''This profile is in use in another application and it cannot be deleted.''' If you see that, does ''that'' profile have a button labeled '''Set as default profile'''? If so, please click that to align the external link behavior with your preferred settings. Any luck?
Was this helpful to you? 1
Quote

Question owner

Hi jscher2000

You were spot on. I did have two profiles and the "correct" one was launching when clicking on the Firefox shortcut while the other profile was launched by external applications.

I tried your suggestion to align the two profiles but it didn't work. Deleting the 2nd profile fixed the issue however.

Thank you much for your help

Hi jscher2000 You were spot on. I did have two profiles and the "correct" one was launching when clicking on the Firefox shortcut while the other profile was launched by external applications. I tried your suggestion to align the two profiles but it didn't work. Deleting the 2nd profile fixed the issue however. Thank you much for your help
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.