Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Too many processes, does not respond to setting!

  • 10 replies
  • 5 have this problem
  • 51 views
  • Last reply by cor-el

more options

I DON'T want 8 Firefox processes right from the start! And I CERTAINLY don't want 4 of them when I have set the limit to ONE!!

I have also checked the dom.ipc.processCount which IS set to one. Firefox 68.0.

All Replies (10)

more options

ThIs is a F-ing DISASTER!!!

When using 68.0 it shows completely or partially BLANK pages using HIGH resourses.

When reinstalling 67.0.4 i had to create a new profile and I cannot acces my BOOKMARKS!!!!!

Even when putting back 68.0 again I can no longer acces my my bookmarks.

HOW TO REACCESS THEM, I NEED THEM NOW!!!!!

more options

Did yelling at people ever help you get an answer?

more options

TyDraniu said

Did yelling at people ever help you get an answer?

Did throwing salt ever help anyone looking for an answer?

Maybe he could have been more civil, but still there was no need for your throwaway salt.

He has a point, there are people that are not happy that the choice to disable e10 has been taken away.

I work with a homeless organisation that have a number of very low end PCs, that could manage to use FF with e10 features disabled, thanks to a simple config tweak that Mozilla themselves put out there.

Without this tweak they are now paperweights...

more options

I agree, why did they remove the ability to limit the number? If it's a security thing, then give us 2 processes one for your/our security blanket and the other for our needs. I've got a i5 with 12gig of memory 1T hard drive external drives for files, running win7 pro (my choice, it's better than win10). For whatever reason 1 instance runs much better in multiple tabs that I leave idle for a long time. When my resources get to around 33 percent I have to force the 4 firefox instances closed and reopen, and then I'm good for a day or so before I have to repeat the process.

more options

goingjag said

I agree, why did they remove the ability to limit the number?

You can limit the number of content processes to 1, but Firefox also has separate processes for the main program, and I think extensions now.

more options

There was an about:config preference that used to control disabling e10s (back to single process), but after some changes, you now need an environment variable to do so:

Variable name: MOZ_FORCE_DISABLE_E10S Variable value: 1

See https://techdows.com/2019/08/multi-process-e10s-can-still-be-disabled-in-firefox-68-or-later-versions-here-is-how.html for a walkthrough.

more options

Disabling e10s is no longer recommended. It will break certain basic functionality, like Firefox Lockwise.

more options

I don't know what Lockwise is, but I do know that Firefox with e10s running loose eats up resources like crazy with all it's iterations, that seem to accomplish nothing that is obvious to the casual user. I would think there would be some setting that would stop it from going wild.

more options

Firefox Lockwise is the password manager built into Firefox.

You can limit multi-process in Firefox by restricting the number of processes that Firefox can use for content. If you go to the Firefox settings and uncheck the Use recommended performance settings option you can change the Content process limit.

You will still get a few Firefox-related processes because Firefox still separates the main browser from the content that you load in tabs, but the setting will allow you to restrict how many processes Firefox can open to use for your content.

You can get severe performance impacts from reducing the number of processes Firefox can use, but it will decrease the memory Firefox uses.

more options

You can disable some feature like WebRender via prefs on the about:config page.

You can look at these prefs on the about:config page page to enable or disable WebRender.

  • gfx.webrender.enabled = false/true
  • gfx.webrender.force-disabled = true

It is quite normal to see more Firefox processes running.

  • one process for the main Firefox thread (user interface)
  • one or more content processes, see:
    Options/Preferences -> General -> Performance
    remove checkmark: [ ] "Use recommended performance settings"
  • one process for the compositor thread
  • one process for the WebRender when this feature is enabled

You can find the current multi-process state on the Troubleshooting Information page (about:support).

  • "Help -> Troubleshooting Information" -> "Application Basics":
    Multiprocess Windows
    Remote Processes

See also the Remote Processes section further down for more detail.