Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I was updated to FireFox 67.0.4 and hyperlinks aren't working the way they used to?

  • 4 replies
  • 1 has this problem
  • 16 views
  • Last reply by jscher2000

more options

hyperlinks now open in a new window and are not recognizing my current open session with my profile & bookmarks. I have to copy the hyperlink and paste it into the current FireFox browser session. I've checked my Options>Tools>General settings and they are checked to open links in a new tab.

All Replies (4)

more options

Please update to Firefox 68, and let us know if there is still an issue

more options

Hi fpikester, Firefox 67+ handles external links -- links in other programs, desktop shortcuts, etc. -- in a different way. Instead of opening in whatever Firefox profile (settings file) is currently running, they will open in the default profile. So possibly your regular profile and the one marked as default might be out of alignment.

Hopefully the update will straighten out your profile list. However, if not, then you may need to update your default profile to the one you normally use. Here's one way:

Next time you use an external link and get an unfamiliar Firefox, try this:

Profile Manager Page

Type or paste about:profiles in the address bar and press Enter/Return to load it.

This page should list at least one profile, and possibly several. (Each profile has two folders and one or more buttons. Do not use any Remove buttons!)

The profile the current Firefox window is currently using will have this:

This is the profile in use and it cannot be deleted.

If another profile is running it will have this longer text:

This profile is in use in another application and it cannot be deleted.

If you see that, does that profile have a button labeled Set as default profile? If so, please click that to align the external link behavior with your preferred settings.

Any luck?

more options

Nope, didn't work. I still have the problem when opening a hyperlink in e-mail, it opens a new FireFox session and totally ignores all my bookmarks and saved id's.

I also updated to Firefox 68.0 .. I was told to do this by someone from FireFox support.

I would really like this fixed a.s.a.p.

more options

Hi fpikester, when you checked the about:profiles screen, were the two windows (regular window and external link window) using different profiles? What did you see there?