X
Tap here to go to the mobile version of the site.

Support Forum

How to prevent Firefox to disable addon that I trust? It's an old version, but I want to keep using it.

Posted

I use an old version of 1Password. I don't want to update it. Current version is far enough for my needs.

But last week, it started to show this: "Browser connection refused".

and its log file states this: "Refusing helper connection because of untrusted certificate".

So, I know that extension and I trust in it. I only want to keep using it, but Mozilla is denying.

How to avoid that certificate checking?

Digging the profile folder, I found some files that may bring the solution, but I don't know how: addons.json addonStartup.json.lz4 extensions.json

Older versions of Firefox had an option to uncheck certificate validation, as we see here: https://smallbusiness.chron.com/disable-firefox-rejecting-certificates-59249.html but I'm afraid that my current version (66.0.2) has not. I can't find it.

I use an old version of 1Password. I don't want to update it. Current version is far enough for my needs. But last week, it started to show this: "Browser connection refused". and its log file states this: "Refusing helper connection because of untrusted certificate". So, I know that extension and I trust in it. I only want to keep using it, but Mozilla is denying. How to avoid that certificate checking? Digging the profile folder, I found some files that may bring the solution, but I don't know how: addons.json addonStartup.json.lz4 extensions.json Older versions of Firefox had an option to uncheck certificate validation, as we see here: https://smallbusiness.chron.com/disable-firefox-rejecting-certificates-59249.html but I'm afraid that my current version (66.0.2) has not. I can't find it.
Quote

Additional System Details

Installed Plug-ins

1Password and others.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

jscher2000
  • Top 10 Contributor
8635 solutions 70627 answers

Hi Gabarito, where do you see the message:

But last week, it started to show this: "Browser connection refused".
and its log file states this: "Refusing helper connection because of untrusted certificate".

I think the helper connection may refer to the extension's connection to the locally installed 1Password program, which would be a different issue from Firefox's built-in validation of extension signatures or the kind of certificate revocation checking (OCSP) referenced in that article you found.

Hi Gabarito, where do you see the message: <blockquote> But last week, it started to show this: "Browser connection refused". <br> and its log file states this: "Refusing helper connection because of untrusted certificate". </blockquote> I think the helper connection may refer to the extension's connection to the locally installed 1Password program, which would be a different issue from Firefox's built-in validation of extension signatures or the kind of certificate revocation checking (OCSP) referenced in that article you found.
Was this helpful to you?
Quote

Question owner

jscher2000 said

Hi Gabarito, where do you see the message: I think the helper connection may refer to the extension's connection to the locally installed 1Password program, which would be a different issue from Firefox's built-in validation of extension signatures or the kind of certificate revocation checking (OCSP) referenced in that article you found.

Thank you for your prompt response, jscher2000.

Attached, a picture of the Windows message. Local program works very well, but it's unabled to connect to its partner, browser extension. I'm looking for a solution, doesn't matter if it's a certificate issue or whatelse.

Any ideas?

Thx.

''jscher2000 [[#answer-1233950|said]]'' <blockquote> Hi Gabarito, where do you see the message: I think the helper connection may refer to the extension's connection to the locally installed 1Password program, which would be a different issue from Firefox's built-in validation of extension signatures or the kind of certificate revocation checking (OCSP) referenced in that article you found. </blockquote> Thank you for your prompt response, jscher2000. Attached, a picture of the Windows message. Local program works very well, but it's unabled to connect to its partner, browser extension. I'm looking for a solution, doesn't matter if it's a certificate issue or whatelse. Any ideas? Thx.
Was this helpful to you?
Quote

Question owner

Here is a piece of the log file:

TypeTimeThreadMessage
ISystem Uptime: 0 day(s) 03:36
I12.960.807ms1Locking app with windows locked (SessionUnlock).
I12.960.807ms7> sync

account id: 1; type: L time: 6.841ms

I12.961.002ms43network is available again
I12.961.002ms7refreshing network
E12.961.552ms12Refusing helper connection from "C:\Windows\explorer.exe", because of untrusted certificate.
I12.961.642ms7network configured in 629ms
I12.964.656ms7> sync

account id: 1; type: L time: 2ms

I12.965.498ms7Loaded 9.720 compromised sites in 00:00:00.0249240
I12.965.919ms7Loaded 492 sites with 2FA.
E12.981.653ms13Refusing helper connection from "C:\Windows\explorer.exe", because of untrusted certificate.
E13.001.761ms18Refusing helper connection from "C:\Windows\explorer.exe", because of untrusted certificate.
E13.021.860ms20Refusing helper connection from "C:\Windows\explorer.exe", because of untrusted certificate.
E13.041.991ms17Refusing helper connection from "C:\Windows\explorer.exe", because of untrusted certificate.
Here is a piece of the log file: <blockquote> <table> <tr><th>Type</th><th>Time</th><th>Thread</th><th>Message</th></tr><tr><td>I</td><td></td><td></td><td>System Uptime: 0 day(s) 03:36</td></tr><tr class=""><td>I</td><td title="2019-06-30 00:20:44Z">12.960.807ms</td><td title="UI thread">1</td><td>Locking app with windows locked (SessionUnlock).</td></tr> <tr class=""><td>I</td><td title="2019-06-30 00:20:44Z">12.960.807ms</td><td title="Workspace">7</td><td>&gt; sync account id: 1; type: L time: 6.841ms </td></tr> <tr class=""><td>I</td><td title="2019-06-30 00:20:44Z">12.961.002ms</td><td title="Background Thread">43</td><td>network is available again</td></tr> <tr class=""><td>I</td><td title="2019-06-30 00:20:44Z">12.961.002ms</td><td title="Workspace">7</td><td>refreshing network</td></tr> <tr class="e"><td>E</td><td title="2019-06-30 00:20:45Z">12.961.552ms</td><td title="NativeMessagingBrowserListener1">12</td><td>Refusing helper connection from &quot;C:\Windows\explorer.exe&quot;, because of untrusted certificate.</td></tr> <tr class=""><td>I</td><td title="2019-06-30 00:20:45Z">12.961.642ms</td><td title="Workspace">7</td><td>network configured in 629ms</td></tr> <tr class=""><td>I</td><td title="2019-06-30 00:20:48Z">12.964.656ms</td><td title="Workspace">7</td><td>&gt; sync account id: 1; type: L time: 2ms </td></tr> <tr class=""><td>I</td><td title="2019-06-30 00:20:49Z">12.965.498ms</td><td title="Workspace">7</td><td>Loaded 9.720 compromised sites in 00:00:00.0249240</td></tr> <tr class=""><td>I</td><td title="2019-06-30 00:20:49Z">12.965.919ms</td><td title="Workspace">7</td><td>Loaded 492 sites with 2FA.</td></tr> <tr class="e"><td>E</td><td title="2019-06-30 00:21:05Z">12.981.653ms</td><td title="NativeMessagingBrowserListener2">13</td><td>Refusing helper connection from &quot;C:\Windows\explorer.exe&quot;, because of untrusted certificate.</td></tr> <tr class="e"><td>E</td><td title="2019-06-30 00:21:25Z">13.001.761ms</td><td title="NativeMessagingBrowserListener7">18</td><td>Refusing helper connection from &quot;C:\Windows\explorer.exe&quot;, because of untrusted certificate.</td></tr> <tr class="e"><td>E</td><td title="2019-06-30 00:21:45Z">13.021.860ms</td><td title="NativeMessagingBrowserListener9">20</td><td>Refusing helper connection from &quot;C:\Windows\explorer.exe&quot;, because of untrusted certificate.</td></tr> <tr class="e"><td>E</td><td title="2019-06-30 00:22:05Z">13.041.991ms</td><td title="NativeMessagingBrowserListener6">17</td><td>Refusing helper connection from &quot;C:\Windows\explorer.exe&quot;, because of untrusted certificate.</td></tr> </blockquote>
Was this helpful to you?
Quote

Question owner

More info: extension icon becomes grayed (unable) few seconds after Firefox starts. And I get that message (Browser refuses...) at Windows tray bar.

More info: extension icon becomes grayed (unable) few seconds after Firefox starts. And I get that message (Browser refuses...) at Windows tray bar.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8635 solutions 70627 answers

Hi Gabarito, thank you for the screenshot:

It's a message from 1Password, not an objection from Firefox.

When search for that error message, I find this comment from 1Password support folks:

The connection refused message means 1Password is unable to validate your browser's code signature. This is a security measure to make sure the browser you're filling in is what it claims to be and not a malicious process masquerading as your browser.

https://discussions.agilebits.com/discussion/comment/473343/#Comment_473343

You might try opening a support ticket with them to see whether they can track down the problem.

Hi Gabarito, thank you for the screenshot: <img src="https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2019-06-30-09-17-14-553f63.png"> It's a message from 1Password, not an objection from Firefox. When search for that error message, I find this comment from 1Password support folks: <blockquote>The connection refused message means 1Password is unable to validate your browser's code signature. This is a security measure to make sure the browser you're filling in is what it claims to be and not a malicious process masquerading as your browser.</blockquote> https://discussions.agilebits.com/discussion/comment/473343/#Comment_473343 You might try opening a support ticket with them to see whether they can track down the problem.
Was this helpful to you?
Quote

Question owner

jscher2000 said

The connection refused message means 1Password is unable to validate your browser's code signature. This is a security measure to make sure the browser you're filling in is what it claims to be and not a malicious process masquerading as your browser.

https://discussions.agilebits.com/discussion/comment/473343/#Comment_473343

You might try opening a support ticket with them to see whether they can track down the problem.

Yes, I already had saw comments like that at Agilebits forum. But the solution, they say, it's to update the program. I resist to do that. I don't want to pay updates for something I already have and was working very well, filling all my needs. And the new versions has something to push my Vault with passwords to their servers cloud. I prefer to keep my Vault locally, here with me, at my discs drives. Exactly as it is now, using old version.

I don't understand why it happens these days. Because of that, I thought it was some measure from Mozilla revocating extension certificate, similar to that occurred when Firefox refused all extensions globally, some months ago.

Because all of that, I'm asking for help to get a way to circumvent that browser refusal.

If someone knows how to make my old extension to work again, please, feel free to comment.

Thx.

''jscher2000 [[#answer-1233995|said]]'' <blockquote>The connection refused message means 1Password is unable to validate your browser's code signature. This is a security measure to make sure the browser you're filling in is what it claims to be and not a malicious process masquerading as your browser. <p> https://discussions.agilebits.com/discussion/comment/473343/#Comment_473343 <br> <br> You might try opening a support ticket with them to see whether they can track down the problem. </blockquote> Yes, I already had saw comments like that at Agilebits forum. But the solution, they say, it's to update the program. I resist to do that. I don't want to pay updates for something I already have and was working very well, filling all my needs. And the new versions has something to push my Vault with passwords to their servers cloud. I prefer to keep my Vault locally, here with me, at my discs drives. Exactly as it is now, using old version. I don't understand why it happens these days. Because of that, I thought it was some measure from Mozilla revocating extension certificate, similar to that occurred when Firefox refused all extensions globally, some months ago. Because all of that, I'm asking for help to get a way to circumvent that browser refusal. If someone knows how to make my old extension to work again, please, feel free to comment. Thx.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8635 solutions 70627 answers

Helpful Reply

As far as I can tell, it's not Firefox refusing the connection. The extension is reaching out to the locally installed 1Password program and the program is rejecting the connection. I don't think changing any Firefox settings will help.

What happened in early May was that the certificate Mozilla used to sign most extensions in recent years expired, so the extensions signed with that certificate could no longer be verified and became disabled. The workaround was to add a new certificate into Firefox as an alternate way to prove the extension signature was valid. Then the extensions could be enabled again. Very different issue.

As far as I can tell, it's not Firefox refusing the connection. The extension is reaching out to the locally installed 1Password program and the program is rejecting the connection. I don't think changing any Firefox settings will help. What happened in early May was that the certificate Mozilla used to sign most extensions in recent years expired, so the extensions signed with that certificate could no longer be verified and became disabled. The workaround was to add a new certificate into Firefox as an alternate way to prove the extension signature was valid. Then the extensions could be enabled again. Very different issue.
Was this helpful to you? 1
Quote

Question owner

Thank you very much, jscher2000.

Unfortunately, guided by your comments, I'm reaching into a point to look for another way to store my passwords ...

I can't understand why it suddenly happened.

Question is open.

If someone else had more ideas, lets listen them.

Thank you very much, jscher2000. Unfortunately, guided by your comments, I'm reaching into a point to look for another way to store my passwords ... I can't understand why it suddenly happened. Question is open. If someone else had more ideas, lets listen them.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17415 solutions 157316 answers

Helpful Reply

You can consider to install the Firefox Lockwise Password Manager.

This is currently an extension in Firefox, but will be builtin in future Firefox versions. This extension allow to add a new Login.

You can consider to install the Firefox Lockwise Password Manager. This is currently an extension in Firefox, but will be builtin in future Firefox versions. This extension allow to add a new Login. *https://support.mozilla.org/en-US/kb/sync-logins-firefox-desktop *https://support.mozilla.org/en-US/kb/install-or-remove-firefox-lockwise-desktop *https://lockwise.firefox.com/ *https://lockwise.firefox.com/faq.html
Was this helpful to you? 1
Quote

Question owner

cor-el said

You can consider to install the Firefox Lockwise Password Manager. This is currently an extension in Firefox, but will be builtin in future Firefox versions. This extension allow to add a new Login.

Thank you for your suggestion.

I'll take a look at Lockwise later.

''cor-el [[#answer-1234044|said]]'' <blockquote> You can consider to install the Firefox Lockwise Password Manager. This is currently an extension in Firefox, but will be builtin in future Firefox versions. This extension allow to add a new Login. *https://support.mozilla.org/en-US/kb/sync-logins-firefox-desktop *https://support.mozilla.org/en-US/kb/install-or-remove-firefox-lockwise-desktop *https://lockwise.firefox.com/ *https://lockwise.firefox.com/faq.html </blockquote> Thank you for your suggestion. I'll take a look at Lockwise later.
Was this helpful to you?
Quote

Question owner

jscher2000 said

What happened in early May was that the certificate Mozilla used to sign most extensions in recent years expired, so the extensions signed with that certificate could no longer be verified and became disabled. The workaround was to add a new certificate into Firefox as an alternate way to prove the extension signature was valid. Then the extensions could be enabled again. Very different issue.

Thank you for explanations.


jscher2000 said

As far as I can tell, it's not Firefox refusing the connection. The extension is reaching out to the locally installed 1Password program and the program is rejecting the connection. I don't think changing any Firefox settings will help.

I had run some tests here. I killed the main application task and restarted Firefox. Extension remains unabled, grayed icon. I removed the extension and instaled it again with a xpi file I already have (it's not at Mozilla Store anymore because it's outdated). Restated Firefox but there is no way to enable it back, even if I disconnect computer from internet. So, maybe the refusal it's not caused by the main application. And, because the browser was disconnected from internet, I don't know why extension is still denied. I suspect about some files on profile folder is refusing the extension

Any ideas?

''jscher2000 [[#answer-1234031|said]]'' <blockquote> What happened in early May was that the certificate Mozilla used to sign most extensions in recent years expired, so the extensions signed with that certificate could no longer be verified and became disabled. The workaround was to add a new certificate into Firefox as an alternate way to prove the extension signature was valid. Then the extensions could be enabled again. Very different issue. </blockquote> Thank you for explanations. ''jscher2000 [[#answer-1234031|said]]'' <blockquote> As far as I can tell, it's not Firefox refusing the connection. The extension is reaching out to the locally installed 1Password program and the program is rejecting the connection. I don't think changing any Firefox settings will help. </blockquote> I had run some tests here. I killed the main application task and restarted Firefox. Extension remains unabled, grayed icon. I removed the extension and instaled it again with a xpi file I already have (it's not at Mozilla Store anymore because it's outdated). Restated Firefox but there is no way to enable it back, even if I disconnect computer from internet. So, maybe the refusal it's not caused by the main application. And, because the browser was disconnected from internet, I don't know why extension is still denied. I suspect about some files on profile folder is refusing the extension Any ideas?
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8635 solutions 70627 answers

Gabarito said

I removed the extension and instaled it again with a xpi file I already have (it's not at Mozilla Store anymore because it's outdated). Restated Firefox but there is no way to enable it back, even if I disconnect computer from internet.

Does Firefox list the reason the extension is disabled on the Add-ons page? Usually it will be in red text.

''Gabarito [[#answer-1234153|said]]'' <blockquote> I removed the extension and instaled it again with a xpi file I already have (it's not at Mozilla Store anymore because it's outdated). Restated Firefox but there is no way to enable it back, even if I disconnect computer from internet. </blockquote> Does Firefox list the reason the extension is disabled on the Add-ons page? Usually it will be in red text.
Was this helpful to you?
Quote

Question owner

jscher2000 said

Gabarito said
I removed the extension and instaled it again with a xpi file I already have (it's not at Mozilla Store anymore because it's outdated). Restated Firefox but there is no way to enable it back, even if I disconnect computer from internet.

Does Firefox list the reason the extension is disabled on the Add-ons page? Usually it will be in red text.

Good question. Answer is "no". Simply, extension icon remains grayed, but it has normal look at Add-ons page. See captures below:

''jscher2000 [[#answer-1234210|said]]'' <blockquote> ''Gabarito [[#answer-1234153|said]]'' <blockquote> I removed the extension and instaled it again with a xpi file I already have (it's not at Mozilla Store anymore because it's outdated). Restated Firefox but there is no way to enable it back, even if I disconnect computer from internet. </blockquote> Does Firefox list the reason the extension is disabled on the Add-ons page? Usually it will be in red text. </blockquote> Good question. Answer is "no". Simply, extension icon remains grayed, but it has normal look at Add-ons page. See captures below:

Modified by Gab Arito

Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8635 solutions 70627 answers

Okay, Firefox isn't disabling the extension. I think the icon is gray because the extension can't make a connection with the 1Password application. However, I'm just guessing because I don't use that extension.

Okay, Firefox isn't disabling the extension. I think the icon is gray because the extension can't make a connection with the 1Password application. However, I'm just guessing because I don't use that extension.
Was this helpful to you? 1
Quote

Question owner

Thank you for your support, jscher2000.

Thank you for your support, jscher2000.
Was this helpful to you?
Quote
Tyler Downer
  • Top 25 Contributor
  • Moderator
1529 solutions 10654 answers

Gabarito, It is a VERY bad idea to use old versions of any software. This is especially the case with a piece of software that manages your passwords. New versions will have fixed security issues and bugs that could expose your passwords.

Please update your software.

Gabarito, It is a VERY bad idea to use old versions of any software. This is especially the case with a piece of software that manages your passwords. New versions will have fixed security issues and bugs that could expose your passwords. Please update your software.
Was this helpful to you? 1
Quote
Tyler Downer
  • Top 25 Contributor
  • Moderator
1529 solutions 10654 answers

Also, please update to Firefox 67.0.4, there are very serious security issues in older versions of Firefox that have been fixed.

Also, please update to Firefox 67.0.4, there are very serious security issues in older versions of Firefox that have been fixed.

Modified by Tyler Downer

Was this helpful to you? 1
Quote

Question owner

Thank you, Tyler. I'll consider your advices and, maybe, change my minds.

Thank you, Tyler. I'll consider your advices and, maybe, change my minds.
Was this helpful to you?
Quote

Question owner

Meanwhile, if someone else has new tips/ideas, I'm interested to hear them.

Meanwhile, if someone else has new tips/ideas, I'm interested to hear them.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.