Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I always get the "You have chosen to open..." window

  • 2 replies
  • 1 has this problem
  • 3 views
  • Last reply by cor-el

more options

First, I'm on a mac running macOS Mojave 10.14.5 and Firefox Quantum 67.0.2. From what I gathered, there is an everlasting bug in Firefox that makes it always open a prompt "Opening xxx.xxx" window with various files. OK, but here's my problem: the "Do this automatically for files like this from now on." option is greyed out and I can't select it. If I go in Firefox Preferences/General/Applications, I do have pdf listed and a few others but no way to add another file type and corresponding action (for example add .dmg and select always downlad). I followed Firefox help and deleted handlers.json from my profile foler but that did nothing. So, maybe it's a bug, maybe I missed a setting... in any case this is the only place I found to write this and I hope there's a solution.

All Replies (2)

more options

The box is always grayed everywhere for any kind of download? Hmm, do you have Firefox set to never save history, or in other words, to use automatic private browsing? Just wondering if that could be related.


If you noticed this problem on a particular website, rather than everywhere, I would suggest:

Some websites do not send the PDF-specific Content-Type header (application/pdf) and then Firefox doesn't treat them like PDFs but instead like a generic kind of binary file. I created an add-on to work around that issue (when a file has a .pdf extension, it corrects the content-type):

https://addons.mozilla.org/firefox/addon/content-type-fixer/

I suggest keeping it turned off, and turning it on when you get to a site with that problem.

more options

You can also try to use the Web Console on Network Monitor to check requests and response headers for these files.