Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Leave tabs in place

  • 6 replies
  • 1 has this problem
  • Last reply by cor-el

more options

I have Win 10 and Firefox67.0.1. I understand that Firefox has done away with tabbed browsing because some users kept so many tabs open that their memory usage became excessive. I wanted to be able to keep a few tabs open while browsing (email, weather and a few other sites). I tried using the Pin Tab feature but found it would not work for my email or NOAA, though it did work for one Firefox help site. I also tried changing the browser tab item in about:config. (See uploaded image). I am in the process of slowly migrating to a more user friendly browser (Vivaldi), but before I change default browsers I thought I'd try one more time and ask if there is any way to restore the ability to keep a few tabs open in Firefox while browsing. Thanks for any help.

Attached screenshots

All Replies (6)

more options

From that screenshot your showing I left my settings default and have no issues with having more then one tab on the browser. I never had issue with multiple tabs open. I think what your referring to is a corrupted update or install of firefox that used excessive memory causing lags or freeze in the Browser. What you should really do is backup your bookmarks and then download the latest Browser based on your O/S bit version 32 to 32bit and 64 to 64bit Browser that way you insure the right Browser to the O/S. And then uninstall all firefox and delete the mozilla folder and then do a clean install. This will insure there is nothing to muk up the install so it works as intended. Then you can install your Addon/Extensions as needed.

more options

All of my updates to Firefox have been made automatically, and there have been no lags nor freezes in the browser. While I appreciate your suggestion, it seems to me a rather drastic process with no assurance of ultimate success. The settings change referred to in my above post was made at the suggestion of a reply to my earlier post on this problem. I will retain Firefox as a bookmark resource in the hope that some future update will address the problem I have and in the meantime use Vivaldi - or Opera. Thanks for your response.

more options

jfha said

I understand that Firefox has done away with tabbed browsing because some users kept so many tabs open that their memory usage became excessive.

No, that's not quite right. Like many people, I keep dozens of tabs open in Firefox 67. As far as I know, the only change was that Firefox will discard pages in inactive tabs when physical memory is getting full, to reduce paging to disk, meaning that those tabs need to be reloaded when you switch to them. You already know the setting to turn that off, and then Firefox 67 should work like 66 and earlier. No?

If your Firefox is having to unload tabs due to low memory, it would be worth figuring out why memory is getting so full. Is it because of Firefox using a lot of memory for sites with endless scrolling (like Facebook news feed), or due to other programs running at the same time?

more options

As the below image from my Task Manager indicates, I do not believe that I am using excess memory. This seems to be a typical reading, and as I indicated in my posting, I never kept more than two or three tabs open at the same time, so the Firefox change was of no benefit to me.

more options

8GB is plenty. What is the problem currently?

more options

You can check the Firefox Task Manager (about:performance) and about:memory pages for more info.

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window