Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox incredibly slow in site

  • 12 replies
  • 1 has this problem
  • 148 views
  • Last reply by jmss

more options

When accessing:

https://www.particulares.santandertotta.pt/pagina/indice/0,,276_1_2,00.html

Firefox gets extremely slow.

I tried restarting with all plugins/addons disabled and the behavior is the same.

I looked at Firefox's task manager and it indicates no problems at all with this tab.

Chromium has no problem with this site.

What could be wrong with Firefox?

All Replies (12)

more options

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

I cleaned the cookies for the the website and also all cache with no success.

Restarting in safe mode is what I previously did, also without success.

There are no animations in the site, how could this be related to graphics hardware?

I've used the site hundreds of times before without problems.

This seems a problem with Firefox. Does anyone from Mozilla care? If so, where should I report this?

more options

https://support.mozilla.org/kb/Clear+Recent+History#w_how-do-i-remove-a-single-website-from-my-history

Remove History For One Site

Open the History Manager <Control><Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any settings.

more options

Before I lose more information, did you try to access this site?

more options

It's not English so I can't sign-in.

more options

This is just a username/password login page, but you shouldn't have to do anything to notice the problem with the performance. You should notice your CPU usage going high for just displaying that page.

You can also try to type a few characters in the username text box ("nome de utilizador") and you should observe it takes some seconds to display each character, because the browser is heavily loaded.

Modified by jmss

more options

I used several versions of Firefox. No problem.

more options

This is with version 67.0.

Also happens in a private window.

Have you tried in GNU/Linux?

more options

I notice the same happening. I can't use the Inspector or other developer tools to check what goes on because the debugger gets activated by some JS file that contains a debugger statement. The page responds extremely slow to key presses, so some heavy JavaScript is running (I can scroll with the mouse, but not with the keyboard).

more options

Thanks, why is Chromium immune to this? Doesn't it run Javascript?

Do you run on GNU/Linux?

more options

Chosen Solution