X
Tap here to go to the mobile version of the site.

Support Forum

share camera and microphone

Posted

Using Firefox Developer 68.0b6 x64 on Windows 7

Trying to use Google Hangouts, but cannot share camera mic. Not prompted to, and FF settings wont allow adding web address to [permissions as per help in https://support.mozilla.org/en-US/kb/how-manage-your-camera-and-microphone-permissions.

What other options are there? Works fine in Opera, Chrome. Big disappointment that you guys have shut it out.

Using Firefox Developer 68.0b6 x64 on Windows 7 Trying to use Google Hangouts, but cannot share camera mic. Not prompted to, and FF settings wont allow adding web address to [permissions as per help in https://support.mozilla.org/en-US/kb/how-manage-your-camera-and-microphone-permissions. What other options are there? Works fine in Opera, Chrome. Big disappointment that you guys have shut it out.
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

More Information

McCoy
  • Top 10 Contributor
469 solutions 4269 answers

Hello PeterStrempel,

Could it be that you missed this in the article :

When you're on that site, click on the 'i' in a circle, next to the padlock at the left side of the address bar.

Then click on the little black arrow on the dropdown (next to 'Connection') and then on "More Information", which will take you to "Page Info".

Click on the 'Permissions" tab and scroll down to "Use the Camera". Uncheck "Use Default" and check "Allow".

Do the same for "Use the Microphone".

Then close and restart Firefox.

Hello PeterStrempel, Could it be that you missed this in the article : When you're on that site, click on the 'i' in a circle, next to the padlock at the left side of the address bar. Then click on the little black arrow on the dropdown (next to 'Connection') and then on "More Information", which will take you to "Page Info". Click on the 'Permissions" tab and scroll down to "Use the Camera". Uncheck "Use Default" and check "Allow". Do the same for "Use the Microphone". Then close and restart Firefox.
Was this helpful to you? 0
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17277 solutions 156167 answers

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content.

  • click the shield icon for more details and possibly disable the protection

You can check the Web Console about what content is blocked

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content. *make sure your extensions and filters are updated to the latest version *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content. *click the shield icon for more details and possibly disable the protection You can check the Web Console about what content is blocked *"3-bar" menu button or Tools -> Web Developer *https://support.mozilla.org/en-US/kb/tracking-protection *https://support.mozilla.org/en-US/kb/content-blocking
Was this helpful to you?
Quote

Question owner

Thank you McCoy. It was a good thought, but it doesn't solve the problem. See screen shots. First shows permissions granted, second shows still no choice of selecting my camera/mic (single unit).

Thank you McCoy. It was a good thought, but it doesn't solve the problem. See screen shots. First shows permissions granted, second shows still no choice of selecting my camera/mic (single unit).
Was this helpful to you?
Quote

Question owner

Thank you cor-el. My first suspicion was add-ons, so I disabled them all, restarted, and still no joy. As with McCoy, good thought, but no joy.

Thank you cor-el. My first suspicion was add-ons, so I disabled them all, restarted, and still no joy. As with McCoy, good thought, but no joy.
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
469 solutions 4269 answers

Would you please take a look at this :

https://appearin.helpscoutdocs.com/article/205-appear-in-isnt-selecting-camera-mic

Anything helpful there  ?

Would you please take a look at this : https://appearin.helpscoutdocs.com/article/205-appear-in-isnt-selecting-camera-mic Anything helpful there ?
Was this helpful to you? 0
Quote

Question owner

Thanks McCoy. Went through the doc very carefully. The only suggestion that worked was to use a different browser. Firefox stubbornly refuses to recognise my webcam/mic, though the microphone checks out in appear.in.

No problem in Chtrome or Opera. Camera recognised without fiddling. Trouble is, both those browsers are as graceful as Godzilla when it comes to resource footprint.

Thanks McCoy. Went through the doc very carefully. The only suggestion that worked was to use a different browser. Firefox stubbornly refuses to recognise my webcam/mic, though the microphone checks out in appear.in. No problem in Chtrome or Opera. Camera recognised without fiddling. Trouble is, both those browsers are as graceful as Godzilla when it comes to resource footprint.
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
469 solutions 4269 answers

This will probably have nothing to do with your current problem, but as Google Hangouts uses WebRTC, it doesn't hurt to give it a shot anyway :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar and look for the preference :

media.peerconnection.enabled

Make sure its value is set to true.

In case you had to change the value, then close and restart Firefox.

This will probably have nothing to do with your current problem, but as Google Hangouts uses WebRTC, it doesn't hurt to give it a shot anyway : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar and look for the preference : '''media.peerconnection.enabled''' Make sure its value is set to '''true'''. In case you had to change the value, then close and restart Firefox.
Was this helpful to you? 0
Quote

Question owner

Thanks McCoy. It was enabled/true.

Thanks McCoy. It was enabled/true.
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
469 solutions 4269 answers

PeterStrempel said

Thanks McCoy. It was enabled/true.

Bummer - I can't stand it that we don't seem to be able to get this to work ......  :(

I just looked at your second screenshot again - what happens when you click on those little black arrows next to "Default Video Device" and "Default Audio Device"  ? Nothing  ?

''PeterStrempel [[#answer-1227058|said]]'' <blockquote> Thanks McCoy. It was enabled/true. </blockquote> Bummer - I can't stand it that we don't seem to be able to get this to work ...... :( I just looked at your second screenshot again - what happens when you click on those little black arrows next to "Default Video Device" and "Default Audio Device" ? Nothing ?
Was this helpful to you? 0
Quote
McCoy
  • Top 10 Contributor
469 solutions 4269 answers

Another stab in the dark :

Have you set Shockwave Flash to "Always Activate" in 3-bar menu => Add-ons => Plugins  ?

Another stab in the dark : Have you set Shockwave Flash to "Always Activate" in 3-bar menu => Add-ons => Plugins ?
Was this helpful to you? 0
Quote

Question owner

McCoy said

PeterStrempel said
Thanks McCoy. It was enabled/true.

Bummer - I can't stand it that we don't seem to be able to get this to work ......  :(

I just looked at your second screenshot again - what happens when you click on those little black arrows next to "Default Video Device" and "Default Audio Device"  ? Nothing  ?

That's right, McCoy. Nothing. No other options are displayed (the way they are in Chrome and Opera).

''McCoy [[#answer-1227060|said]]'' <blockquote> ''PeterStrempel [[#answer-1227058|said]]'' <blockquote> Thanks McCoy. It was enabled/true. </blockquote> Bummer - I can't stand it that we don't seem to be able to get this to work ...... :( I just looked at your second screenshot again - what happens when you click on those little black arrows next to "Default Video Device" and "Default Audio Device" ? Nothing ? </blockquote> That's right, McCoy. Nothing. No other options are displayed (the way they are in Chrome and Opera).
Was this helpful to you?
Quote

Question owner

McCoy said

Another stab in the dark : Have you set Shockwave Flash to "Always Activate" in 3-bar menu => Add-ons => Plugins  ?

Set to always activate, restarted FF. No change to Hangouts. Don't know what it means elsewhere yet. Thanks for persisting. I just don't think this is going to work. I have no clue why not. Camera is easily detected by Skype and its own software, plus Chrome and Opera. FF just doesn't want to know about it.

''McCoy [[#answer-1227061|said]]'' <blockquote> Another stab in the dark : Have you set Shockwave Flash to "Always Activate" in 3-bar menu => Add-ons => Plugins ? </blockquote> Set to always activate, restarted FF. No change to Hangouts. Don't know what it means elsewhere yet. Thanks for persisting. I just don't think this is going to work. I have no clue why not. Camera is easily detected by Skype and its own software, plus Chrome and Opera. FF just doesn't want to know about it.
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
469 solutions 4269 answers

I'm baffled .....

I just remembered that yesterday there was this OP wanting to know how to get rid of the camera and mic icon - using Google Hangouts with Firefox :

https://support.mozilla.org/en-US/questions/1260743

So, that proves that it does work  !

I just can't figure out why it won't work for you.

I sure hope that somebody else will come up with an explanation and the perfect solution for you (fingers crossed).

I'm baffled ..... I just remembered that yesterday there was this OP wanting to know how to get rid of the camera and mic icon - using Google Hangouts with Firefox : https://support.mozilla.org/en-US/questions/1260743 So, that proves that it ''does'' work ! I just can't figure out why it won't work for you. I sure hope that somebody else will come up with an explanation and the perfect solution for you (fingers crossed).
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
469 solutions 4269 answers

Just thought of something :

You're using Firefox Developer 68.0b6 - would you consider switching to the regular, stable Firefox version  ?

Who knows ....... (you can always switch back)


And just thought of yet another thing:

A bit far-fetched maybe, but would you please check your settings here (if you haven't already) :

Options => Privacy & Security => Content Blocking

https://support.mozilla.org/en-US/kb/content-blocking

Just thought of something : You're using Firefox Developer 68.0b6 - would you consider switching to the regular, stable Firefox version ? Who knows ....... (you can always switch back) ------------------------------------------------------------------------------------------ And just thought of yet another thing: A bit far-fetched maybe, but would you please check your settings here (if you haven't already) : Options => Privacy & Security => Content Blocking https://support.mozilla.org/en-US/kb/content-blocking
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17277 solutions 156167 answers

Helpful Reply

Try to create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

Try to create a new profile to test if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues
Was this helpful to you? 1
Quote

Question owner

McCoy said

Just thought of something : You're using Firefox Developer 68.0b6 - would you consider switching to the regular, stable Firefox version  ? Who knows ....... (you can always switch back)

Switching to Firefox vanilla would defeat the purpose. Content blocking is set to standard, and the site info dialogue does not permit removing content blocking for 'this site' on hangouts, entirely contrary to the help doc at https://support.mozilla.org/en-US/kb/content-blocking?as=u&utm_source=inproduct#w_turn-content-blocking-off-on-individual-sites.

Cor-el is onto something. See below, and thank you for all your help. Please keep ideas coming if you have them. And just thought of yet another thing:

A bit far-fetched maybe, but would you please check your settings here (if you haven't already) :

Options => Privacy & Security => Content Blocking

https://support.mozilla.org/en-US/kb/content-blocking

''McCoy [[#answer-1227075|said]]'' <blockquote> Just thought of something : You're using Firefox Developer 68.0b6 - would you consider switching to the regular, stable Firefox version ? Who knows ....... (you can always switch back) ------------------------------------------------------------------------------------------ Switching to Firefox vanilla would defeat the purpose. Content blocking is set to standard, and the site info dialogue does not permit removing content blocking for 'this site' on hangouts, entirely contrary to the help doc at https://support.mozilla.org/en-US/kb/content-blocking?as=u&utm_source=inproduct#w_turn-content-blocking-off-on-individual-sites. Cor-el is onto something. See below, and thank you for all your help. Please keep ideas coming if you have them. And just thought of yet another thing: A bit far-fetched maybe, but would you please check your settings here (if you haven't already) : Options => Privacy & Security => Content Blocking https://support.mozilla.org/en-US/kb/content-blocking </blockquote>

Modified by PeterStrempel

Was this helpful to you?
Quote

Question owner

cor-el said

Try to create a new profile to test if your current profile is causing the problem. See "Creating a profile":


Yes, cor-el. A new profile prompts me to share camera/mic, and then shows these among several options in the Hangouts settings dialogue. Camera works (it switches on and displays what it is supposed to even without making a call).

The question now is whether I really want to blow away my existing profile to start afresh and run the risk that not all of my data will save or import correctly into a new profile.

Tips or advice on that, cor-el and McCoy?

''cor-el [[#answer-1227103|said]]'' <blockquote> Try to create a new profile to test if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues </blockquote> Yes, cor-el. A new profile prompts me to share camera/mic, and then shows these among several options in the Hangouts settings dialogue. Camera works (it switches on and displays what it is supposed to even without making a call). The question now is whether I really want to blow away my existing profile to start afresh and run the risk that not all of my data will save or import correctly into a new profile. Tips or advice on that, cor-el and McCoy?
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
469 solutions 4269 answers

I'm so glad that you finally got things working (thanks to cor-el) - it was about time, eh  ?

As for your last question : I'm leaving you in the capable hands of cor-el.

I'm so glad that you finally got things working (thanks to cor-el) - it was about time, eh ? As for your last question : I'm leaving you in the capable hands of cor-el.
Was this helpful to you?
Quote

Question owner

Listen, thanks guys for all your help, but just read a report that Google will discontinue its Hangout chat app next year, and the video app is probably not far behind. That means I'm not gonna fiddle with FF Dev. Will use another browser until Google f*!#s us over once more.

Again, thank you both for your persistence and suggestions.

Listen, thanks guys for all your help, but just read a report that Google will discontinue its Hangout chat app next year, and the video app is probably not far behind. That means I'm not gonna fiddle with FF Dev. Will use another browser until Google f*!#s us over once more. Again, thank you both for your persistence and suggestions.

Modified by PeterStrempel

Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
469 solutions 4269 answers

Here are some alternatives to Hangouts ......

Here are some [https://www.google.nl/search?authuser=1&source=hp&ei=ttD0XMqsB9HVwALQypXICg&q=alternative+for+Google+Hangouts%3F&oq=alternative+for+Google+Hangouts%3F&gs_l=psy-ab.12..0i22i30l2.1330.10710..11182...0.0..0.252.2297.31j1j1......0....1..gws-wiz.....0..0i67j0j35i39j0i20i263.m4VAvMwhhzE alternatives] to Hangouts ......
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.