X
Tap here to go to the mobile version of the site.

Support Forum

Connection is not secure error, when using a local trusted Root CA in the domain.

Posted

We are using a local root CA in a domain and the certificate is example.local. When accessing this website we're still having the Connection is not secure error. Strangely enough this is not happening on other browsers.

We also tried to manually import the Root CA certificate in the FF certificate manager.

We are using a local root CA in a domain and the certificate is example.local. When accessing this website we're still having the Connection is not secure error. Strangely enough this is not happening on other browsers. We also tried to manually import the Root CA certificate in the FF certificate manager.
Quote

Additional System Details

Installed Plug-ins

none

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.103 Safari/537.36

More Information

jscher2000
  • Top 10 Contributor
8690 solutions 71031 answers

Helpful Reply

Hi mvassallo, what is the error code? You might need to click the "Advanced" or "More information" button (the one to the right of the Go Back button in the page) to access that.

As you may recall, the Certificate Manager dialog on the Options page has several tabs. Make sure you import into the Authorities tab.

Hi mvassallo, what is the error code? You might need to click the "Advanced" or "More information" button (the one to the right of the Go Back button in the page) to access that. As you may recall, the Certificate Manager dialog on the Options page has several tabs. Make sure you import into the Authorities tab.
Was this helpful to you? 1
Quote

Helpful Reply

Hi Thanks for your reply. Yes we did import the root CA in the Authorities tab. Could this be because the certificate domain is published for .local? Chrome recognizes this cert and does not prompt for any security warning. We want to implement this acception for firefox via GPO if there is no fix for it.

Hi Thanks for your reply. Yes we did import the root CA in the Authorities tab. Could this be because the certificate domain is published for .local? Chrome recognizes this cert and does not prompt for any security warning. We want to implement this acception for firefox via GPO if there is no fix for it.
Was this helpful to you? 1
Quote
jscher2000
  • Top 10 Contributor
8690 solutions 71031 answers

What error code are you getting?

Also, we probably should move your question to the "Firefox for Enterprise" forum where you could hopefully attract a response from someone more familiar with Firefox's Group Policy features.

What error code are you getting? Also, we probably should move your question to the "Firefox for Enterprise" forum where you could hopefully attract a response from someone more familiar with Firefox's Group Policy features.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17469 solutions 157871 answers

Quote: we probably should move your question to the "Firefox for Enterprise" forum

I was thinking the same when I noticed this question and will move it over to "Firefox for Enterprise".

Quote: ''we probably should move your question to the "Firefox for Enterprise" forum'' I was thinking the same when I noticed this question and will move it over to "Firefox for Enterprise".
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17469 solutions 157871 answers

Do you see the certificate added to the certificate chain when this certificate is imported in the Certificate Manager?

Any luck with importing root certificates from the Windows certificate storage?

You can set this pref to true on the about:config page to import root certificate(s) from the Windows certificate store (there is a policy available, so this is merely a quick test).

  • security.enterprise_roots.enabled = true
Do you see the certificate added to the certificate chain when this certificate is imported in the Certificate Manager? Any luck with importing root certificates from the Windows certificate storage? You can set this pref to true on the <b>about:config</b> page to import root certificate(s) from the Windows certificate store (there is a policy available, so this is merely a quick test). *security.enterprise_roots.enabled = true
Was this helpful to you?
Quote

Question owner

Thanks all for your help! :)

Unfortunately these still did not solve the issue. Is there a way how to force Firefox to trust the local cert stores?

Thanks all for your help! :) Unfortunately these still did not solve the issue. Is there a way how to force Firefox to trust the local cert stores?
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.