Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

No matter the topic, the search bar responds with error even with typing in Google

  • 3 replies
  • 1 has this problem
  • 19 views
  • Last reply by JRM

more options

I recently made Firefox my default browser and in the search bar or the address bar, matters not, any topic typed in renders a result of "error. " To locate anything, I have to resort to either Safari or Google within their browsers. I like the Firefox browser but with this kind of glitch I may have made a mistake in using FFF as my default browser. Any help would be appreciated. thank you.

Chosen solution

Hi n7qx, what does the error page say? For example:

  • Not able to make a secure connection
  • Server not found or address not valid
  • Something else

Does the error page indicate that your search was sent to a different search site, not Google?

Thank you for sharing your add-ons list. There's one called "Smart Search" which might be a hijacker. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that mentions search, looks suspicious or that you just do not remember installing, should be disabled (or removed).

Any improvement?

Note: After removing a hijacker, you might need to reselect your preferred search engine. This article has the steps to check that Firefox is set to send your searches to Google or whatever site you prefer: Change your default search settings in Firefox.

Read this answer in context 👍 1

All Replies (3)

more options

Chosen Solution

Hi n7qx, what does the error page say? For example:

  • Not able to make a secure connection
  • Server not found or address not valid
  • Something else

Does the error page indicate that your search was sent to a different search site, not Google?

Thank you for sharing your add-ons list. There's one called "Smart Search" which might be a hijacker. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that mentions search, looks suspicious or that you just do not remember installing, should be disabled (or removed).

Any improvement?

Note: After removing a hijacker, you might need to reselect your preferred search engine. This article has the steps to check that Firefox is set to send your searches to Google or whatever site you prefer: Change your default search settings in Firefox.

more options

Thanks for the info. I solved it but after comparing the extensions on my laptop and my desktop I found on the desk top that one or both of the weather extensions seemed to interfere with everything. I went to my laptop ( has fewer extensions) and did a search and all worked out well. So I went back to the desktop and deleted all but one extension, my password manager, and then did a search and it worked fine. So I began adding in extensions to see if any of the ones I added interfered and thus far none has. And I also have identical extensions now on both computers. Thanks for the advice.

more options

n7qx said

Thanks for the info. I solved it but after comparing the extensions on my laptop and my desktop I found on the desk top that one or both of the weather extensions seemed to interfere with everything. I went to my laptop ( has fewer extensions) and did a search and all worked out well. So I went back to the desktop and deleted all but one extension, my password manager, and then did a search and it worked fine. So I began adding in extensions to see if any of the ones I added interfered and thus far none has. And I also have identical extensions now on both computers. Thanks for the advice. Note: I do not use any of the weather extensions as I have the NOAA site in the toolbar and don't need other weather apps.