X
Tap here to go to the mobile version of the site.

Support Forum

New version opens Firefox local instead of Firefox portable even though it is explicitly set in attachments/incoming and Windows default browser

Posted

I have both Firefox installed locally and Firefox Portable which is opened and used as default all the time. I have explicitly set Firefox Portable as the default browser in Windows, and also in attachments/incoming in TB settings. Ever since TB Portable 60.7.0 it opens a new local Firefox instance or tab within an already opened local instance no matter what. This is new and wrong behaviour.

I have both Firefox installed locally and Firefox Portable which is opened and used as default all the time. I have explicitly set Firefox Portable as the default browser in Windows, and also in attachments/incoming in TB settings. Ever since TB Portable 60.7.0 it opens a new local Firefox instance or tab within an already opened local instance no matter what. This is new and wrong behaviour.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

More Information

jscher2000
  • Top 10 Contributor
8783 solutions 71835 answers

Helpful Reply

The Firefox 67 update may have changed the default handling for URLs because it now uses your default profile in all cases instead of using the running instance of Firefox.

Could you double-check in Windows 10 settings to see whether it is possible to elect Portable to handle links instead of regular Firefox? For example, in the Windows 10 system search box, type protocol to load the control panel for setting default apps by protocol. Then scroll down to HTTP and HTTPS and see what you can set there.

Any improvement?

Note: if Thunderbird has a separate setting for this, I can't check that because I don't have it on this computer.

The Firefox 67 update may have changed the default handling for URLs because it now uses your default profile in all cases instead of using the running instance of Firefox. Could you double-check in Windows 10 settings to see whether it is possible to elect Portable to handle links instead of regular Firefox? For example, in the Windows 10 system search box, type ''protocol'' to load the control panel for setting default apps by protocol. Then scroll down to HTTP and HTTPS and see what you can set there. Any improvement? ''Note: if Thunderbird has a separate setting for this, I can't check that because I don't have it on this computer.''

Question owner

Thanks for the reply. I tried your protocol suggestions (good one, thanks) but to no avail. Sorry for the duplicate. And I may not have been entirely clear, so let me clarify: I am using *Thunderbird* and want to open a link from an incoming mail. In TB one can set attachments/incoming for text, http etc which is the recommended method with pretty much all Google results. Now as I can't find a specific setting for opening links in mails, I assume the OS setting is the one to look for, but I can try all settings (Windows shows 2 times Firebird w/o further specification, tried both for both protocols) to no avail. As said, this is new with Thunderbird (Portable) version 60.7.0. Thanks again for your help.

Thanks for the reply. I tried your protocol suggestions (good one, thanks) but to no avail. Sorry for the duplicate. And I may not have been entirely clear, so let me clarify: I am using *Thunderbird* and want to open a link from an incoming mail. In TB one can set attachments/incoming for text, http etc which is the recommended method with pretty much all Google results. Now as I can't find a specific setting for opening links in mails, I assume the OS setting is the one to look for, but I can try all settings (Windows shows 2 times Firebird w/o further specification, tried both for both protocols) to no avail. As said, this is new with Thunderbird (Portable) version 60.7.0. Thanks again for your help.