X
Tap here to go to the mobile version of the site.

Support Forum

firefox open with my home page and theme font, ghostery and adblocker

Posted

After Foxfox update 64.0.3 when I open Firefox my home page opens (Startpage) then theme font & size changer, Ghostery, and Adblock open in new tabs. Running Mac OS High Sierra.

I have completely removed Firefox and all addons using app clean and reload Firefox and my addons. I done the reset home page in about:config. This works until a reboot. I have tried to disable the addons and figure out if one or all is causing the problem. The three addons are displaying as if I were to download them again and reinstall the addons. I have run a malware problems with no problems.

I have another identical Mac that does not have this problems. I have been thinking about reloading software and do a clean install, but this is very time consuming. I have searched the web unable to find a solution.

In preferences my home page does not show multiple urls.

I did go back to my backup and load firefox before the 64.0.3 update and firefox ran with no problems.

Suggestions????!!!!!

After Foxfox update 64.0.3 when I open Firefox my home page opens (Startpage) then theme font & size changer, Ghostery, and Adblock open in new tabs. Running Mac OS High Sierra. I have completely removed Firefox and all addons using app clean and reload Firefox and my addons. I done the reset home page in about:config. This works until a reboot. I have tried to disable the addons and figure out if one or all is causing the problem. The three addons are displaying as if I were to download them again and reinstall the addons. I have run a malware problems with no problems. I have another identical Mac that does not have this problems. I have been thinking about reloading software and do a clean install, but this is very time consuming. I have searched the web unable to find a solution. In preferences my home page does not show multiple urls. I did go back to my backup and load firefox before the 64.0.3 update and firefox ran with no problems. Suggestions????!!!!!

Chosen solution

Again I wish to thank all who made suggestions to my problem. Today I reloaded the mac OS. Before reloading the OS, I used appclean to remove Firefox. After the reload, restore, download of Firefox, and added my extensions the problem is solved, so far. About the time the new version of Firefox was made available, I must have has some type of software glitch that was interfering with Firefox.

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

FredMcD
  • Top 10 Contributor
4188 solutions 58467 answers

It’s possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Delete all extensions* files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files":

+++++++++++++++++++++++++++ You will have to approve the updating one last time.

It’s possible that there is a problem with the file(s) that store the extensions registry. Type '''about:support''' in the address bar and press enter. Under the page logo on the left side, you will see '''Application Basics. ''' Under this find '''Profile Folder. ''' To its right press the button '''Show Folder. ''' This will open your file browser to the current Firefox profile. Now '''Close Firefox. ''' Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder '''Linux: ''' Under the page logo on the left side, you will see '''Application Basics.''' Under this find '''Profile Directory. ''' To its right press the button '''Open Directory. ''' Delete all '''extensions*''' files and '''compatibility.ini''' in the Firefox profile folder to reset the extensions registry. *https://support.mozilla.org/kb/Profiles New files will be created when required. After, restart Firefox. See "Corrupt extension files": *http://kb.mozillazine.org/Unable_to_install_themes_or_extensions *https://support.mozilla.org/kb/Unable+to+install+add-ons +++++++++++++++++++++++++++ You will have to approve the updating one last time.
Was this helpful to you?
Quote

Question owner

FredMcD said

It’s possible that there is a problem with the file(s) that store the extensions registry. Type about:support in the address bar and press enter. Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox. Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory. Delete all extensions* files and compatibility.ini in the Firefox profile folder to reset the extensions registry. New files will be created when required. After, restart Firefox. See "Corrupt extension files": +++++++++++++++++++++++++++ You will have to approve the updating one last time.
''FredMcD [[#answer-1223207|said]]'' <blockquote> It’s possible that there is a problem with the file(s) that store the extensions registry. Type '''about:support''' in the address bar and press enter. Under the page logo on the left side, you will see '''Application Basics. ''' Under this find '''Profile Folder. ''' To its right press the button '''Show Folder. ''' This will open your file browser to the current Firefox profile. Now '''Close Firefox. ''' Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder '''Linux: ''' Under the page logo on the left side, you will see '''Application Basics.''' Under this find '''Profile Directory. ''' To its right press the button '''Open Directory. ''' Delete all '''extensions*''' files and '''compatibility.ini''' in the Firefox profile folder to reset the extensions registry. *https://support.mozilla.org/kb/Profiles New files will be created when required. After, restart Firefox. See "Corrupt extension files": *http://kb.mozillazine.org/Unable_to_install_themes_or_extensions *https://support.mozilla.org/kb/Unable+to+install+add-ons +++++++++++++++++++++++++++ You will have to approve the updating one last time. </blockquote>
Was this helpful to you?
Quote

Question owner

Thank your trying. When I deleted the extensions. I then had to reinstall my addons. After a reboot the problem came back.

Thank your trying. When I deleted the extensions. I then had to reinstall my addons. After a reboot the problem came back.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17341 solutions 156762 answers

You would only have to remove the extensions.json file (and previously used extensions.sqlite and extensions.ini), but not the extensions folder that stores your extensions.

You can check for problems with preferences.

  • delete possible user.js and numbered prefs-##.js files and rename/remove the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

You would only have to remove the extensions.json file (and previously used extensions.sqlite and extensions.ini), but not the extensions folder that stores your extensions. You can check for problems with preferences. *delete possible user.js and numbered prefs-##.js files and rename/remove the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox
Was this helpful to you?
Quote

Question owner

Tried all the above without success. Again, I thank you for trying. I will reload mac os soon and see if this corrects the problem.

Tried all the above without success. Again, I thank you for trying. I will reload mac os soon and see if this corrects the problem.
Was this helpful to you?
Quote

Chosen Solution

Again I wish to thank all who made suggestions to my problem. Today I reloaded the mac OS. Before reloading the OS, I used appclean to remove Firefox. After the reload, restore, download of Firefox, and added my extensions the problem is solved, so far. About the time the new version of Firefox was made available, I must have has some type of software glitch that was interfering with Firefox.

Again I wish to thank all who made suggestions to my problem. Today I reloaded the mac OS. Before reloading the OS, I used appclean to remove Firefox. After the reload, restore, download of Firefox, and added my extensions the problem is solved, so far. About the time the new version of Firefox was made available, I must have has some type of software glitch that was interfering with Firefox.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4188 solutions 58467 answers

That was very good work. Well done. Please flag your last post as Solved Problem as this could help others with the same problem.

That was very good work. Well done. Please flag your last post as '''Solved Problem''' as this could help others with the same problem.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.