X
Tap here to go to the mobile version of the site.

Support Forum

Getting screen full of symbols when accessing Facebook from Firefox

Posted

Anyone seeing this? Seems to be somewhat intermittent. I.E. works with no problem.

Here's a screenshot of trying to access Facebook.

Anyone seeing this? Seems to be somewhat intermittent. I.E. works with no problem. Here's a screenshot of trying to access Facebook.
Attached screenshots

Modified by caladie

Chosen solution

The old workaround is to reduce the compression options Firefox suggests to websites. You could test this, but Kaspersky should have updated to be compatible after this first popped up back in 2016:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste enco and pause while the list is filtered

(3) Double-click the network.http.accept-encoding.secure preference and edit as follows: delete the , br from the end so it just reads gzip, deflate like the preference above it in the list, and then click OK

What that does is stop Firefox from telling Facebook it can use "Brotli" compression. Facebook will use the older gzip form of compression instead.

Does that give you readable pages?

Meanwhile, please check for updates to your Kaskpersky product.

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

Question owner

Adding screenshot.

Adding screenshot.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

Looks like a problem with fonts.

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1

Looks like a problem with fonts. Type '''about:preferences#content'''<enter> in the address bar. Across from '''fonts and colors,''' press the '''Advanced''' button. On the bottom, turn on '''Allow Web Sites To Choose Their Own.''' Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17466 solutions 157836 answers

Websites like Google and Facebook and YouTube have enabled Brotli (br) encoding for files send via a secure connection. Some (security) software intercepts a secure connection and acts like a man-in-the-middle to scan content and may not recognize this encoding and changes the content-type header to text/plain. This causes Firefox to display compressed content as gibberish instead of rendering the decompressed content. You can check the issuer of the certificate to see what software is interfering with the connection and places itself as a "man-in-the-middle" between Firefox and the web server. Make sure to have the latest updates of this software and possibly contact them for support.

Websites like Google and Facebook and YouTube have enabled Brotli (br) encoding for files send via a secure connection. Some (security) software intercepts a secure connection and acts like a man-in-the-middle to scan content and may not recognize this encoding and changes the content-type header to text/plain. This causes Firefox to display compressed content as gibberish instead of rendering the decompressed content. You can check the issuer of the certificate to see what software is interfering with the connection and places itself as a "man-in-the-middle" between Firefox and the web server. Make sure to have the latest updates of this software and possibly contact them for support.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8684 solutions 70998 answers

Helpful Reply

cor-el said

You can check the issuer of the certificate to see what software is interfering with the connection and places itself as a "man-in-the-middle" between Firefox and the web server.

In case you are wondering how to do that, there are two ways to get to the "View Certificate" button:

(1) Click the green lock in the address bar, then the > on the Connection row, then the More Information link at the bottom of the next panel. That should pop up the Page Info dialog to the Security tab. Then click the "View Certificate" button.

(2) Right-click the page and click View Page Info. Then in the Page Info dialog, click Security at the top. Then click the "View Certificate" button.

For Facebook, I see this in the Issued by section. How about yours?

''cor-el [[#answer-1222376|said]]'' <blockquote> You can check the issuer of the certificate to see what software is interfering with the connection and places itself as a "man-in-the-middle" between Firefox and the web server. </blockquote> In case you are wondering how to do that, there are two ways to get to the "View Certificate" button: (1) Click the green lock in the address bar, then the > on the Connection row, then the More Information link at the bottom of the next panel. That should pop up the Page Info dialog to the Security tab. Then click the "View Certificate" button. (2) Right-click the page and click View Page Info. Then in the Page Info dialog, click Security at the top. Then click the "View Certificate" button. For Facebook, I see this in the Issued by section. How about yours? <img src="https://prod-cdn.sumo.mozilla.net/uploads/images/2019-05-14-15-10-48-3dd395.png" width="500">
Was this helpful to you? 1
Quote

Question owner

OK, if I read this correctly, "cor-el" is saying that my Anti-Virus software is the man in the middle. My AV software is Kaspersky and I have never had this problem in the past. Seems like it just cropped up when Mozilla had it's recent update and patch for the add-ons. I use "AdBlock Plus" but I've tried disabling it and restarting Firefox and that does not fix the issue. Two keys seem to be that if I click on the green lock and clear cookies, I can get to the login page for Facebook, then it blows up when I enter my login credentials. If I go to clear those cookies, it logs me out and I'm in a catch 22. The second key is that I can log in if I use the I.E. browser. Unfortunately, I do not want to use I.E. FWIW, here is the Certificate from the green lock click in Firefox. Thanks to "jscher 2000" for the help to find the Cert info.

OK, if I read this correctly, "cor-el" is saying that my Anti-Virus software is the man in the middle. My AV software is Kaspersky and I have never had this problem in the past. Seems like it just cropped up when Mozilla had it's recent update and patch for the add-ons. I use "AdBlock Plus" but I've tried disabling it and restarting Firefox and that does not fix the issue. Two keys seem to be that if I click on the green lock and clear cookies, I can get to the login page for Facebook, then it blows up when I enter my login credentials. If I go to clear those cookies, it logs me out and I'm in a catch 22. The second key is that I can log in if I use the I.E. browser. Unfortunately, I do not want to use I.E. FWIW, here is the Certificate from the green lock click in Firefox. Thanks to "jscher 2000" for the help to find the Cert info.
Was this helpful to you?
Quote

Question owner

FredMcD said

Looks like a problem with fonts. Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own. Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1

FWIW, that option is already checked. Thank you

''FredMcD [[#answer-1222372|said]]'' <blockquote> Looks like a problem with fonts. Type '''about:preferences#content'''<enter> in the address bar. Across from '''fonts and colors,''' press the '''Advanced''' button. On the bottom, turn on '''Allow Web Sites To Choose Their Own.''' Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1 </blockquote> FWIW, that option is already checked. Thank you

Modified by caladie

Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8684 solutions 70998 answers

Chosen Solution

The old workaround is to reduce the compression options Firefox suggests to websites. You could test this, but Kaspersky should have updated to be compatible after this first popped up back in 2016:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste enco and pause while the list is filtered

(3) Double-click the network.http.accept-encoding.secure preference and edit as follows: delete the , br from the end so it just reads gzip, deflate like the preference above it in the list, and then click OK

What that does is stop Firefox from telling Facebook it can use "Brotli" compression. Facebook will use the older gzip form of compression instead.

Does that give you readable pages?

Meanwhile, please check for updates to your Kaskpersky product.

The old workaround is to reduce the compression options Firefox suggests to websites. You could test this, but Kaspersky should have updated to be compatible after this first popped up back in 2016: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''enco''' and pause while the list is filtered (3) Double-click the '''network.http.accept-encoding.secure''' preference and edit as follows: delete the ''', br''' from the end so it just reads '''gzip, deflate''' like the preference above it in the list, and then click OK What that does is stop Firefox from telling Facebook it can use "Brotli" compression. Facebook will use the older gzip form of compression instead. Does that give you readable pages? Meanwhile, please check for updates to your Kaskpersky product.
Was this helpful to you? 1
Quote

Question owner

OK, I edited the "Brotli" encoding (, br) and the pages load in readable format.

Is this a 'new' problem? Will I, should I, add that encoding back in at some point?

Did Facebook just start using the Brotli encoding?

I guess my overall question is, why now, and what do I do going forward, along with, what other items might be affected?

Thank you for your help "jscher 2000". You were right on the mark for this. issue.

OK, I edited the "Brotli" encoding (, br) and the pages load in readable format. Is this a 'new' problem? Will I, should I, add that encoding back in at some point? Did Facebook just start using the Brotli encoding? I guess my overall question is, why now, and what do I do going forward, along with, what other items might be affected? Thank you for your help "jscher 2000". You were right on the mark for this. issue.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8684 solutions 70998 answers

Hi caladie, this first occurred in mid-2016, but all the major security programs should have been updated within a few months thereafter. That is why it is a surprise to see it with a modern version of Kaspersky. Please raise the issue with them.

Hi caladie, this first occurred in mid-2016, but all the major security programs should have been updated within a few months thereafter. That is why it is a surprise to see it with a modern version of Kaspersky. Please raise the issue with them.
Was this helpful to you?
Quote

Question owner

OK, I will present it to Kaspersky after I test my Facebook connection from my other machines. They are not running Kaspersky. I didn't do that already because I didn't suspect a AV software problem. If you're correct, I can re-enable the "Brotli" and temporarily disable Kaspersky and FB should work, correctly?

OK, I will present it to Kaspersky after I test my Facebook connection from my other machines. They are not running Kaspersky. I didn't do that already because I didn't suspect a AV software problem. If you're correct, I can re-enable the "Brotli" and temporarily disable Kaspersky and FB should work, correctly?
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8684 solutions 70998 answers

Yes, this article has some steps to stop Kaspersky filtering your Firefox browsing: How to troubleshoot security error codes on secure websites.

Yes, this article has some steps to stop Kaspersky filtering your Firefox browsing: [[How to troubleshoot security error codes on secure websites]].
Was this helpful to you?
Quote

Question owner

jscher2000 said

Hi caladie, this first occurred in mid-2016, but all the major security programs should have been updated within a few months thereafter. That is why it is a surprise to see it with a modern version of Kaspersky. Please raise the issue with them.

I made a misstatement, and now things are a little more confusing. My other machine is running the same version of Kaspersky and Windows and Firefox, but it logs into Facebook with no "about:config - enco" edit for Brotli. I already marked your edit as the solution and since it did work, I will leave it but since my other machine works "as is" I hesitate to contact Kaspersky unless I find some way to differentiate between the two machines handling of the encoding. Perhaps it's a video driver issue on the machine with the issue?

''jscher2000 [[#answer-1222504|said]]'' <blockquote> Hi caladie, this first occurred in mid-2016, but all the major security programs should have been updated within a few months thereafter. That is why it is a surprise to see it with a modern version of Kaspersky. Please raise the issue with them. </blockquote> I made a misstatement, and now things are a little more confusing. My other machine is running the same version of Kaspersky and Windows and Firefox, but it logs into Facebook with no "about:config - enco" edit for Brotli. I already marked your edit as the solution and since it did work, I will leave it but since my other machine works "as is" I hesitate to contact Kaspersky unless I find some way to differentiate between the two machines handling of the encoding. Perhaps it's a video driver issue on the machine with the issue?
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8684 solutions 70998 answers

Any difference in the Kaspersky settings for filtering web pages?

Any difference in the Kaspersky settings for filtering web pages?
Was this helpful to you?
Quote

Question owner

jscher2000 said

Any difference in the Kaspersky settings for filtering web pages?

Hello jscher 2000,

I guess all bets are off. I checked my other machine and it did not have the issue, although the issue was borderline intermittent. When I experienced it recently it was almost all the time.

Since testing my other machine I decided to edit the Brotli setting in the enco line and re-insert the ",br".

Then the conditions changed, Microsoft did an automatic update during my next reboot for their own unstated reasons.

Now I no longer have the issue (at least for the time being). I rebooted my other machine and it also did the Microsoft update. Since that machine worked before the update, there is no direct connection to the disappearance of my symptoms.

In my gut, I believe the changing of the ",br" parameter had something to do with the problem disappearance. It would not be the first time (by a long shot) that setting something in the Microsoft system environment did not actually have the effect the setting should have, then magically, you alter the setting and return it to where it was again and viola, the setting is properly in effect.

At this point I prefer to "let sleeping dogs lie". Thank you for your help and pointers.

''jscher2000 [[#answer-1222520|said]]'' <blockquote> Any difference in the Kaspersky settings for filtering web pages? </blockquote> Hello jscher 2000, I guess all bets are off. I checked my other machine and it did not have the issue, although the issue was borderline intermittent. When I experienced it recently it was almost all the time. Since testing my other machine I decided to edit the Brotli setting in the enco line and re-insert the ",br". Then the conditions changed, Microsoft did an automatic update during my next reboot for their own unstated reasons. Now I no longer have the issue (at least for the time being). I rebooted my other machine and it also did the Microsoft update. Since that machine worked before the update, there is no direct connection to the disappearance of my symptoms. In my gut, I believe the changing of the ",br" parameter had something to do with the problem disappearance. It would not be the first time (by a long shot) that setting something in the Microsoft system environment did not actually have the effect the setting should have, then magically, you alter the setting and return it to where it was again and viola, the setting is properly in effect. At this point I prefer to "let sleeping dogs lie". Thank you for your help and pointers.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17466 solutions 157836 answers

Maybe there was another software that linked in the connection chain that caused it because just like jscher2000 I find it hard to believe that current Kaspersky versions would be responsible. Only quite old software from years ago or possibly proxy software would cause this to happen.

Maybe there was another software that linked in the connection chain that caused it because just like jscher2000 I find it hard to believe that current Kaspersky versions would be responsible. Only quite old software from years ago or possibly proxy software would cause this to happen.
Was this helpful to you?
Quote

Question owner

cor-el,

I didn't think it was Kaspersky either. As I mentioned, I have seen problems corrected by multiple reboots in the past because the settings don't always "stick" the first time or even the first few times they're applied in Microsoft environments.

Not too long ago I had a setting where I'd remove Firefox and when I reinstalled it, it was not listed to be selected as my default browser. After several reboots, viola, it is back in the list. I don't trust Microsoft as far as I can throw a grand piano.

What can I say, the ",br" is back in the enco line and the problem is no longer occurring.

cor-el, I didn't think it was Kaspersky either. As I mentioned, I have seen problems corrected by multiple reboots in the past because the settings don't always "stick" the first time or even the first few times they're applied in Microsoft environments. Not too long ago I had a setting where I'd remove Firefox and when I reinstalled it, it was not listed to be selected as my default browser. After several reboots, viola, it is back in the list. I don't trust Microsoft as far as I can throw a grand piano. What can I say, the ",br" is back in the enco line and the problem is no longer occurring.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.