X
Tap here to go to the mobile version of the site.

Support Forum

Android Add-ons, "Add to Firefox" button replaced with "Only with Firefox-Get Firefox Now" Firefox is already install and I'm currently using it. Help please?

Posted

I recently noticed my Firefox Android Ad blocker (Adblocker Plus) was not working. I went into the Add-ons and firefox said it wasn't verified or something like that. I figured I'd just search again for Ad block extensions and install one that worked. The problem I am seeing now is that no add-ons can be installed. The button to add the extension to Firefox on my Samsung S8 is not present.

The only button available on all add-ons says "Only with Firefox-Get Firefox Now". I thought maybe this was a glitch with me having selected "Request Desktop Site" but that box is not checked and toggling it did not resolve the issue with the website not recognizing I am browsing their website with my already installed Android Version of Firefox.

If you follow the only available "Only with Firefox-Get Firefox Now" button it guides you to a page that has a "Download Firefox" button. If you click that button, it loops you to the previous page that lead you to the "Download Firefox" button page. It is a loop that doesn't address the issue Firefox website is not recognizing its own browser and preventing all Add-ons at for Firefox Android. See images attached regarding what I'm seeing.

I recently noticed my Firefox Android Ad blocker (Adblocker Plus) was not working. I went into the Add-ons and firefox said it wasn't verified or something like that. I figured I'd just search again for Ad block extensions and install one that worked. The problem I am seeing now is that no add-ons can be installed. The button to add the extension to Firefox on my Samsung S8 is not present. The only button available on all add-ons says "Only with Firefox-Get Firefox Now". I thought maybe this was a glitch with me having selected "Request Desktop Site" but that box is not checked and toggling it did not resolve the issue with the website not recognizing I am browsing their website with my already installed Android Version of Firefox. If you follow the only available "Only with Firefox-Get Firefox Now" button it guides you to a page that has a "Download Firefox" button. If you click that button, it loops you to the previous page that lead you to the "Download Firefox" button page. It is a loop that doesn't address the issue Firefox website is not recognizing its own browser and preventing all Add-ons at for Firefox Android. See images attached regarding what I'm seeing.
Attached screenshots

Chosen solution

First, could you install the latest Firefox for Android update from Google Play? That should resolve the issue of installed add-ons being disabled due to an unverifiable signature. After that your Firefox for Android should be version 66.0.5. You can view your version number under:

menu button > Settings > Mozilla Firefox (way at the bottom) > About Firefox

Second, it sounds as though possibly you are requesting the desktop version of the site, which changes how Firefox identifies itself, more specifically, it changes the user agent string to the Linux OS instead of Android.

My test page here shows your browser's user agent string in red:

https://www.jeffersonscher.com/res/jstest.php

If it doesn't look something like this, it's probably been changed:

Mozilla/5.0 (Android 8.0.0; Mobile; rv:66.0) Gecko/66.0 Firefox/66.0

As an example of the settings involved in changing it, check out this thread: I use a 12.2" Galaxy Tab. Need a way to automatically go to websites in desktop view, always.

Read this answer in context 0
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

More Information

jscher2000
  • Top 10 Contributor
8507 solutions 69505 answers

Chosen Solution

First, could you install the latest Firefox for Android update from Google Play? That should resolve the issue of installed add-ons being disabled due to an unverifiable signature. After that your Firefox for Android should be version 66.0.5. You can view your version number under:

menu button > Settings > Mozilla Firefox (way at the bottom) > About Firefox

Second, it sounds as though possibly you are requesting the desktop version of the site, which changes how Firefox identifies itself, more specifically, it changes the user agent string to the Linux OS instead of Android.

My test page here shows your browser's user agent string in red:

https://www.jeffersonscher.com/res/jstest.php

If it doesn't look something like this, it's probably been changed:

Mozilla/5.0 (Android 8.0.0; Mobile; rv:66.0) Gecko/66.0 Firefox/66.0

As an example of the settings involved in changing it, check out this thread: I use a 12.2" Galaxy Tab. Need a way to automatically go to websites in desktop view, always.

First, could you install the latest Firefox for Android update from Google Play? That should resolve the issue of installed add-ons being disabled due to an unverifiable signature. After that your Firefox for Android should be version 66.0.5. You can view your version number under: menu button > Settings > Mozilla Firefox (way at the bottom) > About Firefox Second, it sounds as though possibly you are requesting the desktop version of the site, which changes how Firefox identifies itself, more specifically, it changes the user agent string to the Linux OS instead of Android. My test page here shows your browser's user agent string in red: https://www.jeffersonscher.com/res/jstest.php If it doesn't look something like this, it's probably been changed: Mozilla/5.0 (Android 8.0.0; Mobile; rv:66.0) Gecko/66.0 Firefox/66.0 As an example of the settings involved in changing it, check out this thread: [https://support.mozilla.org/questions/1222890 I use a 12.2" Galaxy Tab. Need a way to automatically go to websites in desktop view, always.]
Was this helpful to you?
Quote

Question owner

Firefox was already updated to the latest version.

That said I forgot that I had gone into about:config and added the general.useragent.override (That was an attempt to get basic information from a website that refused to load in desktop view and couldn't be accessed with the mobile version of the site when Firefox refuses to load the desktop version even when instructed in the android Firefox browser. And unfortunately for me, the override never work on the website I wanted to use it for regardless of which user agent string I told it to load and I never could get the User Manual I needed downloaded.)

Resetting that override resolved the issue regarding Add-ons.

Thanks, I would have forgotten this change without being reminded about it via reading your reply.

(That said, I still hope one day Firefox will be able to load desktop views for all websites. It is super annoying to know where links are, but we can't access them on our mobile devices too.)

Firefox was already updated to the latest version. That said I forgot that I had gone into about:config and added the general.useragent.override (That was an attempt to get basic information from a website that refused to load in desktop view and couldn't be accessed with the mobile version of the site when Firefox refuses to load the desktop version even when instructed in the android Firefox browser. And unfortunately for me, the override never work on the website I wanted to use it for regardless of which user agent string I told it to load and I never could get the User Manual I needed downloaded.) Resetting that override resolved the issue regarding Add-ons. Thanks, I would have forgotten this change without being reminded about it via reading your reply. (That said, I still hope one day Firefox will be able to load desktop views for all websites. It is super annoying to know where links are, but we can't access them on our mobile devices too.)
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.