Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I get rid of the page thumbail showing upon the bookmarks list when bookmarking ?

  • 7 replies
  • 2 have this problem
  • 42 views
  • Last reply by jiff

more options

Hi folks,

I just switched from esr to v.66 but I don't like the thumbnail displayed on top of the list when bookmarking. As I use a laptop with a small screen, this useless stuff eats my list's place.

How can I get rid of it ?

And BTW, as this list is already made longer using a: <profile>/chrome/userChrome.css file, is there a way to make everything other than the list itself (button ,etc) smaller ?

All Replies (7)

more options

Hi jiff, what rules are you using in your userChrome.css for the drop-down panel? This thread has the extra bits for the large thumbnail image:

https://support.mozilla.org/questions/1232360

more options

jscher2000 said

https://support.mozilla.org/questions/1232360

Hi jscher2000, thanks to you as it worked for the snapshot, however if did not for the favicon :/

Tweaking a bit, I suppressed the bookmark's name 40px lower shift but it now collides with the favicon (why the hell did the devs chosed to display that here, do they think everybody's working on a 4k display?), which also takes a lot of place :/

So now I'm looking for a way to rid of the favicon and (if possible) the upper text line that is also totally useless ("New bookmark" or "Edit this bookmark".)

more options

Do you use the @namespace at the top of your userChrome.css file? If so, you need a variation. I had a link to that in the other post, but you may have missed the significance of that. The variation has a few extra characters before the second selector to work around the limiting effects of declaring the XUL namespace:

/* Hide Giant Thumbnail and Favicon */
#editBookmarkPanelImage,
*|div#editBookmarkPanelFaviconContainer {
  display: none !important;
}

https://support.mozilla.org/questions/1232360#answer-1152038

more options

The selector for the panel header is:

#editBookmarkPanel .panel-header

(Added "before and after" screenshot)

Modified by jscher2000

more options

jscher2000 said

*|div

https://support.mozilla.org/questions/1232360#answer-1152038

Yes, that did the trick, thanks! :) Although, about the header's line, I'd like to completely get rid of it, not put it downwards.

My userChrome.css now looks like that:

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* set default namespace to XUL */
  1. editBMPanel_folderTree { min-height: 21em !important; }
/* NOTE: AS OF V.esr, IT WAS: 27em */
  1. editBookmarkPanelImage,
  • |div#editBookmarkPanelFaviconContainer {
display: none !important; }
more options

I'm not sure what you mean here:

jiff said

Although, about the header's line, I'd like to completely get rid of it, not put it downwards.

Isn't it hidden if you add the third selector:

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* set default namespace to XUL */

#editBMPanel_folderTree { min-height: 21em !important; }
/* NOTE: AS OF V.esr, IT WAS: 27em */

#editBookmarkPanelImage, 
*|div#editBookmarkPanelFaviconContainer,
#editBookmarkPanel .panel-header {
  display: none !important;
}
more options

Oops, I thought it was just to move it up/down.

I added it and now everything's working as wanted, thanks jscher2000.