X
Tap here to go to the mobile version of the site.

Support Forum

отключили дополнения?

Posted

Добрый день. Вы поотключали дополнения, при чем без всякого спроса. Вы подвергаете частную жизнь опасности, так как люди доверились Вам! Верните все как было, хотя бы для критически важных дополнений. UbLockMobile, noscript.

Добрый день. Вы поотключали дополнения, при чем без всякого спроса. Вы подвергаете частную жизнь опасности, так как люди доверились Вам! Верните все как было, хотя бы для критически важных дополнений. UbLockMobile, noscript.

Chosen solution

Sorry, a critical certificate used to verify add-ons expired.

As a temporary workaround, you can disable the add-on verification. I suggest setting it back after a real fix is announced.

(1) In a new tab, type or paste about:config in the address bar and submit that. Click the button promising to be careful or accepting the risk if presented.

(2) In the search box above the list, type or paste xpin and pause while the list is filtered

(3) Tap the xpinstall.signatures.required preference to trigger a Toggle button and tap Toggle to switch the value from true to false

Does that work on yours?

** EDIT **

Unfortunately, this creates the potential for a bad actor to serve Firefox an unsigned update, so it's definitely not a long-term fix. You can turn off extension auto-updating as a mitigation:

(4) In the search box above the list, type or paste autoup and pause while the list is filtered

(5) Tap the extensions.update.autoUpdateDefault preference to show a Toggle button, then tap Toggle to switch the value from true to false

Hopefully this won't be needed for very long.

Read this answer in context 0
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Android 7.1.1; Mobile; rv:66.0) Gecko/66.0 Firefox/66.0

More Information

jscher2000
  • Top 10 Contributor
8568 solutions 70052 answers

Chosen Solution

Sorry, a critical certificate used to verify add-ons expired.

As a temporary workaround, you can disable the add-on verification. I suggest setting it back after a real fix is announced.

(1) In a new tab, type or paste about:config in the address bar and submit that. Click the button promising to be careful or accepting the risk if presented.

(2) In the search box above the list, type or paste xpin and pause while the list is filtered

(3) Tap the xpinstall.signatures.required preference to trigger a Toggle button and tap Toggle to switch the value from true to false

Does that work on yours?

** EDIT **

Unfortunately, this creates the potential for a bad actor to serve Firefox an unsigned update, so it's definitely not a long-term fix. You can turn off extension auto-updating as a mitigation:

(4) In the search box above the list, type or paste autoup and pause while the list is filtered

(5) Tap the extensions.update.autoUpdateDefault preference to show a Toggle button, then tap Toggle to switch the value from true to false

Hopefully this won't be needed for very long.

Sorry, a critical certificate used to verify add-ons expired. As a temporary workaround, you can disable the add-on verification. I suggest setting it back after a real fix is announced. (1) In a new tab, type or paste '''about:config''' in the address bar and submit that. Click the button promising to be careful or accepting the risk if presented. (2) In the search box above the list, type or paste '''xpin''' and pause while the list is filtered (3) Tap the '''xpinstall.signatures.required''' preference to trigger a Toggle button and tap Toggle to switch the value from true to false Does that work on yours? '''** EDIT **''' Unfortunately, this creates the potential for a bad actor to serve Firefox an unsigned update, so it's definitely not a long-term fix. You can turn off extension auto-updating as a mitigation: (4) In the search box above the list, type or paste '''autoup''' and pause while the list is filtered (5) Tap the '''extensions.update.autoUpdateDefault''' preference to show a Toggle button, then tap Toggle to switch the value from true to false Hopefully this won't be needed for very long.

Modified by jscher2000

Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8568 solutions 70052 answers

As pointed out elsewhere, this settings change creates the potential for a bad actor to serve Firefox an unsigned update, so it's definitely not a long-term fix. You can turn off extension auto-updating as a mitigation. This would be added to the above:

(4) In the search box above the list, type or paste autoup and pause while the list is filtered

(5) Tap the extensions.update.autoUpdateDefault preference to show a Toggle button, then tap Toggle to switch the value from true to false

Hopefully this won't be needed for very long.

As pointed out elsewhere, this settings change creates the potential for a bad actor to serve Firefox an unsigned update, so it's definitely not a long-term fix. You can turn off extension auto-updating as a mitigation. This would be added to the above: (4) In the search box above the list, type or paste '''autoup''' and pause while the list is filtered (5) Tap the '''extensions.update.autoUpdateDefault''' preference to show a Toggle button, then tap Toggle to switch the value from true to false Hopefully this won't be needed for very long.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.