X
Tap here to go to the mobile version of the site.

Support Forum

Hotfix received, Marked as complete. Add-ons not yet enabled.

Posted

I've received the hotfix, and it was marked as "Complete" in the studies section, but it has not re-enabled my add-ons, and I can't enable them myself.

I've received the hotfix, and it was marked as "Complete" in the studies section, but it has not re-enabled my add-ons, and I can't enable them myself.

Chosen solution

great, thanks for reporting back & sorry for all the hassle. hope you're back on track now :))

Read this answer in context 0
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.90 Safari/537.36

More Information

philipp
  • Top 25 Contributor
  • Moderator
5251 solutions 23225 answers

hi, the hotfix comes in two parts and about:studies should look something like this:

hi, the hotfix comes in two parts and about:studies should look something like this:
Was this helpful to you?
Quote

Helpful Reply

@phillipp, I have push-performance and hotfix-reset-verification-timesfamp in completed. Nothing active.

@phillipp, I have push-performance and hotfix-reset-verification-timesfamp in completed. Nothing active.
Was this helpful to you? 1
Quote
philipp
  • Top 25 Contributor
  • Moderator
5251 solutions 23225 answers

can you check in the firefox options > privacy & security > view certificates > authorities that you have an entry from Mozilla Corporation/"signingca1.addons.mozilla.org" present there?

if not you can try the following - enter this code into the address bar and confirm to add the root cert into your browser (don't tick any boxes):

data:application/x-x509-ca-cert;base64,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
can you check in the firefox options > privacy & security > view certificates > authorities that you have an entry from Mozilla Corporation/"signingca1.addons.mozilla.org" present there? if not you can try the following - enter this code into the address bar and confirm to add the root cert into your browser (don't tick any boxes): <blockquote>data:application/x-x509-ca-cert;base64,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</blockquote>
Was this helpful to you?
Quote

Question owner

Hi there phillipp,

It was not present. I just added it, any other steps? Add-ons still not enabled.

Regards, George

Hi there phillipp, It was not present. I just added it, any other steps? Add-ons still not enabled. Regards, George
Was this helpful to you? 0
Quote
philipp
  • Top 25 Contributor
  • Moderator
5251 solutions 23225 answers

hm, not sure - is it possible to install extensions from addons.mozilla.org in this state at least?

hm, not sure - is it possible to install extensions from addons.mozilla.org in this state at least?
Was this helpful to you?
Quote

Question owner

philipp said

hm, not sure - is it possible to install extensions from addons.mozilla.org in this state at least?

Appears to be, old extensions still not working, and under normal circumstances, I'd uninstall and re-install, but I'd like to keep my configurations. Please keep me posted with any updates that might happen.

Cheers, George

''philipp [[#answer-1218494|said]]'' <blockquote> hm, not sure - is it possible to install extensions from addons.mozilla.org in this state at least? </blockquote> Appears to be, old extensions still not working, and under normal circumstances, I'd uninstall and re-install, but I'd like to keep my configurations. Please keep me posted with any updates that might happen. Cheers, George
Was this helpful to you?
Quote
philipp
  • Top 25 Contributor
  • Moderator
5251 solutions 23225 answers

i think the signature verification mechanism should kick in again once in the next 24h and mark addons as active again.

you could try if resetting the "app.update.lastUpdateTime.xpi-signature-verification" pref in about:config and restarting the browser (or setting it to "1556945257" as was done by one part of the hotfix) can speed this up.

i think the signature verification mechanism should kick in again once in the next 24h and mark addons as active again. you could try if resetting the "app.update.lastUpdateTime.xpi-signature-verification" pref in about:config and restarting the browser (or setting it to "1556945257" as was done by one part of the hotfix) can speed this up.
Was this helpful to you?
Quote

Question owner

Heya phillipp,

So, setting the last update timestamp to a future date and letting that time pass (I set it to about 10-15 seconds later) worked!

Cheers man!

Heya phillipp, So, setting the last update timestamp to a future date and letting that time pass (I set it to about 10-15 seconds later) worked! Cheers man!
Was this helpful to you?
Quote
philipp
  • Top 25 Contributor
  • Moderator
5251 solutions 23225 answers

Chosen Solution

great, thanks for reporting back & sorry for all the hassle. hope you're back on track now :))

great, thanks for reporting back & sorry for all the hassle. hope you're back on track now :))
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.