X
Tap here to go to the mobile version of the site.

Support Forum

restore legacy add-ons

Posted

Firefox does it again! "modernizing" and in the process trashing most of my add-ins. How to I tell FF to NOT do that ? Thx.

Firefox does it again! "modernizing" and in the process trashing most of my add-ins. How to I tell FF to NOT do that ? Thx.
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

metalman630 0 solutions 24 answers

Have you tried this yet? Go look at the crappy new ones...every time I try to add one "DOWNLOAD FAILED, CHECK YOUR CONNECTION". So, I go to work, my FF gets broken after about 10 minutes like this one...SAME THING. I can't download new themes or extensions on TWO PC's now.

SO, I go about uninstalling, download 65.0.2. Pull the internet (if you don't, FF will almost instantly UPDATE FF before you get to the "ask me" thing) and install. Guess what. 66.0.3 has apparently ETERNALLY broken ALL MY items. Google up how to override. I find something. BAAAAAA! Wrong answer, 66.0.3 REALLY HAS BROKEN EVERYTHING and you can't go back! Sure, i saw the page ..."it's still customizable"...BUT I CAN'T CUSTOMIZE IT!!!

Sounds like someone DIDN'T BETA this new version. HIGHLY SUGGEST you put out a new version that puts us ALL BACK TO WHERE WE WERE and beta this software!!!

Have you tried this yet? Go look at the crappy new ones...every time I try to add one "DOWNLOAD FAILED, CHECK YOUR CONNECTION". So, I go to work, my FF gets broken after about 10 minutes like this one...SAME THING. I can't download new themes or extensions on TWO PC's now. SO, I go about uninstalling, download 65.0.2. Pull the internet (if you don't, FF will almost instantly UPDATE FF before you get to the "ask me" thing) and install. Guess what. 66.0.3 has apparently ETERNALLY broken ALL MY items. Google up how to override. I find something. BAAAAAA! Wrong answer, 66.0.3 REALLY HAS BROKEN EVERYTHING and you can't go back! Sure, i saw the page ..."it's still customizable"...BUT I CAN'T CUSTOMIZE IT!!! Sounds like someone DIDN'T BETA this new version. HIGHLY SUGGEST you put out a new version that puts us ALL BACK TO WHERE WE WERE and beta this software!!!
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8577 solutions 70121 answers

Sorry, this was not intentional A critical Add-on-related certificate expired (which obviously should not happen). As a result, all verifications for that certificate are failing, which affects using, updating, and installing the affected extensions.

The Add-ons team is working on a fix for this. Official updates are expected to be posted here:

https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047

Currently, the only workaround is to set your system clock back (for example, if your date is May 3, set to May 2; if your date is May 4, set to May 3). You might have to reinstall extensions after that, or maybe Firefox will detect the difference at your next shut down/restart. Changing the date may have other consequences, so I understand this option isn't ideal.

Sorry, this was not intentional A critical Add-on-related certificate expired (which obviously should not happen). As a result, all verifications for that certificate are failing, which affects using, updating, and installing the affected extensions. The Add-ons team is working on a fix for this. Official updates are expected to be posted here: https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047 Currently, the only workaround is to set your system clock back (for example, if your date is May 3, set to May 2; if your date is May 4, set to May 3). You might have to reinstall extensions after that, or maybe Firefox will detect the difference at your next shut down/restart. Changing the date may have other consequences, so I understand this option isn't ideal.
Was this helpful to you?
Quote
Chris Ilias
  • Moderator
347 solutions 1918 answers

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps.

In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled

  1. Go to [=] > Options > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked.

I you had it disabled, you can disable studies again after your add-ons have been re-enabled.

They are working on a general fix that doesn't need to rely on this and will keep you updated.

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps. In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled # Go to '''[=] > Options > Privacy & Security'''. # Make sure '''Allow Firefox to install and run studies''' is check marked. I you had it disabled, you can disable studies again after your add-ons have been re-enabled. They are working on a general fix that doesn't need to rely on this and will keep you updated.
Was this helpful to you? 0
Quote

Question owner

Does that require a FF restart?

Does that require a FF restart?
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8577 solutions 70121 answers

Bill99 said

Does that require a FF restart?

The setting change should take effect immediately, but since Firefox only checks for new studies every six hours, the actual download may not occur right away. Exiting/Quitting Firefox and starting it back up again might hasten it, but we don't know.

''Bill99 [[#answer-1218628|said]]'' <blockquote> Does that require a FF restart? </blockquote> The setting change should take effect immediately, but since Firefox only checks for new studies every six hours, the actual download may not occur right away. Exiting/Quitting Firefox and starting it back up again might hasten it, but we don't know.
Was this helpful to you?
Quote

Question owner

Been well over 6 hrs. Even rebooted FF. No effect.

Been well over 6 hrs. Even rebooted FF. No effect.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8577 solutions 70121 answers

Hi Bill99, did you get the studies related to this fix, or did they never show up on the about:studies page?

If you got the studies, check whether the certificate was added. That would be on the Options/Preferences page:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type cert and Firefox should filter to the Certificates section. Then click the "View Certificates" button. Check the "Authorities" tab to see whether Mozilla is listed with the new certificate. You can compare the attached screenshot.

If you got not studies and no certificate, try the manual method listed in this reply and/or the ones that follow: https://support.mozilla.org/questions/1258208#answer-1218876

Hi Bill99, did you get the studies related to this fix, or did they never show up on the about:studies page? If you got the studies, check whether the certificate was added. That would be on the Options/Preferences page: * Windows: "3-bar" menu button (or Tools menu) > Options * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the search box at the top of the page, type ''cert'' and Firefox should filter to the '''Certificates''' section. Then click the "View Certificates" button. Check the "Authorities" tab to see whether Mozilla is listed with the new certificate. You can compare the attached screenshot. If you got not studies and no certificate, try the manual method listed in this reply and/or the ones that follow: https://support.mozilla.org/questions/1258208#answer-1218876
Was this helpful to you?
Quote

Question owner

Do not see Mozilla in certs. Have below in studies:

   p
   prefflip-push-performance-1491171•Active
   This study sets dom.push.alwaysConnect to true.

Completed studies

   h
   hotfix-reset-xpi-verification-timestamp-1548973•Complete
   This study sets app.update.lastUpdateTime.xpi-signature-verification to 1556945257.
   s
   pref-flip-screenshots-release-1369150•Complete
   This study sets extensions.screenshots.system-disabled to false.
Do not see Mozilla in certs. Have below in studies: p prefflip-push-performance-1491171•Active This study sets dom.push.alwaysConnect to true. Completed studies h hotfix-reset-xpi-verification-timestamp-1548973•Complete This study sets app.update.lastUpdateTime.xpi-signature-verification to 1556945257. s pref-flip-screenshots-release-1369150•Complete This study sets extensions.screenshots.system-disabled to false.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8577 solutions 70121 answers

Helpful Reply

If the certificate was not added successfully by the hotfix, try the manual methods in the thread I linked to earlier.

If the certificate was not added successfully by the hotfix, try the manual methods in the thread I linked to earlier.
Was this helpful to you? 1
Quote

Question owner

Tried the manual (first option), restarted. No change; most add-ons listed as disabled. Sigh.

Tried the manual (first option), restarted. No change; most add-ons listed as disabled. Sigh.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8577 solutions 70121 answers

Bill99 said

Tried the manual (first option), restarted. No change; most add-ons listed as disabled. Sigh.

Hmm, I only tested that on Firefox 52, and Firefox did a fresh verification less than a minute after starting. I haven't tested on Firefox 66 because I didn't need to. Maybe I'll have to test it tomorrow.

''Bill99 [[#answer-1219137|said]]'' <blockquote> Tried the manual (first option), restarted. No change; most add-ons listed as disabled. Sigh. </blockquote> Hmm, I only tested that on Firefox 52, and Firefox did a fresh verification less than a minute after starting. I haven't tested on Firefox 66 because I didn't need to. Maybe I'll have to test it tomorrow.
Was this helpful to you?
Quote

Question owner

Said it was already installed, but went ahead with the rest of the instructions. Seems OK now, as some of my add-ons are back working. Thx!

Said it was already installed, but went ahead with the rest of the instructions. Seems OK now, as some of my add-ons are back working. Thx!
Was this helpful to you?
Quote
Seburo
  • Top 10 Contributor
  • Moderator
714 solutions 5240 answers

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

Hello, I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.