X
Tap here to go to the mobile version of the site.

Support Forum

Do you like to anger your users?

Posted

Tonight I go on Firefox and now all my add-ons are gone. No warning, no explanation. I want my add-ons back! Fadebook Purity to control the FB monster. Ad block to control the out of control ads. I will be searching for another browser! Your ruined Firefox, thank you very much!

Tonight I go on Firefox and now all my add-ons are gone. No warning, no explanation. I want my add-ons back! Fadebook Purity to control the FB monster. Ad block to control the out of control ads. I will be searching for another browser! Your ruined Firefox, thank you very much!

Chosen solution

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps.

In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled

  1. Go to [=] > Options > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked.

I you had it disabled, you can disable studies again after your add-ons have been re-enabled.

They are working on a general fix that doesn't need to rely on this and will keep you updated.

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

jscher2000
  • Top 10 Contributor
8637 solutions 70648 answers

Helpful Reply

Sorry, it's not intentional. A critical certificate expired (which obviously should not happen). The Add-ons team is working on a fix for this. Official updates are expected to be posted here:

https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047

Currently, the only workaround is to set your system clock back (for example, if your date is May 3, set to May 2; if your date is May 4, set to May 3). You might have to reinstall extensions after that, or maybe Firefox will detect the difference at your next shut down/restart. Changing the date may have other consequences, so this option isn't ideal.

Sorry, it's not intentional. A critical certificate expired (which obviously should not happen). The Add-ons team is working on a fix for this. Official updates are expected to be posted here: https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047 Currently, the only workaround is to set your system clock back (for example, if your date is May 3, set to May 2; if your date is May 4, set to May 3). You might have to reinstall extensions after that, or maybe Firefox will detect the difference at your next shut down/restart. Changing the date may have other consequences, so this option isn't ideal.
Was this helpful to you? 1
Quote
Chris Ilias
  • Moderator
353 solutions 1941 answers

Chosen Solution

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps.

In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled

  1. Go to [=] > Options > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked.

I you had it disabled, you can disable studies again after your add-ons have been re-enabled.

They are working on a general fix that doesn't need to rely on this and will keep you updated.

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps. In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled # Go to '''[=] > Options > Privacy & Security'''. # Make sure '''Allow Firefox to install and run studies''' is check marked. I you had it disabled, you can disable studies again after your add-ons have been re-enabled. They are working on a general fix that doesn't need to rely on this and will keep you updated.
Was this helpful to you? 1
Quote

Question owner

Thanks for this info. Minutes after I made the suggested change I had my addons back and working fine. Thanks for the fix and quick response!

May I also offer an apology for the way in which I posted this issue. I was thinking Firefox was making big changes without notifying its users.

Thanks for this info. Minutes after I made the suggested change I had my addons back and working fine. Thanks for the fix and quick response! May I also offer an apology for the way in which I posted this issue. I was thinking Firefox was making big changes without notifying its users.

Modified by chzuck

Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.