X
Tap here to go to the mobile version of the site.

Support Forum

Cannot use Bling

Posted

An update of FireFox to day is now not allowing me to use the Bling wallpaper as an opening page

An update of FireFox to day is now not allowing me to use the Bling wallpaper as an opening page

Chosen solution

Hello phebas,

Could it be that you're talking about this add-on  ?

https://addons.mozilla.org/en-US/firefox/addon/bing-wallpaper-downloader/?src=search

If so, would you contact the developer please  ?

(Support Email under "More information")

But maybe I misconstrued your question ..... (?)

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

jscher2000
  • Top 10 Contributor
8758 solutions 71658 answers

Hmm, I wonder if your home page got changed. Is it still

https://www.bing.com/

or is a different page loading? This article might help if you need to update that setting: How to set the home page.

Hmm, I wonder if your home page got changed. Is it still https://www.bing.com/ or is a different page loading? This article might help if you need to update that setting: [[How to set the home page]].
McCoy
  • Top 10 Contributor
545 solutions 5139 answers

Chosen Solution

Hello phebas,

Could it be that you're talking about this add-on  ?

https://addons.mozilla.org/en-US/firefox/addon/bing-wallpaper-downloader/?src=search

If so, would you contact the developer please  ?

(Support Email under "More information")

But maybe I misconstrued your question ..... (?)

Hello phebas, Could it be that you're talking about this add-on ? https://addons.mozilla.org/en-US/firefox/addon/bing-wallpaper-downloader/?src=search If so, would you contact the developer please ? (Support Email under "More information") But maybe I misconstrued your question ..... (?)

Question owner

Thanks to both parties for replying to my query. It's the bling wallpaper downloader I needed. Thanks a lot McCoy!

Thanks to both parties for replying to my query. It's the bling wallpaper downloader I needed. Thanks a lot McCoy!
McCoy
  • Top 10 Contributor
545 solutions 5139 answers

phebas said

Thanks a lot McCoy!

My pleasure, phebas  !

''phebas [[#answer-1217828|said]]'' <blockquote> Thanks a lot McCoy! </blockquote> My pleasure, phebas !

Question owner

Problem not solved after all! I can access the bing-wallpaper addon however I cannot find this as an allowable extension which I can add to Firefox. My original problem of accessing bling.com as wallpaper-of-the-day still elicits the response "www.bing.com has a security policy called HTTP Strict Transport Security (HSTS), which means that Firefox can only connect to it securely. You can’t add an exception to visit this site"

How do I resolve this? thanks, Tony

Problem not solved after all! I can access the bing-wallpaper addon however I cannot find this as an allowable extension which I can add to Firefox. My original problem of accessing bling.com as wallpaper-of-the-day still elicits the response "www.bing.com has a security policy called HTTP Strict Transport Security (HSTS), which means that Firefox can only connect to it securely. You can’t add an exception to visit this site" How do I resolve this? thanks, Tony
jscher2000
  • Top 10 Contributor
8758 solutions 71658 answers

Hi Tony, if you click the "Advanced" button on the error page, can you find an error code similar to SEC_ERROR_SOMETHING that would help in pinpointing the problem? This article should help with that code, or let us know what it is: How to troubleshoot security error codes on secure websites.

Hi Tony, if you click the "Advanced" button on the error page, can you find an error code similar to SEC_ERROR_SOMETHING that would help in pinpointing the problem? This article should help with that code, or let us know what it is: [[How to troubleshoot security error codes on secure websites]].

Question owner

The problem appears to be certificate related. How do I solve this?

"Web sites prove their identity via certificates. Firefox does not trust www.bing.com because its certificate issuer is unknown, the certificate is self-signed, or the server is not sending the correct intermediate certificates.


Error code: SEC_ERROR_UNKNOWN_ISSUER"

The problem appears to be certificate related. How do I solve this? "Web sites prove their identity via certificates. Firefox does not trust www.bing.com because its certificate issuer is unknown, the certificate is self-signed, or the server is not sending the correct intermediate certificates. Error code: SEC_ERROR_UNKNOWN_ISSUER"
cor-el
  • Top 10 Contributor
  • Moderator
17525 solutions 158458 answers

Did you already update to Firefox 66.0.5 ?

Did you already update to Firefox 66.0.5 ? *https://support.mozilla.org/en-US/kb/update-firefox-latest-version *Help -> About Firefox
cor-el
  • Top 10 Contributor
  • Moderator
17525 solutions 158458 answers

You can check if there is more detail available about the issuer of the certificate.

  • click the "Advanced" button show more detail
  • click the blue error text (SEC_ERROR_UNKNOWN_ISSUER) to show the certificate chain
  • click "Copy text to clipboard" and paste the base64 certificate chain text in a reply

If clicking the blue error text doesn't provide the certificate chain then try these steps to inspect the certificate.

  • open the Servers tab in the Certificate Manager
    • Options/Preferences -> Privacy & Security
      Certificates: View Certificates -> Servers: "Add Exception"
  • paste the URL of the website (https://xxx.xxx) in it's Location field

Let Firefox retrieve the certificate -> "Get Certificate"

  • click the "View" button and inspect the certificate

You can find detail like the issuer of the certificate and intermediate certificates in the Details tab.

See also:

You can check if there is more detail available about the issuer of the certificate. *click the "Advanced" button show more detail *click the blue error text (SEC_ERROR_UNKNOWN_ISSUER) to show the certificate chain *click "Copy text to clipboard" and paste the base64 certificate chain text in a reply If clicking the blue error text doesn't provide the certificate chain then try these steps to inspect the certificate. *open the Servers tab in the Certificate Manager **Options/Preferences -> Privacy & Security<br>Certificates: View Certificates -> Servers: "Add Exception" *paste the URL of the website (https://xxx.xxx) in it's Location field Let Firefox retrieve the certificate -> "Get Certificate" *click the "View" button and inspect the certificate You can find detail like the issuer of the certificate and intermediate certificates in the Details tab. See also: *https://support.mozilla.org/en-US/kb/error-codes-secure-websites

Question owner

https://bing.com/

Peer's Certificate issuer is not recognised.

HTTP Strict Transport Security: true HTTP Public Key Pinning: false

Certificate chain:


BEGIN CERTIFICATE-----

MIIH3zCCBsegAwIBAgIRANyq88czSp1aSsd7E+2bS6EwDQYJKoZIhvcNAQELBQAw KzELMAkGA1UEBhMCRU4xHDAaBgNVBAMME0FkZ3VhcmQgUGVyc29uYWwgQ0EwHhcN MTcwNzIwMTc0NzA4WhcNMTkwNzEwMTc0NzA4WjAXMRUwEwYDVQQDEwx3d3cuYmlu Zy5jb20wgZ8wDQYJKoZIhvcNAQEBBQADgY0AMIGJAoGBAOX3jbq/d6JIf2e/aQkF LpYXANOo9xPsGddFeEc2L3zq6gTxykdeopZpidOoTYTKTJCDNdEeTFFIHmkNtTZn dSShdeHME2ruxC65vID7/1a6tH+iUe5wflTX8Cjv2S4hDiy3Lw3X/QVuP4Zizflb 6X8mNPpXLsRfqGyfOnGIn7TRAgMBAAGjggWUMIIFkDCCBW0GA1UdEQSCBWQwggVg ggx3d3cuYmluZy5jb22CEGRpY3QuYmluZy5jb20uY26CEyoucGxhdGZvcm0uYmlu Zy5jb22CCiouYmluZy5jb22CCGJpbmcuY29tghZpZW9ubGluZS5taWNyb3NvZnQu Y29tghMqLndpbmRvd3NzZWFyY2guY29tghljbi5pZW9ubGluZS5taWNyb3NvZnQu Y29tghEqLm9yaWdpbi5iaW5nLmNvbYINKi5tbS5iaW5nLm5ldIIOKi5hcGkuYmlu Zy5jb22CGGVjbi5kZXYudmlydHVhbGVhcnRoLm5ldIINKi5jbi5iaW5nLm5ldIIN Ki5jbi5iaW5nLmNvbYIQc3NsLWFwaS5iaW5nLmNvbYIQc3NsLWFwaS5iaW5nLm5l dIIOKi5hcGkuYmluZy5uZXSCDiouYmluZ2FwaXMuY29tgg9iaW5nc2FuZGJveC5j b22CFmZlZWRiYWNrLm1pY3Jvc29mdC5jb22CG2luc2VydG1lZGlhLmJpbmcub2Zm aWNlLm5ldIIOci5iYXQuYmluZy5jb22CECouci5iYXQuYmluZy5jb22CEiouZGlj dC5iaW5nLmNvbS5jboIPKi5kaWN0LmJpbmcuY29tgg4qLnNzbC5iaW5nLmNvbYIQ Ki5hcHBleC5iaW5nLmNvbYIWKi5wbGF0Zm9ybS5jbi5iaW5nLmNvbYINd3AubS5i aW5nLmNvbYIMKi5tLmJpbmcuY29tgg9nbG9iYWwuYmluZy5jb22CEXdpbmRvd3Nz ZWFyY2guY29tgg5zZWFyY2gubXNuLmNvbYIRKi5iaW5nc2FuZGJveC5jb22CGSou YXBpLnRpbGVzLmRpdHUubGl2ZS5jb22CDyouZGl0dS5saXZlLmNvbYIYKi50MC50 aWxlcy5kaXR1LmxpdmUuY29tghgqLnQxLnRpbGVzLmRpdHUubGl2ZS5jb22CGCou dDIudGlsZXMuZGl0dS5saXZlLmNvbYIYKi50My50aWxlcy5kaXR1LmxpdmUuY29t ghUqLnRpbGVzLmRpdHUubGl2ZS5jb22CCzNkLmxpdmUuY29tghNhcGkuc2VhcmNo LmxpdmUuY29tghRiZXRhLnNlYXJjaC5saXZlLmNvbYIVY253ZWIuc2VhcmNoLmxp dmUuY29tggxkZXYubGl2ZS5jb22CDWRpdHUubGl2ZS5jb22CEWZhcmVjYXN0Lmxp dmUuY29tgg5pbWFnZS5saXZlLmNvbYIPaW1hZ2VzLmxpdmUuY29tghFsb2NhbC5s aXZlLmNvbS5hdYIUbG9jYWxzZWFyY2gubGl2ZS5jb22CFGxzNGQuc2VhcmNoLmxp dmUuY29tgg1tYWlsLmxpdmUuY29tghFtYXBpbmRpYS5saXZlLmNvbYIObG9jYWwu bGl2ZS5jb22CDW1hcHMubGl2ZS5jb22CEG1hcHMubGl2ZS5jb20uYXWCD21pbmRp YS5saXZlLmNvbYINbmV3cy5saXZlLmNvbYIcb3JpZ2luLmNud2ViLnNlYXJjaC5s aXZlLmNvbYIWcHJldmlldy5sb2NhbC5saXZlLmNvbYIPc2VhcmNoLmxpdmUuY29t ghJ0ZXN0Lm1hcHMubGl2ZS5jb22CDnZpZGVvLmxpdmUuY29tgg92aWRlb3MubGl2 ZS5jb22CFXZpcnR1YWxlYXJ0aC5saXZlLmNvbYIMd2FwLmxpdmUuY29tghJ3ZWJt YXN0ZXIubGl2ZS5jb22CE3dlYm1hc3RlcnMubGl2ZS5jb22CFXd3dy5sb2NhbC5s aXZlLmNvbS5hdYIUd3d3Lm1hcHMubGl2ZS5jb20uYXUwHQYDVR0lBBYwFAYIKwYB BQUHAwIGCCsGAQUFBwMBMA0GCSqGSIb3DQEBCwUAA4IBAQBxekR6+sSATzMwjITz kxyF+YjchD8RQvKHVKT6rE8YdaoPjWUJzutI8FnDQd0YIOeag3fzUY1J8r7CF7YK irbGAE4vT9ZLnG6FyIxln2DeUM1wWC05VneAJvcEbali08K/EaoaC8YCQmxcdWUo wEi1SJfPyyFxjASC5+AkOD6aAaL+JjNH7xMSZ05CS9AwnrNFax2KaWK6GV0fT0Ax p54ZkwYoA0Dg/soy3P7pU3TN7z6oRz0M1BdF1wnWyal4pGKmLXDAKOIEo/nodPZs Bc+pSdVG/qu/q5QH1xN7VYI025zwrCzPkC/EHYj0PX1UVU8Rr9jdmQQlojJAp35+ Myov


END CERTIFICATE-----
https://bing.com/ Peer's Certificate issuer is not recognised. HTTP Strict Transport Security: true HTTP Public Key Pinning: false Certificate chain: -----BEGIN CERTIFICATE----- MIIH3zCCBsegAwIBAgIRANyq88czSp1aSsd7E+2bS6EwDQYJKoZIhvcNAQELBQAw KzELMAkGA1UEBhMCRU4xHDAaBgNVBAMME0FkZ3VhcmQgUGVyc29uYWwgQ0EwHhcN MTcwNzIwMTc0NzA4WhcNMTkwNzEwMTc0NzA4WjAXMRUwEwYDVQQDEwx3d3cuYmlu Zy5jb20wgZ8wDQYJKoZIhvcNAQEBBQADgY0AMIGJAoGBAOX3jbq/d6JIf2e/aQkF LpYXANOo9xPsGddFeEc2L3zq6gTxykdeopZpidOoTYTKTJCDNdEeTFFIHmkNtTZn dSShdeHME2ruxC65vID7/1a6tH+iUe5wflTX8Cjv2S4hDiy3Lw3X/QVuP4Zizflb 6X8mNPpXLsRfqGyfOnGIn7TRAgMBAAGjggWUMIIFkDCCBW0GA1UdEQSCBWQwggVg ggx3d3cuYmluZy5jb22CEGRpY3QuYmluZy5jb20uY26CEyoucGxhdGZvcm0uYmlu Zy5jb22CCiouYmluZy5jb22CCGJpbmcuY29tghZpZW9ubGluZS5taWNyb3NvZnQu Y29tghMqLndpbmRvd3NzZWFyY2guY29tghljbi5pZW9ubGluZS5taWNyb3NvZnQu Y29tghEqLm9yaWdpbi5iaW5nLmNvbYINKi5tbS5iaW5nLm5ldIIOKi5hcGkuYmlu Zy5jb22CGGVjbi5kZXYudmlydHVhbGVhcnRoLm5ldIINKi5jbi5iaW5nLm5ldIIN Ki5jbi5iaW5nLmNvbYIQc3NsLWFwaS5iaW5nLmNvbYIQc3NsLWFwaS5iaW5nLm5l dIIOKi5hcGkuYmluZy5uZXSCDiouYmluZ2FwaXMuY29tgg9iaW5nc2FuZGJveC5j b22CFmZlZWRiYWNrLm1pY3Jvc29mdC5jb22CG2luc2VydG1lZGlhLmJpbmcub2Zm aWNlLm5ldIIOci5iYXQuYmluZy5jb22CECouci5iYXQuYmluZy5jb22CEiouZGlj dC5iaW5nLmNvbS5jboIPKi5kaWN0LmJpbmcuY29tgg4qLnNzbC5iaW5nLmNvbYIQ Ki5hcHBleC5iaW5nLmNvbYIWKi5wbGF0Zm9ybS5jbi5iaW5nLmNvbYINd3AubS5i aW5nLmNvbYIMKi5tLmJpbmcuY29tgg9nbG9iYWwuYmluZy5jb22CEXdpbmRvd3Nz ZWFyY2guY29tgg5zZWFyY2gubXNuLmNvbYIRKi5iaW5nc2FuZGJveC5jb22CGSou YXBpLnRpbGVzLmRpdHUubGl2ZS5jb22CDyouZGl0dS5saXZlLmNvbYIYKi50MC50 aWxlcy5kaXR1LmxpdmUuY29tghgqLnQxLnRpbGVzLmRpdHUubGl2ZS5jb22CGCou dDIudGlsZXMuZGl0dS5saXZlLmNvbYIYKi50My50aWxlcy5kaXR1LmxpdmUuY29t ghUqLnRpbGVzLmRpdHUubGl2ZS5jb22CCzNkLmxpdmUuY29tghNhcGkuc2VhcmNo LmxpdmUuY29tghRiZXRhLnNlYXJjaC5saXZlLmNvbYIVY253ZWIuc2VhcmNoLmxp dmUuY29tggxkZXYubGl2ZS5jb22CDWRpdHUubGl2ZS5jb22CEWZhcmVjYXN0Lmxp dmUuY29tgg5pbWFnZS5saXZlLmNvbYIPaW1hZ2VzLmxpdmUuY29tghFsb2NhbC5s aXZlLmNvbS5hdYIUbG9jYWxzZWFyY2gubGl2ZS5jb22CFGxzNGQuc2VhcmNoLmxp dmUuY29tgg1tYWlsLmxpdmUuY29tghFtYXBpbmRpYS5saXZlLmNvbYIObG9jYWwu bGl2ZS5jb22CDW1hcHMubGl2ZS5jb22CEG1hcHMubGl2ZS5jb20uYXWCD21pbmRp YS5saXZlLmNvbYINbmV3cy5saXZlLmNvbYIcb3JpZ2luLmNud2ViLnNlYXJjaC5s aXZlLmNvbYIWcHJldmlldy5sb2NhbC5saXZlLmNvbYIPc2VhcmNoLmxpdmUuY29t ghJ0ZXN0Lm1hcHMubGl2ZS5jb22CDnZpZGVvLmxpdmUuY29tgg92aWRlb3MubGl2 ZS5jb22CFXZpcnR1YWxlYXJ0aC5saXZlLmNvbYIMd2FwLmxpdmUuY29tghJ3ZWJt YXN0ZXIubGl2ZS5jb22CE3dlYm1hc3RlcnMubGl2ZS5jb22CFXd3dy5sb2NhbC5s aXZlLmNvbS5hdYIUd3d3Lm1hcHMubGl2ZS5jb20uYXUwHQYDVR0lBBYwFAYIKwYB BQUHAwIGCCsGAQUFBwMBMA0GCSqGSIb3DQEBCwUAA4IBAQBxekR6+sSATzMwjITz kxyF+YjchD8RQvKHVKT6rE8YdaoPjWUJzutI8FnDQd0YIOeag3fzUY1J8r7CF7YK irbGAE4vT9ZLnG6FyIxln2DeUM1wWC05VneAJvcEbali08K/EaoaC8YCQmxcdWUo wEi1SJfPyyFxjASC5+AkOD6aAaL+JjNH7xMSZ05CS9AwnrNFax2KaWK6GV0fT0Ax p54ZkwYoA0Dg/soy3P7pU3TN7z6oRz0M1BdF1wnWyal4pGKmLXDAKOIEo/nodPZs Bc+pSdVG/qu/q5QH1xN7VYI025zwrCzPkC/EHYj0PX1UVU8Rr9jdmQQlojJAp35+ Myov -----END CERTIFICATE-----
cor-el
  • Top 10 Contributor
  • Moderator
17525 solutions 158458 answers

Thanks. The certificate is issued by your Adguard security software

Subject CN=www.bing.com Issuer C=EN, CN=Adguard Personal CA

See e.g.:

Thanks. The certificate is issued by your Adguard security software Subject CN=www.bing.com Issuer C=EN, CN=Adguard Personal CA See e.g.: *[/questions/1258498] FireFox asking for Master Password on startup

Question owner

I am running AdGuard however disabling (as discussed in the question you mentioned above) does not resolve the problem. Any further suggestions would be appreciated

I am running AdGuard however disabling (as discussed in the question you mentioned above) does not resolve the problem. Any further suggestions would be appreciated
jscher2000
  • Top 10 Contributor
8758 solutions 71658 answers

Presumably AdGuard has a feature or instructions to make Firefox compatible with its filtering. Since AdGuard needs to create a fake certificate for every secure site, the solution ususually is to get the "signing" certificate for those fake certificates into Firefox's certificate store.

(Adding a new certificate. Sounds familiar...)

Could you check the AdGuard documentation or, if you haven't tried it already, do a normal shut down and restart Windows in case AdGuard's startup routine includes taking care of this for you?

Presumably AdGuard has a feature or instructions to make Firefox compatible with its filtering. Since AdGuard needs to create a fake certificate for every secure site, the solution ususually is to get the "signing" certificate for those fake certificates into Firefox's certificate store. (Adding a new certificate. Sounds familiar...) Could you check the AdGuard documentation or, if you haven't tried it already, do a normal shut down and restart Windows in case AdGuard's startup routine includes taking care of this for you?

Question owner

Your suggestion of restarting my PC has allowed me to load bling.com's page-of-the-day. I'll see if I can have Firefox open it automatically and also look at how to stop AdGuard from causing further problems. But that's for another day. Thanks for your help. Tony

Your suggestion of restarting my PC has allowed me to load bling.com's page-of-the-day. I'll see if I can have Firefox open it automatically and also look at how to stop AdGuard from causing further problems. But that's for another day. Thanks for your help. Tony