Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

After clearing history, searchbar auto complete no longer works.

  • 3 replies
  • 1 has this problem
  • Last reply by FredMcD

more options

A couple of weeks ago I cleared my firefox history to get rid of some... unsavory searches. However, since then my search bar auto complete refuses to work properly. There are several websites that I visit on a regular basis and I really liked being able to type one letter and then press enter.

For the longest time, it would try to auto complete to bookmarks that I have. I did not want that, and after extensive google searching I found the only way to stop them from being auto completed was to remove them completely.

I assumed over time that once I kept visiting the websites the auto complete would come back, but it hasn't and it has almost ruined Firefox for me. I have also tried reinstalling and it did not work.

Any suggestions?

All Replies (3)

more options

If you use Sync then best is to disconnect Sync temporarily during troubleshooting.

You can check for problems with the places.sqlite and favicons.sqlite files in the Firefox profile folder.

  • use "Verify Integrity" button on the "Help -> Troubleshooting Information" (about:support) page

In case errors are reported with "Verify Integrity" close and restart Firefox and retry.

If "Verify Integrity" cannot repair places.sqlite then remove all places.sqlite and favicons.sqlite files in the Firefox profile folder. Firefox will rebuild places.sqlite and restore the bookmarks from a recent JSON backup in the bookmarkbackups folder.

  • keep a backup copy of places.sqlite in case a new places.sqlite database has to be created

See also:

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:preferences page.

more options

It might be you cleared out too much data, or are using the wrong settings.

How did you clear the data?


Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

more options

Note: when you don't want anything to be recorded; Private Browsing - Use Firefox without saving history

Firefox Private Browsing is great for viewing websites without saving things like cookies, temp files, and a history of the pages you visit.