X
Tap here to go to the mobile version of the site.

Support Forum

icons on certain websites do not work

Posted

on certain websites some icons do not show up and just show a rectangle with a four digit letter and number code that starts with a letter. Does anyone know how to fix this? I have tried resetting the cache, looking for extensions that would conflict with these websites and have cleared them, and setting the minimum font size to be none. Help

on certain websites some icons do not show up and just show a rectangle with a four digit letter and number code that starts with a letter. Does anyone know how to fix this? I have tried resetting the cache, looking for extensions that would conflict with these websites and have cleared them, and setting the minimum font size to be none. Help
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

Question owner

I looked at the console of the website I was browsing and it gives me this error. Content Security Policy: The page’s settings blocked the loading of a resource at data:font/woff;base64,d09GRgABAAAAAIw4AB… (“font-src”). i hope this helps.

I looked at the console of the website I was browsing and it gives me this error. Content Security Policy: The page’s settings blocked the loading of a resource at data:font/woff;base64,d09GRgABAAAAAIw4AB… (“font-src”). i hope this helps.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17467 solutions 157841 answers

Helpful Reply

What hex code is in the little boxes? Is this in the E000-E8FF PUA range that is used for downloadable fonts?

Special icons are usually supplied by an icon font that is downloaded from the server (@font-face) You may see little boxes with the hex code of the character if you do not have a font installed that covers this Unicode range.

You can check gfx.downloadable_fonts.enabled on the about:config page and make sure it is set to true (if necessary double-click the line to toggle its value to true).


Such a font wouldn't normally be block by CSP rules.

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

If you use uBlock Origin then check the "block remote fonts" setting.


If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console about what content is blocked

What hex code is in the little boxes? Is this in the E000-E8FF PUA range that is used for downloadable fonts? Special icons are usually supplied by an icon font that is downloaded from the server (@font-face) You may see little boxes with the hex code of the character if you do not have a font installed that covers this Unicode range. You can check <b>gfx.downloadable_fonts.enabled</b> on the <b>about:config</b> page and make sure it is set to true (if necessary double-click the line to toggle its value to true). ---- Such a font wouldn't normally be block by CSP rules. Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)? If you use uBlock Origin then check the "block remote fonts" setting. ---- If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content. *make sure your extensions and filters are updated to the latest version *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content. *click the shield icon for more detail and possibly disable the protection You can check the Web Console about what content is blocked *"3-bar" menu button or Tools -> Web Developer *https://support.mozilla.org/en-US/kb/tracking-protection *https://support.mozilla.org/en-US/kb/content-blocking
Was this helpful to you? 1
Quote

Question owner

i do use ublock and i followed the instructions and now everything works normally. thank you

i do use ublock and i followed the instructions and now everything works normally. thank you
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
532 solutions 5034 answers

marc1412 said

i do use ublock and i followed the instructions and now everything works normally. thank you

Hello marc1412,

Would you be so kind as to mark cor-el's post as "Chosen Solution" ("Solved the problem" button to the right)  ?

Thank you in advance  !

''marc1412 [[#answer-1215264|said]]'' <blockquote> i do use ublock and i followed the instructions and now everything works normally. thank you </blockquote> Hello marc1412, Would you be so kind as to mark cor-el's post as "Chosen Solution" ("Solved the problem" button to the right) ? Thank you in advance !
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.