X
Tap here to go to the mobile version of the site.

Support Forum

Stop multiple Firefox windows from shuffing

Posted

I'll be working with a lot of windows and tabs open, then I get the "Firefox is not responding" message for several seconds. After that, when it comes back the windows are all shuffled. Sometimes I can literally watch them shuffle before my eyes. It's not only when I restore after a FF crash or shut-down.

Any ideas what's happening or how to fix it?

Thanks

I'll be working with a lot of windows and tabs open, then I get the "Firefox is not responding" message for several seconds. After that, when it comes back the windows are all shuffled. Sometimes I can literally watch them shuffle before my eyes. It's not only when I restore after a FF crash or shut-down. Any ideas what's happening or how to fix it? Thanks
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

WestEnd
  • Top 25 Contributor
61 solutions 5308 answers

I think you should make bookmarks of the tabs if your having that much problems. This could be from the lack of Memory causing the shuffling as well due to lack of Memory resources. How much RAM do you have installed? This could be a Memory capacity as well being taxed to much.

I think you should make bookmarks of the tabs if your having that much problems. This could be from the lack of Memory causing the shuffling as well due to lack of Memory resources. How much RAM do you have installed? This could be a Memory capacity as well being taxed to much.
Was this helpful to you?
Quote
Pj
  • Top 25 Contributor
42 solutions 868 answers

dottiej77 said

I'll be working with a lot of windows and tabs open, then I get the "Firefox is not responding" message for several seconds. After that, when it comes back the windows are all shuffled. Sometimes I can literally watch them shuffle before my eyes. It's not only when I restore after a FF crash or shut-down.

Does this happen when you do this?:

Menu > Help > Restart with Add-ons Disabled.


What I see in Task Manager, Physical Memory Usage over time creeps up the graph, eventually nearing my 8GB my computer has. So, depending how many Tabs/Sites I visit, when the Graph Line nears the top, I hear my disk drive go into 'crunch' mode. This must be FF Caching Data and/or The 'large' Paging File crunching my hard drive. This can happen within several hours or a few days later, depending on my FF use.

However, once it reaches this point, the browser performance takes a nasty hit. The only way to regain better performance for me, is to Exit (Quit) FF and restart it.

Recommended Hardware for FF 66:

  • Pentium 4 or newer processor that supports SSE2
  • 512MB of RAM / 2GB of RAM for the 64-bit version
  • 200MB of hard drive space


Please do the following:

Click on the Windows icon 'Start' (bottom-left) and in the right column, bottom, click on Run. Enter in:

DxDiag /64bit

...Wait until the green bar loads and disappears, then click "Save All Information".
Post back here in the Forum with a Copy-n-Paste of just these information parts, under these three Headers:


System Information



Display Devices



Disk & DVD/CD-ROM Drives


Make sure your computer is not too 'LOW' on disk-remaining space. This will be a major performance problem if your remaining disk space is TOO LOW!
If you're way under 25%, then you're probably running into performance / Memory issues.
Windows-7 and Programs like to have plenty of free-disk 'breathing' room.
If you have lots of Browser Windows and Tabs going and your FireFox Browser is set to Restore Session when you start-up FF, the following will help with conserving some Memory:

Go to Options. Edit or Insert in the Address/URL Box About:Config and go there. Set the following Values:

browser.newtabpage.enabled; false

browser.newtabpage.enhanced; false

browser.sessionstore.restore_pinned_tabs_on_demand; true


Upon the next start of FireFox, this will preload only the last Tab you were parked on per browser window. The other Tabs from your Previous Session will load only when you click on them.

If you open a lot of browser windows, you can set the maximum 'remembered' browser windows higher than the default for your Restored Session. Example: My max is set for 25:

browser.sessionstore.max_windows_undo; 25

Additionally, you could try this also. Have FF reset how much Disk Cache it will use for your system by changing the following to true:

browser.cache.disk.smart_size.first_run - false

It will change back to false after FF is Exited and runs next time, setting-up your Disk Cache value. Maybe this doesn't need to run again, but I did it a while back and 'appeared' to help me.

Finally, I did the following FireFox adjustments for my old 2010 computer with the Performance settings in Options as shown in the image attachment:


~Pj

''dottiej77 [[#question-1256717|said]]'' <blockquote> I'll be working with a lot of windows and tabs open, then I get the "Firefox is not responding" message for several seconds. After that, when it comes back the windows are all shuffled. Sometimes I can literally watch them shuffle before my eyes. It's not only when I restore after a FF crash or shut-down. </blockquote> Does this happen when you do this?: '''Menu > Help > Restart with Add-ons Disabled'''. <Hr> What I see in Task Manager, '''Physical Memory Usage''' over time creeps up the graph, eventually nearing my 8GB my computer has. So, depending how many Tabs/Sites I visit, when the Graph Line nears the top, I hear my disk drive go into 'crunch' mode. This must be FF Caching Data and/or The 'large' Paging File crunching my hard drive. This can happen within several hours or a few days later, depending on my FF use. <Br> However, once it reaches this point, the browser performance takes a nasty hit. The only way to regain better performance for me, is to Exit (Quit) FF and restart it. <Br> Recommended Hardware for FF 66: *Pentium 4 or newer processor that supports SSE2 *512MB of RAM / 2GB of RAM for the 64-bit version *200MB of hard drive space<Br> Please do the following: <Br> Click on the Windows icon ''''Start'''' (bottom-left) and in the right column, bottom, click on '''Run'''. Enter in: <Center>'''DxDiag /64bit'''</Center><Br> ...Wait until the green bar loads and disappears, then click "'''Save All Information'''". <Br> Post back here in the Forum with a Copy-n-Paste of just these information parts, under these three Headers:<Br> <Hr>'''System Information'''<Hr> <Br> <Hr>'''Display Devices'''<Hr> <Br> <Hr>'''Disk & DVD/CD-ROM Drives'''<Hr><Br><Br> Make sure your computer is not too 'LOW' on disk-remaining space. This will be a major performance problem if your remaining disk space is '''TOO LOW!'''<Br> If you're way under 25%, then you're probably running into performance / Memory issues.<Br> Windows-7 and Programs like to have plenty of free-disk 'breathing' room.<Br> If you have lots of Browser Windows and Tabs going and your FireFox Browser is set to '''Restore Session''' when you start-up FF, the following will help with conserving some Memory:<Br><Br> Go to '''Options'''. Edit or Insert in the Address/URL Box '''About:Config''' and go there. Set the following Values:<Br> <Center> '''browser.newtabpage.enabled; false'''<Br><Br> '''browser.newtabpage.enhanced; false'''<Br><Br> '''browser.sessionstore.restore_pinned_tabs_on_demand; true''' </Center><Br> Upon the next start of FireFox, this will preload only the last Tab you were parked on per browser window. The other Tabs from your Previous Session will load only when you click on them.<Br><Br> If you open a lot of browser windows, you can set the maximum 'remembered' browser windows higher than the default for your Restored Session. Example: My max is set for 25:<Br><Br> <Center>'''browser.sessionstore.max_windows_undo; 25'''</Center><Br> Additionally, you could try this also. Have FF reset how much Disk Cache it will use for your system by changing the following to '''true''':<Br> '''browser.cache.disk.smart_size.first_run''' - <s> false </s><Br> It will change back to '''false''' after FF is Exited and runs next time, setting-up your Disk Cache value. Maybe this doesn't need to run again, but I did it a while back and 'appeared' to help me. <Br><Br> Finally, I did the following FireFox adjustments for my old 2010 computer with the '''Performance''' settings in '''Options''' as shown in the image attachment: <Br><Br><Br> ~Pj
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.