X
Tap here to go to the mobile version of the site.

Support Forum

Firefox cannot be updated

Posted

I have Firefox ESR 52.4.1. At first that seems perfectly fine. All webpages open perfectly fine, as Firefox ESR 52.4.1 supports the very newest HTML5 standards. All the samples at https://typedesign.netlify.com/consolas.html and https://typedesign.netlify.com/customfont.html work perfectly fine.

But not all extensions are compatible.

The problem is, I can't really update it. Each time I update Firefox, the word "Quantum" appears in the About Firefox dialog, which clearly indicates that this isn't an official version of Firefox. So I have to downgrade to get the proper Firefox experience.

I have Firefox ESR 52.4.1. At first that seems perfectly fine. All webpages open perfectly fine, as Firefox ESR 52.4.1 supports the very newest HTML5 standards. All the samples at https://typedesign.netlify.com/consolas.html and https://typedesign.netlify.com/customfont.html work perfectly fine. But not all extensions are compatible. The problem is, I can't really update it. Each time I update Firefox, the word "Quantum" appears in the About Firefox dialog, which clearly indicates that this isn't an official version of Firefox. So I have to downgrade to get the proper Firefox experience.

Chosen solution

Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0

More Information

Tyler Downer
  • Top 25 Contributor
  • Moderator
1530 solutions 10669 answers

The current version of Firefox is 66.0.3. This version will show the word "Quantum" in the About window, as quantum is a project that was a combination of efforts to make Firefox more secure, stable and fast.

Please update to the latest version of Firefox by downloading it from www.getfirefox.com. You will receive Firefox 66.0.3, which will show as "Firefox Quantum"

The current version of Firefox is 66.0.3. This version will show the word "Quantum" in the About window, as quantum is a project that was a combination of efforts to make Firefox more secure, stable and fast. Please update to the latest version of Firefox by downloading it from www.getfirefox.com. You will receive Firefox 66.0.3, which will show as "Firefox Quantum"
Was this helpful to you?
Quote

Question owner

The "project that was a combination of efforts to make Firefox more secure, stable and fast" is fraud.

The "project that was a combination of efforts to make Firefox more secure, stable and fast" is fraud.
Was this helpful to you?
Quote
Tyler Downer
  • Top 25 Contributor
  • Moderator
1530 solutions 10669 answers

Nope! Quantum is just a code name for the latest version of Firefox.

https://blog.mozilla.org/blog/2017/11/14/introducing-firefox-quantum/

Please update to Firefox 66.0.3. Thank you!

Nope! Quantum is just a code name for the latest version of Firefox. https://blog.mozilla.org/blog/2017/11/14/introducing-firefox-quantum/ Please update to Firefox 66.0.3. Thank you!
Was this helpful to you?
Quote

Chosen Solution

n­­­o

n­­­o
Was this helpful to you?
Quote
Tyler Downer
  • Top 25 Contributor
  • Moderator
1530 solutions 10669 answers

No what? I'm not sure what further information you need. You asked how to update Firefox and I gave you all required information. Please update and if you have any problems please let me know

No what? I'm not sure what further information you need. You asked how to update Firefox and I gave you all required information. Please update and if you have any problems please let me know
Was this helpful to you?
Quote
Tyler Downer
  • Top 25 Contributor
  • Moderator
1530 solutions 10669 answers

And just to be clear, here is where you can download the latest version of Firefox: https://www.mozilla.org/firefox/all/

Then just install it, and you'll be up to date!

And just to be clear, here is where you can download the latest version of Firefox: https://www.mozilla.org/firefox/all/ Then just install it, and you'll be up to date!
Was this helpful to you?
Quote
James
  • Moderator
1595 solutions 11242 answers

PiotrGrochowski said

But not all extensions are compatible. The problem is, I can't really update it. Each time I update Firefox, the word "Quantum" appears in the About Firefox dialog, which clearly indicates that this isn't an official version of Firefox. So I have to downgrade to get the proper Firefox experience.

For Mozilla, Official means Firefox builds from say mozilla.org and not third-party builds that are not allowed to be distributed with the Firefox name and icons.

Quantum basically refers to say Firefox 57.0 and later including the current which is 66.0.3 which is Official.

Extensions for the old End of Life (EOL) Firefox 52 ESR (52.9.0esr was the last and not 52.4.1) used the legacy Extensions which are not compatible with Firefox 57.0 and later.

All of the official Releases (Release Notes pages) are listed on https://www.mozilla.org/firefox/releases/

''PiotrGrochowski [[#question-1256660|said]]'' <blockquote>But not all extensions are compatible. The problem is, I can't really update it. Each time I update Firefox, the word "Quantum" appears in the About Firefox dialog, which clearly indicates that this isn't an official version of Firefox. So I have to downgrade to get the proper Firefox experience. </blockquote> For Mozilla, Official means Firefox builds from say mozilla.org and not third-party builds that are not allowed to be distributed with the Firefox name and icons. Quantum basically refers to say Firefox 57.0 and later including the current which is 66.0.3 which is Official. Extensions for the old End of Life (EOL) Firefox 52 ESR (52.'''9'''.0esr was the last and not 52.4.1) used the legacy Extensions which are not compatible with Firefox 57.0 and later. All of the official Releases (Release Notes pages) are listed on https://www.mozilla.org/firefox/releases/
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.