X
Tap here to go to the mobile version of the site.

Support Forum

How do I allow a site to set cookies when content blocking is set to reject them?

Posted

I'd like to be able to allow specific sites to set cookies, but reject cookies by default.

The options I've been able to find would allow me to turn off content blocking for a given site, but this is not a satisfactory solution as this results in allowing trackers and third-party cookies to be set by that site in addition to it's own.

Perhaps I've missed something? The only other browsers I'm familiar with are chromium based and it's pretty easy to do on them.

I'd like to be able to allow specific sites to set cookies, but reject cookies by default. The options I've been able to find would allow me to turn off content blocking for a given site, but this is not a satisfactory solution as this results in allowing trackers and third-party cookies to be set by that site in addition to it's own. Perhaps I've missed something? The only other browsers I'm familiar with are chromium based and it's pretty easy to do on them.
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

McCoy
  • Top 10 Contributor
473 solutions 4275 answers

Hello ettmetal,

Would you try this please :

When you're on that site, click on the 'i' in a circle, next to the padlock at the left side of the address bar.

Then click on the little black arrow on the dropdown (next to 'Connection') and then on "More Information", which will take you to "Page Info".

Click on the 'Permissions" tab and scroll down to "Set Cookies". Uncheck "Use Default" and check "Allow".

Then close and restart Firefox.

'Hope that works ......

Hello ettmetal, Would you try this please : When you're on that site, click on the 'i' in a circle, next to the padlock at the left side of the address bar. Then click on the little black arrow on the dropdown (next to 'Connection') and then on "More Information", which will take you to "Page Info". Click on the 'Permissions" tab and scroll down to "Set Cookies". Uncheck "Use Default" and check "Allow". Then close and restart Firefox. 'Hope that works ......
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.