X
Tap here to go to the mobile version of the site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Support Forum

Deactivate opening in native app

Posted

Many many webpages I visit offer the little Android symbol in the address bar.

This is an error, because when clicking it, it opens my banking tan generator app - totally unrelated.

I checked system settings for default apps: Settings --> Apps --> Advanced --> Default App settings. Everything is ok here. Also checked both FF and the banking app via Settings --> Apps: No special default settings are made here.

FF 66.0.2 on Android 6.0, Huawei P8lite (ALE-L21 with EMUI 4.0.3)

Installed Addons: uBlock Origin, Stylus.

Related topics (can't answer because archived and I didn't have an account yet): https://support.mozilla.org/en-US/questions/985895 https://support.mozilla.org/en-US/questions/1243309

Many many webpages I visit offer the little Android symbol in the address bar. This is an error, because when clicking it, it opens my banking tan generator app - totally unrelated. I checked system settings for default apps: Settings --> Apps --> Advanced --> Default App settings. Everything is ok here. Also checked both FF and the banking app via Settings --> Apps: No special default settings are made here. FF 66.0.2 on Android 6.0, Huawei P8lite (ALE-L21 with EMUI 4.0.3) Installed Addons: uBlock Origin, Stylus. Related topics (can't answer because archived and I didn't have an account yet): https://support.mozilla.org/en-US/questions/985895 https://support.mozilla.org/en-US/questions/1243309

Chosen solution

Thank you for your answer.

I've already tried this. That was what I meant by

"Also checked both FF and the banking app via Settings --> Apps: No special default settings are made here."

So after all, I think it is solved now. The banking app today got an update.

Still it would be good to have an about:config option for deactivating this "open with native app" feature.

Read this answer in context 0
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

jscher2000
  • Top 10 Contributor
8315 solutions 68040 answers

Android 6.0, hmm, could you try this:

Android Settings > Apps > Problem App Name

Scroll down and look for "Open by default" or "Set as default" and look for a button to clear defaults or tap it and then look for the button.

Can you get rid of it that way?

Android 6.0, hmm, could you try this: Android Settings > Apps > ''Problem App Name'' Scroll down and look for "Open by default" or "Set as default" and look for a button to clear defaults or tap it and then look for the button. Can you get rid of it that way?

Modified by jscher2000

Was this helpful to you?
Quote

Chosen Solution

Thank you for your answer.

I've already tried this. That was what I meant by

"Also checked both FF and the banking app via Settings --> Apps: No special default settings are made here."

So after all, I think it is solved now. The banking app today got an update.

Still it would be good to have an about:config option for deactivating this "open with native app" feature.

Thank you for your answer. I've already tried this. That was what I meant by "Also checked both FF and the banking app via Settings --> Apps: No special default settings are made here." So after all, I think it is solved now. The banking app today got an update. Still it would be good to have an about:config option for deactivating this "open with native app" feature.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.