Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

opens with previous sessions

  • 9 replies
  • 1 has this problem
  • 21 views
  • Last reply by McCoy

more options

Firefox keeps restoring previous sessions even though it has not crashed. I can close the browser and reopen the browser and it will bring up the past session.

Chosen solution

jsteegs said

Unfortunately it is still unchecked.

Thank you for checking to see if it was checked, though.

If there are no crashes; Firefox still might think there was a crash. Would you give this a try and close Firefox this way :

3-bar menu button => Exit (Power button) or : Ctrl + Shift + Q

(if you already tried it - sorry .... )

Read this answer in context 👍 0

All Replies (9)

more options

You may have corrupt sessionstore [v56] sessionstore.jsonlz4 file(s). Delete all sessionstore* files and the sessionstore-backups folder.

Type about:support<enter> in the address bar.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Locate the above file. Then rename or delete it. Restart Firefox.


Don't delete the files if you need to rescue any data from them, just move them out of the profile folder to some location where Firefox doesn't look for them. You can try to read out their contents using this tool: https://www.jeffersonscher.com/res/scrounger.html

more options

Hey Fred, I have already tried this solution and Everytime I reopen Firefox it brings up the previous session. I have completely deleted the file 3 times with no luck.

more options

Hello jsteegs,

This is going to be a very, very dumb question, but I'll ask it anyway, just in case :

In Options => General => under 'Startup' :

Is 'Restore previous session' unchecked  ?

(sometimes it miraculously seems to check itself .... )

more options

Unfortunately it is still unchecked.

more options

Chosen Solution

jsteegs said

Unfortunately it is still unchecked.

Thank you for checking to see if it was checked, though.

If there are no crashes; Firefox still might think there was a crash. Would you give this a try and close Firefox this way :

3-bar menu button => Exit (Power button) or : Ctrl + Shift + Q

(if you already tried it - sorry .... )

more options

I ended up uninstalling and reinstalling and that worked.

more options

jsteegs said

I ended up uninstalling and reinstalling and that worked.

Well, how about that - well done  !

I was just about to suggest to change the value of a preference on the 'about:config' page and you just saved me the trouble  !

You marked my post as Chosen Solution - would you please remove that mark (click on the 'Undo' button to the right) and then mark your own last post as Chosen Solution  ?

Again : well done  !

more options

I actually tried that as well last night. It seemed nothing I did would work. So last resort was to just start over.

Thanks for the help.

more options

jsteegs said

I actually tried that as well last night. It seemed nothing I did would work. So last resort was to just start over.

Well, you sure did a great job  ! Must be a huge relief to finally have things back to normal.

(don't forget to mark your own post as Chosen Solution ....)