X
Tap here to go to the mobile version of the site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Support Forum

Firefox not outputting surround sound when available in videos

  • No replies
  • 1 has this problem
  • 2 views
Posted

Hello Folks,

I have trouble reliably getting firefox to output surround sound in 5.1, for any format of it. Before the last update adding the command "--disable-audio-output-resampler" to the shortcut worked. Now it doesn't. I've verified it is not a windows 10 issue, ad nauseum. I have also noticed Chrome has the same issue, unless I cast the video I'm trying to watch, then I get whatever sound codec the video is supposed to be.

I'm outputting from the HDMI port from an NVIDIA Geforce 1060. Again, this is isolated to my web browsers. Other apps, games, and tests inside windows verifies the system can output to all five speakers if told to do so. I'm just back to the web browser seemingly resampling my audio but now I can't make it not do so. I have gone through checking if its addons (disabling them had no effect). I have no idea if there's some advanced setting or command I'm missing to fix this. Does anyone have any ideas, or am I doomed to letting google have yet more control over how I use modern technology?

I'm presently using Firefox Quantum version 66.0.3.

Thanks all in advance!

Hello Folks, I have trouble reliably getting firefox to output surround sound in 5.1, for any format of it. Before the last update adding the command "--disable-audio-output-resampler" to the shortcut worked. Now it doesn't. I've verified it is not a windows 10 issue, ad nauseum. I have also noticed Chrome has the same issue, unless I cast the video I'm trying to watch, then I get whatever sound codec the video is supposed to be. I'm outputting from the HDMI port from an NVIDIA Geforce 1060. Again, this is isolated to my web browsers. Other apps, games, and tests inside windows verifies the system can output to all five speakers if told to do so. I'm just back to the web browser seemingly resampling my audio but now I can't make it not do so. I have gone through checking if its addons (disabling them had no effect). I have no idea if there's some advanced setting or command I'm missing to fix this. Does anyone have any ideas, or am I doomed to letting google have yet more control over how I use modern technology? I'm presently using Firefox Quantum version 66.0.3. Thanks all in advance!
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.