X
Tap here to go to the mobile version of the site.

Support Forum

adblock.com keeps trying to install on computer when I use Firefox. Why?

Posted

Every time I access the net with Firefox, a secondary tab screen appears which says " GetAdBlock.com , install adblock now." If I leave it alone, it will begin to install "adblock" without any permission. I have to abort it by ex-ing it out immediately. Is this a Firefox ad for it's adblocker, or has a virus permanently installed itself and will not die until I install it? I've run all my antivirus programs and they all say everything is fine.

Every time I access the net with Firefox, a secondary tab screen appears which says " GetAdBlock.com , install adblock now." If I leave it alone, it will begin to install "adblock" without any permission. I have to abort it by ex-ing it out immediately. Is this a Firefox ad for it's adblocker, or has a virus permanently installed itself and will not die until I install it? I've run all my antivirus programs and they all say everything is fine.
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • Firefox 66.0.3
  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0
  • Support URL: https://support.mozilla.org/1/firefox/66.0.3/WINNT/en-US/

Extensions

  • AdBlock 3.27.0 (jid1-NIfFY2CA8fy1tg@jetpack) (Inactive)
  • AVG Web TuneUp 4.3.6.255 (avg@toolbar) (Inactive)
  • Cookie AutoDelete 3.0.1 (CookieAutoDelete@kennydo.com) (Inactive)
  • Disconnect 5.18.21 (2.0@disconnect.me) (Inactive)
  • Enhancer for YouTube™ 2.0.87 (enhancerforyoutube@maximerf.addons.mozilla.org) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 8330
  • adapterDescription2:
  • adapterDeviceID: 0x9832
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 amdxc64 aticfx32 aticfx32 aticfx32 amdxc32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterSubsysID: 2b18103c
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2.2 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 400
  • contentUsesTiling: False
  • crashGuards: []
  • direct2DEnabled: False
  • direct2DEnabledMessage: {u'key': u''}
  • directWriteEnabled: True
  • directWriteVersion: 10.0.17134.376
  • driverDate: 8-6-2015
  • driverDate2:
  • driverVersion: 15.201.1101.0
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'Acceleration blocked by safe-mode', u'type': u'runtime'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct2D', u'log': [{u'status': u'unavailable', u'message': u'Direct2D requires Direct3D 11 compositing', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'disabled', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'unavailable', u'message': u'D3D11 compositing is disabled', u'type': u'default'}, {u'status': u'disabled', u'message': u'D3D11 compositing is disabled', u'type': u'env'}], u'name': u'D3D11_HW_ANGLE'}, {u'status': u'blocked', u'description': u'GPU Process', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'Safe-mode is enabled', u'type': u'runtime'}], u'name': u'GPU_PROCESS'}, {u'status': u'unavailable', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u'ANGLE is disabled', u'type': u'runtime'}], u'name': u'WEBRENDER'}, {u'status': u'blocked', u'description': u'WebRender qualified', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'Not Nvidia', u'type': u'env'}], u'name': u'WEBRENDER_QUALIFIED'}, {u'status': u'blocked', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'OMTP blocked by safe-mode', u'type': u'runtime'}], u'name': u'OMTP'}]}
  • info: {u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'cairo', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • isGPU2Active: False
  • lowEndMachine: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: {u'key': u''}
  • numTotalWindows: 1
  • offMainThreadPaintEnabled: False
  • offMainThreadPaintWorkerCount: 0
  • targetFrameRate: 60
  • usesTiling: False
  • webgl1DriverExtensions: -
  • webgl1Extensions: -
  • webgl1Renderer: WebGL is currently disabled.
  • webgl1Version: -
  • webgl1WSIInfo: -
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL is currently disabled.
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic
  • windowUsingAdvancedLayers: False

Modified Preferences

Misc

  • User JS: Yes
  • Accessibility: No
Wesley Branton
  • Top 10 Contributor
536 solutions 4642 answers

Helpful Reply

It's possible that this website was accidentally set as your home page on Firefox. For information on changing your home page, see How to set the home page.

You can also try removing the Adblock add-on from your browser. Sometimes I've found that page will appear when there is an update, even if you have disabled Adblock but not removed it. For more information on removing add-ons from Firefox, see Disable or remove Add-ons.

Otherwise, I'd recommend scanning your computer for malware. Most scanning utilities will offer a fix to viruses or infections. You can try these free programs to scan for malware, which work with your existing antivirus software:

Microsoft Security Essentials is a good permanent antivirus for Windows 7/Vista if you don't already have one. Windows 8/10 have antivirus protection built-in.

Did this fix your problems? Please report back to us!

It's possible that this website was accidentally set as your home page on Firefox. For information on changing your home page, see [[How to set the home page]]. You can also try removing the Adblock add-on from your browser. Sometimes I've found that page will appear when there is an update, even if you have disabled Adblock but not removed it. For more information on removing add-ons from Firefox, see [[Disable or remove Add-ons]]. Otherwise, I'd recommend scanning your computer for malware. Most scanning utilities will offer a fix to viruses or infections. You can try these free programs to scan for malware, which work with your existing antivirus software: * [https://www.microsoft.com/en-us/wdsi/products/scanner Microsoft Safety Scanner] * [http://www.malwarebytes.org/products/malwarebytes_free/ MalwareBytes' Anti-Malware] * [http://support.kaspersky.com/viruses/disinfection/5350 Anti-Rootkit Utility - TDSSKiller] (for more info, see this [https://www.bleepingcomputer.com/download/tdsskiller/ alternate TDSSKiller download page]) * [https://www.malwarebytes.com/adwcleaner/ AdwCleaner] (for more info, see this [http://www.bleepingcomputer.com/download/adwcleaner/ alternate AdwCleaner download page]) * [http://www.surfright.nl/en/hitmanpro/ Hitman Pro] * [http://www.eset.com/us/online-scanner/ ESET Online Scanner] [https://support.microsoft.com/help/14210/security-essentials-download Microsoft Security Essentials] is a good permanent antivirus for Windows 7/Vista if you don't already have one. Windows 8/10 have antivirus protection [https://www.microsoft.com/windows/comprehensive-security built-in]. Did this fix your problems? Please report back to us!
Was this helpful to you? 1
Quote

Question owner

Yes, problem seems fixed, but now Mozilla Enhancer for YouTube won't save my changes, i.e., the remove ads feature and the "Disable pin video when comments are viewed" feature, both of which I enabled, get DISABLED when I watch YouTube videos, as if YouTube purposely disabled them. Not sure if this is in any way related to previous GetAdBlocker problem, but it only started as soon as the Getadblocker issue went away by disabling Google Chrome, which seemed to be the one forcing it on my tabs. Help!

Yes, problem seems fixed, but now Mozilla Enhancer for YouTube won't save my changes, i.e., the remove ads feature and the "Disable pin video when comments are viewed" feature, both of which I enabled, get DISABLED when I watch YouTube videos, as if YouTube purposely disabled them. Not sure if this is in any way related to previous GetAdBlocker problem, but it only started as soon as the Getadblocker issue went away by disabling Google Chrome, which seemed to be the one forcing it on my tabs. Help!
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.