X
Tap here to go to the mobile version of the site.

Support Forum

buttons fail to firefox 66.x

Posted

Firefox webpage buttons fail to fire. Works in version 65. Also, button work with other browsers including IE 11, latest version of opera and chrome.

Anyone else experience this ....

Firefox webpage buttons fail to fire. Works in version 65. Also, button work with other browsers including IE 11, latest version of opera and chrome. Anyone else experience this ....
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

WestEnd
  • Top 25 Contributor
60 solutions 5366 answers

What buttons are you talking about?

What buttons are you talking about?
Was this helpful to you? 0
Quote

Helpful Reply

Here's the HTML code for the button control.


<button type="button" data-widget="button" data-member="CALL_PZMOPER07_BUTTON" data-block="CONTROL_BLOCK" data-action="WHEN-BUTTON-PRESSED" id="callPzmoper07Button" data-name="callPzmoper07Button" data-tooltip="PZMOPER07 - OPERS Employee Maintenace - Contributions by Reporting Period" class="ui-widget ui-button ui-state-default ui-corner-all ui-button-text-only mode-edit" style="height: 23px; width: 285px; " role="button" aria-disabled="false" title="PZMOPER07 - OPERS Employee Maintenace - Contributions by Reporting Period">Monthly Maintenance</button>

Here's the HTML code for the button control. <'''button type="button" '''data-widget="button" data-member="CALL_PZMOPER07_BUTTON" data-block="CONTROL_BLOCK" data-action="WHEN-BUTTON-PRESSED" id="callPzmoper07Button" data-name="callPzmoper07Button" data-tooltip="PZMOPER07 - OPERS Employee Maintenace - Contributions by Reporting Period" class="ui-widget ui-button ui-state-default ui-corner-all ui-button-text-only mode-edit" style="height: 23px; width: 285px; " role="button" aria-disabled="false" title="PZMOPER07 - OPERS Employee Maintenace - Contributions by Reporting Period"><span class="ui-button-text"><u>M</u>onthly Maintenance</span></button>
Was this helpful to you? 1
Quote
WestEnd
  • Top 25 Contributor
60 solutions 5366 answers

Can you provide a screenshot of the buttons? Are these on the browser toolbar?

Can you provide a screenshot of the buttons? Are these on the browser toolbar?
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8633 solutions 70605 answers

Hi john.posey, your button has a lot of attributes, but one that I don't see is onclick, which is a common way to assign a scripted action to a button. Button actions can be assigned dynamically instead of adding them as an attribute, but either way, if the button plays dead, there is a script-related issue.

If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally:

Double-check content blockers: Firefox's Content Blocking feature and extensions that counter ads and tracking may break websites that embed third party content (meaning, from a secondary server).

(A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: Content blocking.

(B) Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "Clear Cookies and Site Data"
  • (menu bar) Tools > Page Info > Security > "Clear Cookies and Site Data"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "Clear Cookies and Site Data" button

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Hi john.posey, your button has a lot of attributes, but one that I don't see is '''onclick''', which is a common way to assign a scripted action to a button. Button actions can be assigned dynamically instead of adding them as an attribute, but either way, if the button plays dead, there is a script-related issue. If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally: '''Double-check content blockers:''' Firefox's Content Blocking feature and extensions that counter ads and tracking may break websites that embed third party content (meaning, from a secondary server). (A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: [[Content Blocking]]. (B) Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site. '''Cache and Cookies:''' When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Clear Firefox's Cache See: [[How to clear the Firefox cache]] If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either: * right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "Clear Cookies and Site Data" * (menu bar) Tools > Page Info > Security > "Clear Cookies and Site Data" * click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "Clear Cookies and Site Data" button In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites. Then try reloading the page. Does that help? '''Testing in Firefox's Safe Mode:''' In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?
Was this helpful to you?
Quote

Question owner

Can you provide a screenshot of the buttons? Yes, see attachment.

Are these on the browser toolbar? No

Can you provide a screenshot of the buttons? Yes, see attachment. Are these on the browser toolbar? No
Was this helpful to you?
Quote

Question owner

Down graded Firefox to version 65.0.2 and ...

the Buttons fire correctly ...

What ever coding changes made in 66.0.3 affected how html buttons work.

Looking forward to a future release when the buttons work correctly.

Thank you for your responses above, tried them and they didn't solve the button issue.

Down graded Firefox to version 65.0.2 and ... the Buttons fire correctly ... What ever coding changes made in 66.0.3 affected how html buttons work. Looking forward to a future release when the buttons work correctly. Thank you for your responses above, tried them and they didn't solve the button issue.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8633 solutions 70605 answers

Can you contact the website about the issue and see whether they plan to file a bug with Mozilla or update their code?

Can you contact the website about the issue and see whether they plan to file a bug with Mozilla or update their code?
Was this helpful to you?
Quote
Pj 42 solutions 869 answers

john.posey said

Firefox webpage buttons fail to fire. Works in version 65. Also, button work with other browsers including IE 11, latest version of opera and chrome. Anyone else experience this?

Yes, at times, button actions are dead with certain sites. I run into this at times. It's usually the Blocking of Trackers and/or Cookies that will 'break' some Website functions.

Did you try the Content Blocking setting at Standard? (Menu > Content Blocking.)



~Pj

''john.posey [[#question-1255799|said]]'' <blockquote> Firefox webpage buttons fail to fire. Works in version 65. Also, button work with other browsers including IE 11, latest version of opera and chrome. Anyone else experience this? </blockquote> Yes, at times, button actions are dead with certain sites. I run into this at times. It's usually the Blocking of '''Trackers''' and/or '''Cookies''' that will 'break' some Website functions. Did you try the '''Content Blocking''' setting at '''Standard'''? ('''Menu > Content Blocking'''.) ~Pj
Was this helpful to you?
Quote

Question owner

Something to consider, I did the following ...

- removed 66.0.3, cleaned off all mozilla subdirectories.

- installed 65.0.2 buttons work --- using default settings

- upgraded to 66.0.3 buttons failed -- using default settings

- down graded to 65.0.2 buttons worked -- using default settings

when installing, upgrading and down grading -- does the default setting get reset ????

Please look at the changes to the code. Does FF coding have side effects when someone changes the code? Something changed ... setting probably not, if so what setting changed so I can change the settings?

Something to consider, I did the following ... - removed 66.0.3, cleaned off all mozilla subdirectories. - installed 65.0.2 buttons work --- using default settings - upgraded to 66.0.3 buttons failed -- using default settings - down graded to 65.0.2 buttons worked -- using default settings when installing, upgrading and down grading -- does the default setting get reset ???? Please look at the changes to the code. Does FF coding have side effects when someone changes the code? Something changed ... setting probably not, if so what setting changed so I can change the settings?
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8633 solutions 70605 answers

There are many hundreds of code changes between Firefox 65 and 66 (as with any full version update). I don't think we have enough information about why the buttons aren't working to point to a workaround.

Since that doesn't look like the kind of site that you could share a link to, I suggest contacting the vendor for guidance.

Are there any other sites that don't require a login where you experience the problem, that you could share a link to?

There are many hundreds of code changes between Firefox 65 and 66 (as with any full version update). I don't think we have enough information about why the buttons aren't working to point to a workaround. Since that doesn't look like the kind of site that you could share a link to, I suggest contacting the vendor for guidance. Are there any other sites that don't require a login where you experience the problem, that you could share a link to?
Was this helpful to you?
Quote

Question owner

Understood !!! One final comment, the issue isn't with the intranet site, but rather FF. The buttons work with all the other browsers, so the issue remains with the FF 66.0.3 ... coding changes.

Our work around will be to not use FF 66.

Is there anyway to turn off automatic updates? I am thinking about:config. This will allow me to use FF 65 ...

Thank you for your time.

Understood !!! One final comment, the issue isn't with the intranet site, but rather FF. The buttons work with all the other browsers, so the issue remains with the FF 66.0.3 ... coding changes. Our work around will be to not use FF 66. Is there anyway to turn off automatic updates? I am thinking about:config. This will allow me to use FF 65 ... Thank you for your time.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8633 solutions 70605 answers

john.posey said

One final comment, the issue isn't with the intranet site, but rather FF.

Maybe. PowerPoint Online users discovered they could not type the letter p into the web application in Firefox 66. This is because Firefox 66 removed certain nonstandard keyboard behaviors. The goal was to make Firefox more compatible with other browsers, but some sites were not ready. So there is a special preference to make an exemption to this change for a long list of servers.

I'm not saying your intranet has this problem, but that websites often contain code that relies on certain browser quirks that change over time. If the applications are not updated regularly, they may become less and less functional over time.

Or it could be a bug. But we can't help you investigate without a page we can access.

Is there anyway to turn off automatic updates?

Have you already used the feature on the Options page to have Firefox ask you before installing updates? With that setting, you usually will get a drop-down from the menu button every 12 hours asking if you want to update now or not now.

The easiest way to find that setting is:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type updat and Firefox should filter to the "Firefox Updates" section where you can switch between automatically install and check/ask.

''john.posey [[#answer-1215965|said]]'' <blockquote> One final comment, the issue isn't with the intranet site, but rather FF.</blockquote> Maybe. PowerPoint Online users discovered they could not type the letter p into the web application in Firefox 66. This is because Firefox 66 removed certain nonstandard keyboard behaviors. The goal was to make Firefox more compatible with other browsers, but some sites were not ready. So there is a special preference to make an exemption to this change for a long list of servers. I'm not saying your intranet has ''this'' problem, but that websites often contain code that relies on certain browser quirks that change over time. If the applications are not updated regularly, they may become less and less functional over time. Or it could be a bug. But we can't help you investigate without a page we can access. <blockquote> Is there anyway to turn off automatic updates? </blockquote> Have you already used the feature on the Options page to have Firefox ask you before installing updates? With that setting, you usually will get a drop-down from the menu button every 12 hours asking if you want to update now or not now. The easiest way to find that setting is: * Windows: "3-bar" menu button (or Tools menu) > Options * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the search box at the top of the page, type ''updat'' and Firefox should filter to the "Firefox Updates" section where you can switch between automatically install and check/ask.
Was this helpful to you?
Quote
Pj 42 solutions 869 answers

john.posey said

Did you try the Content Blocking setting at Standard?

(Menu > Content Blocking.)

''john.posey [[#answer-1215965|said]]'' <blockquote> </blockquote> Did you try the '''Content Blocking''' setting at '''Standard'''? ('''Menu > Content Blocking'''.)
Was this helpful to you?
Quote

Question owner

Yes. the content blocking does not allow me to add a website to the exceptions list.

Yes. the content blocking does not allow me to add a website to the exceptions list.
Was this helpful to you?
Quote
Pj 42 solutions 869 answers

john.posey said

Yes. the content blocking does not allow me to add a website to the exceptions list.

But, does your buttons work on the Standard setting of Content Blocking? If so, do this:
Go to Options and in its Search Box enter:
Cookies and Site Data
Click on Manage Permissions.
Make two Allowed entries of your 'problem' Website like so:
https://ProblemSite.abc ProblemSite.abc


~Pj

''john.posey [[#answer-1216331|said]]'' <blockquote> Yes. the content blocking does not allow me to add a website to the exceptions list. </blockquote> But, does your buttons work on the '''Standard''' setting of '''Content Blocking'''? If so, do this: <Br> Go to '''Options''' and in its Search Box enter: <Br> '''Cookies and Site Data'''<Br> Click on '''Manage Permissions'''.<Br> Make two Allowed entries of your 'problem' Website like so: <Br> https://ProblemSite.abc ProblemSite.abc ~Pj
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.