Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Every time I restart FF on my Mac I see the Firefox Safe Mode warning box. What's going on?

  • 4 replies
  • 1 has this problem
  • 51 views
  • Last reply by johnnylion

more options

I get this attached warning box every time I restart FF on my Mac (2016 MBP, OSX 10.14.14) When I click on "Restore" FF informs me that it was unable to restore my last session. I have done a clean reinstall of the FF and have no add-ons running.

Thanks, John

Chosen solution

Make sure that you do not hold the Options key when you start Firefox.

Start Firefox in Safe Mode on Mac:

Read this answer in context 👍 1

All Replies (4)

more options

for some reason the screenshot didn't upload the first time around.

more options

What's your computer system and Firefox version?

https://support.mozilla.org/en-US/kb/firefox-is-stuck-in-safe-mode


johnnylion said

unable to restore my last session

You may have corrupt sessionstore [v56] sessionstore.jsonlz4 file(s). Delete all sessionstore* files and the sessionstore-backups folder.

Type about:support<enter> in the address bar.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Locate the above file. Then rename or delete it. Restart Firefox.


Don't delete the files if you need to rescue any data from them, just move them out of the profile folder to some location where Firefox doesn't look for them. You can try to read out their contents using this tool: https://www.jeffersonscher.com/res/scrounger.html

more options

Chosen Solution

Make sure that you do not hold the Options key when you start Firefox.

Start Firefox in Safe Mode on Mac:

more options

Hah, so it turns out I use a keyboard shortcut (using Keyboard Maestro) to launch FF. It's "option-control-F". So, yup, I'm inadvertently holding down the option key while launching FF. Oops. If I launch through Spotlight search I don't have the problem.

Thanks Cor-el!