X
Tap here to go to the mobile version of the site.

Support Forum

blocking autoplay no longer does

Posted

some sites such as abcnews.go.com can now play videos automatically when they couldn't before. i've changed all the about:config autop* settings as described. you admit that some sites can now play with the new 'improved' blocking. a video that i never launched running on a tab i wasn't viewing streamed all night and used up 1GB of my 30GB hard data cap. i live in the country and get isp over verizon cell. i NEVER want ANY video on ANY site to play automatically in my browser. muting is moot. data is what matters. now i have to make sure no news site is open on any tab on any computer before going to bed every night. please restore a way to block ALL videos from autoplaying.

some sites such as abcnews.go.com can now play videos automatically when they couldn't before. i've changed all the about:config autop* settings as described. you admit that some sites can now play with the new 'improved' blocking. a video that i never launched running on a tab i wasn't viewing streamed all night and used up 1GB of my 30GB hard data cap. i live in the country and get isp over verizon cell. i NEVER want ANY video on ANY site to play automatically in my browser. muting is moot. data is what matters. now i have to make sure no news site is open on any tab on any computer before going to bed every night. please restore a way to block ALL videos from autoplaying.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

WestEnd
  • Top 25 Contributor
60 solutions 5379 answers

You going to have to make a screenshot of the site and point which video on there is autoplaying or not.

You going to have to make a screenshot of the site and point which video on there is autoplaying or not.

Question owner

thanks for the feedback.

the live stream in the upper right corner of the attached image started playing by itself. when i clicked on it, it stopped and a play button appeared.

something similar now happens on cbsnews.com.

with firefox open with seven non-news tabs open (see image), i consume about 200 KB/min. with abc or cbs news websites open (even with no visible video playing), i consume about 1 MB/min.

thanks for the feedback. the live stream in the upper right corner of the attached image started playing by itself. when i clicked on it, it stopped and a play button appeared. something similar now happens on cbsnews.com. with firefox open with seven non-news tabs open (see image), i consume about 200 KB/min. with abc or cbs news websites open (even with no visible video playing), i consume about 1 MB/min.
cor-el
  • Top 10 Contributor
  • Moderator
17475 solutions 157940 answers

I'm seeing the auto-play block icon in the location/address bar on the ABC page and not much network activity (only a few byres).

You can look at these prefs on the about:config page to see if these settings work for you.

  • media.autoplay.default = 1 [0=Allowed, 1=Blocked, 2=Prompt]
  • media.autoplay.allow-muted = false
  • media.autoplay.enabled.user-gestures-needed = false

For user-gestures-needed you can try false and true to see what works for you.

You can look at this extension.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

I'm seeing the auto-play block icon in the location/address bar on the ABC page and not much network activity (only a few byres). *http://abcnews.go.com/ You can look at these prefs on the about:config page to see if these settings work for you. *media.autoplay.default = 1 [0=Allowed, 1=Blocked, 2=Prompt] *media.autoplay.allow-muted = false *media.autoplay.enabled.user-gestures-needed = false For user-gestures-needed you can try false and true to see what works for you. You can look at this extension. *Disable HTML5 Autoplay https://addons.mozilla.org/firefox/addon/disable-autoplay/ You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config
cor-el
  • Top 10 Contributor
  • Moderator
17475 solutions 157940 answers

Helpful Reply

Note that if you use content blocking extensions that the builtin Firefox Content Blocking might not work properly.

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Note that if you use content blocking extensions that the builtin Firefox Content Blocking might not work properly. Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems

Question owner

thanks again for the detailed suggestions in the last two replies. i'd already tried all the config settings. turning off mute play stopped all but the live stream issue. i thought the html5 extension was no longer being maintained, but that appears to no longer be the case. anyway, your reminder that i use two third-party content blocking extensions (add-ons?), ublock and adblock, was invaluable. ublock was able to stop the live streams from playing so that open abcnews.go.com or cbsnews.com pages no longer suck up huge amounts of data. problem solved.

thanks again for the detailed suggestions in the last two replies. i'd already tried all the config settings. turning off mute play stopped all but the live stream issue. i thought the html5 extension was no longer being maintained, but that appears to no longer be the case. anyway, your reminder that i use two third-party content blocking extensions (add-ons?), ublock and adblock, was invaluable. ublock was able to stop the live streams from playing so that open abcnews.go.com or cbsnews.com pages no longer suck up huge amounts of data. problem solved.