X
Tap here to go to the mobile version of the site.

Support Forum

Why does my Firefox automatically send me to Yahoo for searches?

Posted

For about a week now, Firefox has automatically sent me to a Yahoo search engine, which regularly reports that it cannot find any links to the inquiry I have made. I switch to Safari and it always finds multiple links to the same search. I do not want Yahoo, nor this problem. How do I prevent it?

For about a week now, Firefox has automatically sent me to a Yahoo search engine, which regularly reports that it cannot find any links to the inquiry I have made. I switch to Safari and it always finds multiple links to the same search. I do not want Yahoo, nor this problem. How do I prevent it?
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

jscher2000
  • Top 10 Contributor
8504 solutions 69465 answers

The usual culprit is an extension. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that mentions search or that you just do not remember installing or why? If in doubt, disable (or remove).

Please feel free to "name names" on bad add-ons!

Any improvement?

Note: After removing the perpetrator, you might also need to update your default search setting. I suspect you're familiar with it, but just in case, this article has the steps: Change your default search settings in Firefox.

The usual culprit is an extension. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either: * Command+Shift+a (Windows: Ctrl+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons * type or paste '''about:addons''' in the address bar and press Enter/Return In the left column of the Add-ons page, click Extensions. Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that mentions search or that you just do not remember installing or why? If in doubt, disable (or remove). ''Please feel free to "name names" on bad add-ons!'' Any improvement? Note: After removing the perpetrator, you might also need to update your default search setting. I suspect you're familiar with it, but just in case, this article has the steps: [[Change your default search settings in Firefox]].
Was this helpful to you? 0
Quote

Question owner

Thanks. Followed that path, found and deleted two Extensions, but Yahoo was not one of them; when I make Firefox the default again, Yahoo showed up again and did the same thing. How can a search engine find nothing about "Vietnam War Macnamara," the random search I made to test it????

Thanks. Followed that path, found and deleted two Extensions, but Yahoo was not one of them; when I make Firefox the default again, Yahoo showed up again and did the same thing. How can a search engine find nothing about "Vietnam War Macnamara," the random search I made to test it????
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8504 solutions 69465 answers

gadams02 said

Thanks. Followed that path, found and deleted two Extensions, but Yahoo was not one of them; when I make Firefox the default again, Yahoo showed up again and did the same thing.

Hmm, what do you mean by making Firefox the default again? The default search engine in Firefox in most of the world is Google. There is no built-in search engine plugin named Firefox, so if you have one, that is very suspicious.

''gadams02 [[#answer-1211451|said]]'' <blockquote> Thanks. Followed that path, found and deleted two Extensions, but Yahoo was not one of them; when I make Firefox the default again, Yahoo showed up again and did the same thing.</blockquote> Hmm, what do you mean by making Firefox the default again? The default search engine in Firefox in most of the world is Google. There is no built-in search engine plugin named Firefox, so if you have one, that is very suspicious.
Was this helpful to you?
Quote

Question owner

I may not understand. I deleted two extensions and then went to preferences in Firefox and made it my default browser. When it boots and opens the page, i put in a search item, at which point it goes to a search page with Yahoo (not Google) at the top, and tells me it cannot find anything on that topic. I would vastly prefer that it goes to Google; how would I change that?

I may not understand. I deleted two extensions and then went to preferences in Firefox and made it my default browser. When it boots and opens the page, i put in a search item, at which point it goes to a search page with Yahoo (not Google) at the top, and tells me it cannot find anything on that topic. I would vastly prefer that it goes to Google; how would I change that?
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8504 solutions 69465 answers

Oh, the default browser setting -- which browser handles links from other apps on your system -- and the default search engine to use in Firefox are separate. You can check here:

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the left column, click Search

Then on the right side, look at the Default Search Engine section.

What is set there as your default search engine, meaning, the site Firefox will use for searches?

Oh, the default ''browser'' setting -- which browser handles links from other apps on your system -- and the default ''search engine'' to use in Firefox are separate. You can check here: * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Windows: "3-bar" menu button (or Tools menu) > Options * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the left column, click '''Search''' Then on the right side, look at the '''Default Search Engine''' section. What is set there as your default search engine, meaning, the site Firefox will use for searches?
Was this helpful to you?
Quote

Question owner

Followed the instructions for Mac. Went to Firefox menu, preferences, search, default search engine (which had no entry), entered Google. Exited, tried to boot Firefox, Yahoo showed up again. Rebooted computer; Yahoo was still the default in Firefox. Any other ideas?

Followed the instructions for Mac. Went to Firefox menu, preferences, search, default search engine (which had no entry), entered Google. Exited, tried to boot Firefox, Yahoo showed up again. Rebooted computer; Yahoo was still the default in Firefox. Any other ideas?
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8504 solutions 69465 answers

First, don't leave the Preferences page. Set Google as the default, then open a new tab and test immediately. What happens at that point?

If the switch occurs when quitting and restarting Firefox, you might need to clear files out of the Firefox program folder. I need to find a different thread to get those steps for Mac.

First, don't leave the Preferences page. Set Google as the default, then open a new tab and test immediately. What happens at that point? If the switch occurs when quitting and restarting Firefox, you might need to clear files out of the Firefox program folder. I need to find a different thread to get those steps for Mac.
Was this helpful to you?
Quote

Question owner

Did that just now, immediately opened a new window; Yahoo still comes up as the search engine though it is mentioned nowhere on the preferences page. Mystery. Thanks for the help so far; clear as mud, but I am a bit smarter.

Did that just now, immediately opened a new window; Yahoo still comes up as the search engine though it is mentioned nowhere on the preferences page. Mystery. Thanks for the help so far; clear as mud, but I am a bit smarter.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8504 solutions 69465 answers

Helpful Reply

I am beginning to wonder if you have an external interception. It's a myth that a Mac can't get malware. Please try this well-regarded scanner/cleaner (free version or free trial version):

https://www.malwarebytes.com/mac/

I am beginning to wonder if you have an external interception. It's a myth that a Mac can't get malware. Please try this well-regarded scanner/cleaner (free version or free trial version): https://www.malwarebytes.com/mac/
Was this helpful to you? 1
Quote

Question owner

I had that on my apps; ran it; no change.

I had that on my apps; ran it; no change.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8504 solutions 69465 answers

Any unusual connection settings? You can check that here:

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

The default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting. "Auto-detect" can lead to a flaky connection. You may want to try "No proxy".

Any difference?


To distinguish a profile problem from a program files problem, could you try:

New Profile Test

This takes about 3 minutes, plus the time to test some searches.

Inside Firefox, type or paste about:profiles in the address bar and press Return to load it.

Click the Create a New Profile button, then click Next. Assign a name like April2019, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Set as default profile button below that profile, then scroll back up and click the Restart normally button. (There are some other buttons, but please ignore them.)

Firefox should exit and then start up using the new profile, which will just look brand new. Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test.

Do searches run on Google in the new profile? If you quit/restart, Firefox should use that new profile again. Better? Worse? Same?

When you are done with the experiment, open the about:profiles page again, click the Set as default profile button for your normal profile, then click the Restart normally button to get back to it.

Any unusual connection settings? You can check that here: * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Windows: "3-bar" menu button (or Tools menu) > Options * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the search box at the top of the page, type ''proxy'' and Firefox should filter to the "Settings" button, which you can click. The default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting. "Auto-detect" can lead to a flaky connection. You may want to try "No proxy". Any difference? ---- To distinguish a profile problem from a program files problem, could you try: '''New Profile Test''' This takes about 3 minutes, plus the time to test some searches. Inside Firefox, type or paste '''about:profiles''' in the address bar and press Return to load it. Click the Create a New Profile button, then click Next. Assign a name like April2019, ignore the option to relocate the profile folder, and click the Finish button. After creating the profile, scroll down to it and click the '''Set as default profile''' button below that profile, then scroll back up and click the '''Restart normally''' button. (There are some other buttons, but please ignore them.) Firefox should exit and then start up using the new profile, which will just look brand new. Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test. Do searches run on Google in the new profile? If you quit/restart, Firefox should use that new profile again. Better? Worse? Same? When you are done with the experiment, open the about:profiles page again, click the '''Set as default profile''' button for your normal profile, then click the '''Restart normally''' button to get back to it.
Was this helpful to you?
Quote

Question owner

haven't done the new profile test. Did the proxy test; tried all of them; no change, still Yahoo. Have not tried the second.

haven't done the new profile test. Did the proxy test; tried all of them; no change, still Yahoo. Have not tried the second.
Was this helpful to you?
Quote
James
  • Top 25 Contributor
  • Moderator
1593 solutions 11222 answers

Firefox from mozilla.org (www.mozilla.org/firefox/all/) no longer comes with Yahoo as one of the search engine defaults for any locale. So that is not the reason.

Firefox as of 57.0 in Nov 2017 was when Mozilla went back to using Google as the default on U.S., Canada, Hong Kong and Taiwan because they needed a option to replace Yahoo in those areas that had Yahoo as default.

https://blog.mozilla.org/blog/2017/11/14/firefox-features-google-as-default-search-provider-in-the-u-s-canada-hong-kong-and-taiwan/

Reasons for moving away from Yahoo is in https://support.mozilla.org/en-US/forums/contributors/712925

So you have a Yahoo search (is it even the real yahoo search) hijacking your searches on google search? you likely have an Extension in Firefox or some malware on your system.

Some ISP's in past at least did so if you say mistyped a url it may do a search with their own search engine option page which made use of yahoo, google or something else. In this case they often have a opt-out option.

Firefox from mozilla.org (www.mozilla.org/firefox/all/) no longer comes with Yahoo as one of the search engine defaults for any locale. So that is not the reason. Firefox as of 57.0 in Nov 2017 was when Mozilla went back to using Google as the default on U.S., Canada, Hong Kong and Taiwan because they needed a option to replace Yahoo in those areas that had Yahoo as default. https://blog.mozilla.org/blog/2017/11/14/firefox-features-google-as-default-search-provider-in-the-u-s-canada-hong-kong-and-taiwan/ Reasons for moving away from Yahoo is in https://support.mozilla.org/en-US/forums/contributors/712925 So you have a Yahoo search (is it even the real yahoo search) hijacking your searches on google search? you likely have an Extension in Firefox or some malware on your system. Some ISP's in past at least did so if you say mistyped a url it may do a search with their own search engine option page which made use of yahoo, google or something else. In this case they often have a opt-out option.

Modified by James

Was this helpful to you?
Quote

Question owner

Seems to me my best bet at this point is to uninstall and re-download and install Firefox and see if it changes anything.

Seems to me my best bet at this point is to uninstall and re-download and install Firefox and see if it changes anything.
Was this helpful to you?
Quote

Question owner

I uninstalled, emptied History and Cache, trashed it all, emptied the trash, re-downloaded Firefox, installed it, and, guess what, it still comes up Yahoo. No idea what to do.

I uninstalled, emptied History and Cache, trashed it all, emptied the trash, re-downloaded Firefox, installed it, and, guess what, it still comes up Yahoo. No idea what to do.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8504 solutions 69465 answers

Could you check the following location, which allows files to override normal Firefox behavior:

/Applications/Firefox.app/Contents/Resources/defaults/pref

A file named channel-prefs.js is normal here. Any other file in this folder is suspicious if you do not remember creating it yourself. Remove any such files to a neutral location for further analysis at your leisure.

Could you check the following location, which allows files to override normal Firefox behavior: /Applications/Firefox.app/Contents/Resources/defaults/pref A file named '''channel-prefs.js''' is normal here. '''Any other file''' in this folder is suspicious if you do not remember creating it yourself. Remove any such files to a neutral location for further analysis at your leisure.
Was this helpful to you?
Quote

Question owner

Where do I find that location? Through Finder to Apps? How do I search it?

Where do I find that location? Through Finder to Apps? How do I search it?
Was this helpful to you?
Quote

Question owner

Suddenly, on my third download of Firefox, it started defaulting to Google as the search engine. I have no idea why that suddenly worked, but for now, the problem seems to be gone. Thanks for your help.

Suddenly, on my third download of Firefox, it started defaulting to Google as the search engine. I have no idea why that suddenly worked, but for now, the problem seems to be gone. Thanks for your help.
Was this helpful to you?
Quote
Thulerose 0 solutions 2 answers

I'm having all those problems, too. It's really frustrating.

I'm having all those problems, too. It's really frustrating.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8504 solutions 69465 answers

Hi Thulerose, which problem(s) do you have:

(A) A Yahoo page displays as your startup page and in new windows (Command+N).

Please check your home page: How to set the home page. If the Preferences page mentions that an extension or policies control some settings, we can suggest steps to research that.

Also, please scrutinize your extensions (steps earlier in this thread).

(B) When you search using the address bar, you get results on Yahoo instead of the site you want to use.

Please check your default search engine settings: Change your default search settings in Firefox. If the Preferences page mentions that an extension or policies control some settings, we can suggest steps to research that.

Also, please scrutinize your extensions (steps earlier in this thread) and scan for malware, for example, with https://www.malwarebytes.com/mac/.

(C) Something else?

Hi Thulerose, which problem(s) do you have: (A) A Yahoo page displays as your startup page and in new windows (Command+N). Please check your home page: [[How to set the home page]]. If the Preferences page mentions that an extension or policies control some settings, we can suggest steps to research that. Also, please scrutinize your extensions (steps [https://support.mozilla.org/questions/1255418#answer-1211441 earlier in this thread]). (B) When you search using the address bar, you get results on Yahoo instead of the site you want to use. Please check your default search engine settings: [[Change your default search settings in Firefox]]. If the Preferences page mentions that an extension or policies control some settings, we can suggest steps to research that. Also, please scrutinize your extensions (steps [https://support.mozilla.org/questions/1255418#answer-1211441 earlier in this thread]) and scan for malware, for example, with [https://www.malwarebytes.com/mac/]. (C) Something else?
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.