X
Tap here to go to the mobile version of the site.

Support Forum

firefox 'Screenshot' feature - strange char showing on copy

Posted

I am using Firefox 'Screenshot' feature instead of 3rd party tool having discovered it, it is very handy however I am getting funny chars in the input boxes (whether clipboard or save as PNG). They look like dashes and dots or partial chars. I have attached an example.

Thank you

I am using Firefox 'Screenshot' feature instead of 3rd party tool having discovered it, it is very handy however I am getting funny chars in the input boxes (whether clipboard or save as PNG). They look like dashes and dots or partial chars. I have attached an example. Thank you
Attached screenshots
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

FredMcD
  • Top 10 Contributor
4119 solutions 57510 answers

Are these what you are talking about? Those settings can be changed via a dropdown menu.

If you look at the entries without, those are text fields.

Are these what you are talking about? Those settings can be changed via a dropdown menu. If you look at the entries without, those are text fields.
Was this helpful to you? 0
Quote

Question owner

we are not on the same page... look at the quality of the background image.

we are not on the same page... look at the quality of the background image.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4119 solutions 57510 answers

Is this what you mean?

Is this what you mean?
Was this helpful to you?
Quote

Question owner

Yes! these marks are all over the place, I have included a blow-up to help you along.

Yes! these marks are all over the place, I have included a blow-up to help you along.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4119 solutions 57510 answers

Is this on many pages, some, a few?

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Is this on many pages, some, a few? [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17183 solutions 155285 answers

A screenshot is created on canvas that might be white by default.

I assume that the artifacts you see are caused by not all the pixels are getting painted for some reason. This could be a problem with using a dark theme.

A screenshot is created on canvas that might be white by default. I assume that the artifacts you see are caused by not all the pixels are getting painted for some reason. This could be a problem with using a dark theme.
Was this helpful to you? 0
Quote

Question owner

if i use any other snipping tool I don't have this problem, there is something not right with firefox built in screenshot feature that is picking up graphic 'noise' in the background. I would hope that Mozilla as the author could address this... otherwise I'll just use another product.

if i use any other snipping tool I don't have this problem, there is something not right with firefox built in screenshot feature that is picking up graphic 'noise' in the background. I would hope that Mozilla as the author could address this... otherwise I'll just use another product.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8432 solutions 68774 answers

Hmm, when I screenshot this page, which has a large black area at the bottom, I don't get any spots (Windows 10, in case it matters). Is the problem specific to form fields? Could you share the link to that page for others to try out, or a publicly accessible page that exhibits the same problem?

Edit:

I injected the following rule into a simple form page using the Style Editor, and the screenshot was clean, so there must be something more to it than simply white text on a black background.

  input[type="text"], textarea, select {
    color: white;
    background-color: black;
    min-width: 300px;
  }
Hmm, when I screenshot ''this'' page, which has a large black area at the bottom, I don't get any spots (Windows 10, in case it matters). Is the problem specific to form fields? Could you share the link to that page for others to try out, or a publicly accessible page that exhibits the same problem? ''Edit:'' I injected the following rule into a simple form page using the [https://developer.mozilla.org/docs/Tools/Style_Editor Style Editor], and the screenshot was clean, so there must be something more to it than simply white text on a black background. <pre> input[type="text"], textarea, select { color: white; background-color: black; min-width: 300px; } </pre>

Modified by jscher2000

Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17183 solutions 155285 answers

Helpful Reply

Are you zooming the page or use a custom DPI setting in case that matters? You can also try to disable Firefox hardware acceleration to see if that has effect.

Are you zooming the page or use a custom DPI setting in case that matters? You can also try to disable Firefox hardware acceleration to see if that has effect.
Was this helpful to you? 1
Quote
FredMcD
  • Top 10 Contributor
4119 solutions 57510 answers

I prefer using Windows Snapshot program. https://www.bing.com/search?q=windows+10+screenshot

I prefer using Windows Snapshot program. https://www.bing.com/search?q=windows+10+screenshot
Was this helpful to you?
Quote

Question owner

I use it all the time however it does not support the page 'scrolling' feature... the Firefox tool does and the only reason why I tried using it... i could pay for snagit but if FF does it for free..

I use it all the time however it does not support the page 'scrolling' feature... the Firefox tool does and the only reason why I tried using it... i could pay for snagit but if FF does it for free..
Was this helpful to you?
Quote

Question owner

You can also try to disable Firefox hardware acceleration to see if that has effect.

    • Yes, disabling hardware acceleration solved the problem! not sure what negative effect it may have on other browser operations but I'll take it...
You can also try to disable Firefox hardware acceleration to see if that has effect. ** Yes, disabling hardware acceleration solved the problem! not sure what negative effect it may have on other browser operations but I'll take it...
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.