Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Fonts blurry with hardware acceleration on (until you click on the blurry text), YouTube videos horizontal lines with hardware acceleration off

  • 8 replies
  • 1 has this problem
  • 15 views
  • Last reply by jscher2000

more options

This is really noticeable on some forums. The edge of text font turns slightly blurry (so the text camouflages a bit into the background), and when you click on the text, it disappears magically?

If I disable hardware aceleration to fix it, YouTube videos have horizontal lines in dark content, so it's not a solution.

All Replies (8)

more options

Here is example of text before and after click

more options

I can't think of a reason for ordinary text to change appearance when you click it. (Links and buttons might.)

Any idea what font that is? One way to check is to use the Page Inspector: right-click the problem text and choose Inspect Element. Firefox will open a new section at the bottom of the tab with an HTML "tree" diagram of the page, and the clicked element should be highlighted. On the right side, there are a set of panels, one of which is Fonts. If you don't see a little Fonts tab after Layout Computed Changes, click the downward pointing triangle at the end of the row to show that one.

more options

jscher2000 said

I can't think of a reason for ordinary text to change appearance when you click it. (Links and buttons might.) Any idea what font that is? One way to check is to use the Page Inspector: right-click the problem text and choose Inspect Element. Firefox will open a new section at the bottom of the tab with an HTML "tree" diagram of the page, and the clicked element should be highlighted. On the right side, there are a set of panels, one of which is Fonts. If you don't see a little Fonts tab after Layout Computed Changes, click the downward pointing triangle at the end of the row to show that one.

Verdana. It's not always in this blurry mode, but every now and then the text is blurry and I'll have to click it again.

more options

Hmm, it's strange, Verdana is on the list of fonts that are not supposed to be anti-aliased (smoothed) according to the below setting. So I'm not sure what is happening there.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste CLEART and pause while the list is filtered

Usually Verdana is listed in listed in the value of the gfx.font_rendering.cleartype_params.force_gdi_classic_for_families so Verdana shouldn't be smoothed, and therefore disabling hardware acceleration shouldn't affect it.

Maybe this has changed in a way I don't understand. ???

more options

jscher2000 said

Hmm, it's strange, Verdana is on the list of fonts that are not supposed to be anti-aliased (smoothed) according to the below setting. So I'm not sure what is happening there. (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste CLEART and pause while the list is filtered Usually Verdana is listed in listed in the value of the gfx.font_rendering.cleartype_params.force_gdi_classic_for_families so Verdana shouldn't be smoothed, and therefore disabling hardware acceleration shouldn't affect it. Maybe this has changed in a way I don't understand. ???

Yep, Verdana was listed there.

But obviously hardware acceleration is doing something, if disabling it makes this behaviour go away completely.

more options

Is there any way as a workaround solution to get rid of the horizontal lines in videos, when hardware acceleration is off?

more options

Hmm, so no info about this? I'm using a 1440p display by the way.

I've been on Chrome but they're removing adblocks so Firefox would be the natural option, if the text worked without having to click the texts...

more options

Hi Leopardi, although it's not really the relevant point, Chrome didn't announce that they are completely disabling all ad blocking extensions. They plan to take away a popular method extensions use to block web requests, and provide add-on authors a less flexible way to set up a more limited number of filters. That probably that will make the extensions less effective, but what you see may vary depending on the sites you browse and which features of the extension you use.

I'm using a 1440p display by the way.

That might be related to the problem, if Firefox isn't fully compatible with your graphics display driver software at that resolution. Is there a page where the problem occurs pretty reliably? If it's easy to reproduce, you could consider filing a bug at https://bugzilla.mozilla.org/ .

To rule out settings/add-ons as a factor, you may want to confirm using:

New Profile Test

This takes about 3 minutes, plus the time to test your problem site(s).

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the "Create a New Profile" button, then click Next. Assign a name like June2019, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Launch profile in new browser button.

Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test.

Does the problem text display any better in the new profile?

When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile. (June2019 will remain available for future testing if needed during bug diagnosis.)