X
Tap here to go to the mobile version of the site.

Support Forum

Do not track signal causing some videos not to load.

Posted

EDIT: I'VE CHANGED THE SUBJECT LINE TO BETTER REFLECT THE REAL ISSUE WHICH I NOW BELIEVE I MAY HAVE MISUNDERSTOOD INITIALLY. SUBJECT CHANGED IN THE HOPES THAT SEARCH ENGINES WILL FIND IT WITH RELEVANCE.

FF 66.0.2 64 bit Windows 10

PROBLEM WITH CHANGING THE "SEND WEBSITES DO NOT TRACK SIGNAL."

I realize that most FF settings do not require a restart of FF to take effect but it seems that when changing the "Send websites a 'do not track' signal from "Always" to "Only when Firefox is set to block known trackers," the effect of doing so is not apparent until FF is shut down and restarted.

The issue is that no prompt is given after making this change. There should be a prompt.

Recently I have been unable to load videos on a site I visit regularly. After a lot of messing around with the security settings I finally discovered it was sending this do not track signal that was causing the issue. However it took a ridiculous amount of time to narrow the issue down to that one setting since FF was not giving me any indication the browser should be restarted after making the change. It was only my suspicion that led me to try changing the setting and restarting that i finally discovered how to fix the issue.

There is NO issue with switching the setting back to "Always." That takes effect immediately without restarting (videos instantly become unplayable). When switching the setting back to the second setting, the videos don't become playable again until FF is restarted.

IMO, there should be a prompt when choosing the "Only when Firefox is set to block known trackers" setting to restart FF so the setting actually takes effect,

OR, fix the issue so FF doesn't have to be restarted.

Either fix would be better than leaving users in the dark.

EDIT: I'VE CHANGED THE SUBJECT LINE TO BETTER REFLECT THE REAL ISSUE WHICH I NOW BELIEVE I MAY HAVE MISUNDERSTOOD INITIALLY. SUBJECT CHANGED IN THE HOPES THAT SEARCH ENGINES WILL FIND IT WITH RELEVANCE. FF 66.0.2 64 bit Windows 10 PROBLEM WITH CHANGING THE "SEND WEBSITES DO NOT TRACK SIGNAL." I realize that most FF settings do not require a restart of FF to take effect but it seems that when changing the "Send websites a 'do not track' signal from "Always" to "Only when Firefox is set to block known trackers," the effect of doing so is not apparent until FF is shut down and restarted. The issue is that no prompt is given after making this change. There should be a prompt. Recently I have been unable to load videos on a site I visit regularly. After a lot of messing around with the security settings I finally discovered it was sending this do not track signal that was causing the issue. However it took a ridiculous amount of time to narrow the issue down to that one setting since FF was not giving me any indication the browser should be restarted after making the change. It was only my suspicion that led me to try changing the setting and restarting that i finally discovered how to fix the issue. There is NO issue with switching the setting back to "Always." That takes effect immediately without restarting (videos instantly become unplayable). When switching the setting back to the second setting, the videos don't become playable again until FF is restarted. IMO, there should be a prompt when choosing the "Only when Firefox is set to block known trackers" setting to restart FF so the setting actually takes effect, OR, fix the issue so FF doesn't have to be restarted. Either fix would be better than leaving users in the dark.

Modified by RiversideRepeatIII

Chosen solution

Note that the only effect of do-not-track is to add the DNT=1 header to the HTTP request headers. It is up to the server to do anything with this DNT request header. If I toggle this setting in Options/Preferences and reload the page then I immediately see the DNT header appear and omitted in the Network Monitor.

Is that different for you?

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

WestEnd
  • Top 25 Contributor
61 solutions 5340 answers

So what site is that is having issues with the tracker settings?

So what site is that is having issues with the tracker settings?
Was this helpful to you? 0
Quote

Question owner

WestEnd said

So what site is that is having issues with the tracker settings?

Which site is not really relevant to the specific issue I’m raising. I’m saying the setting doesn’t actually change until FF is restarted and the problem is that FF gives no way to know restart is necessary.

FF should either:

1) Prompt for a restart when the change is made, or... 2) Fix so restart is no longer necessary.

''WestEnd [[#answer-1209565|said]]'' <blockquote> So what site is that is having issues with the tracker settings? </blockquote> Which site is not really relevant to the specific issue I’m raising. I’m saying the setting doesn’t actually change until FF is restarted and the problem is that FF gives no way to know restart is necessary. FF should either: 1) Prompt for a restart when the change is made, or... 2) Fix so restart is no longer necessary.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8568 solutions 70054 answers

Helpful Reply

Are you sure a restart is required?

If I open the Options page in one tab and this test page is a second tab:

https://www.jeffersonscher.com/res/jstest.php

The test page will show dnt: 1 when the page receives a Do Not Track signal, and it will not show that header when the page does not receive a Do Not Track signal.

It seems that as soon as I change the setting I can reload the page and the headers reflect my current setting.


Perhaps what happened on the problem site was that the site had stored the Do Not Track signal in a cookie and it didn't update the cookie until you restarted Firefox?? If you want to test that on the problem site, you could clear its cookies after changing the setting. Here's how:

While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "Clear Cookies and Site Data"
  • (menu bar) Tools > Page Info > Security > "Clear Cookies and Site Data"

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Alternately, you can use the Storage Inspector tool. Shift+F9 will open it in the lower part of the tab. You can right-click any cookie to delete it or all of the site's cookies.

Are you sure a restart is required? If I open the Options page in one tab and this test page is a second tab: https://www.jeffersonscher.com/res/jstest.php The test page will show '''dnt: 1''' when the page receives a Do Not Track signal, and it will not show that header when the page does not receive a Do Not Track signal. It seems that as soon as I change the setting I can reload the page and the headers reflect my current setting. ---- Perhaps what happened on the problem site was that the site had stored the Do Not Track signal in a cookie and it didn't update the cookie until you restarted Firefox?? If you want to test that on the problem site, you could clear its cookies after changing the setting. Here's how: While viewing a page on the site, try either: * right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "Clear Cookies and Site Data" * (menu bar) Tools > Page Info > Security > "Clear Cookies and Site Data" In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites. Alternately, you can use the Storage Inspector tool. Shift+F9 will open it in the lower part of the tab. You can right-click any cookie to delete it or all of the site's cookies.
Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17334 solutions 156713 answers

Chosen Solution

Note that the only effect of do-not-track is to add the DNT=1 header to the HTTP request headers. It is up to the server to do anything with this DNT request header. If I toggle this setting in Options/Preferences and reload the page then I immediately see the DNT header appear and omitted in the Network Monitor.

Is that different for you?

Note that the only effect of do-not-track is to add the DNT=1 header to the HTTP request headers. It is up to the server to do anything with this DNT request header. If I toggle this setting in Options/Preferences and reload the page then I immediately see the DNT header appear and omitted in the Network Monitor. *https://developer.mozilla.org/en-US/Tools/Network_Monitor Is that different for you?
Was this helpful to you? 1
Quote

Question owner

I'm thinking it's a cookie thing too in this case. And yes, it does require a restart before the issue resolves. Refresh doesn't work. Since I have no reason to store cookies for this site I'll try redoing the setting and deleting the cookies and see if that is what's causing it. If so, I may get in touch with the site admins. If not, I'm not sure.

I'm thinking it's a cookie thing too in this case. And yes, it does require a restart before the issue resolves. Refresh doesn't work. Since I have no reason to store cookies for this site I'll try redoing the setting and deleting the cookies and see if that is what's causing it. If so, I may get in touch with the site admins. If not, I'm not sure.
Was this helpful to you?
Quote

Question owner

Well this just gets more curious. The site doesn't use cookies at all so that's not it. It's definitely the DNT setting that's causing the issue. Shut it off and videos play. Turn it on and they don't. Period.

When DNT is on the page returns DNT = 1 When DNT is off, page returns no DNT setting at all.

It's got to be triggering something on the server side that won't reset until a full disconnect occurs. I guess it's time to contact the web site.

Thanks.

Well this just gets more curious. The site doesn't use cookies at all so that's not it. It's definitely the DNT setting that's causing the issue. Shut it off and videos play. Turn it on and they don't. Period. When DNT is on the page returns DNT = 1 When DNT is off, page returns no DNT setting at all. It's got to be triggering something on the server side that won't reset until a full disconnect occurs. I guess it's time to contact the web site. Thanks.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17334 solutions 156713 answers

Note that Firefox shows the the shield icon at the left end of the location/address bar in case content is blocked by Content Blocking.

Note that Firefox shows the the shield icon at the left end of the location/address bar in case content is blocked by Content Blocking.
Was this helpful to you?
Quote

Question owner

cor-el said

Note that Firefox shows the the shield icon at the left end of the location/address bar in case content is blocked by Content Blocking.

Yes. No content is reported as blocked. I'm certain it's a server-side issue in this case.

''cor-el [[#answer-1209607|said]]'' <blockquote> Note that Firefox shows the the shield icon at the left end of the location/address bar in case content is blocked by Content Blocking. </blockquote> Yes. No content is reported as blocked. I'm certain it's a server-side issue in this case.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.